Forum Replies Created

Viewing 30 posts - 1 through 30 (of 40 total)
  • Author
    Posts
  • in reply to: Slider bleibt stehen #1232906
    This reply has been marked as private.
    in reply to: Slider bleibt stehen #1232544
    This reply has been marked as private.
    in reply to: after update to WP 5.4 custom fields editing #1200821

    Please inform the development team that this bug needs to be resolved in the next update of Enfold. It is not something we can fix in the child theme and it is not caused by customization on our end. The issue is that the developer forgot to include the custom fields in his thoughts. Custom fields is a standard feature. The patch was recommended about a year ago and was supposed to be merged into the next update of Enfold. Luckily, Olaf remembered now.
    Kind regards
    Wolfgang

    in reply to: after update to WP 5.4 custom fields editing #1200791

    Hello, please change the existing code (register-portfolio.php, raw 42) with our new code that contains the custom field ‘supports’ => array(‘title’,’thumbnail’,’excerpt’,’editor’,’comments’, ‘revisions’,’custom-fields’ ),
    Every time when Enfold makes an update we have to change this code by hand. Please make sure that your development department will change the code automatically with every new update.
    Thank you and best regards Olaf

    in reply to: Enfold Masonry Filter Recursive #1188572

    Hi Ismael,
    You are the real MASTER. Thank you for that function. It works very well.
    Have a nice day.
    Wolfgang

    in reply to: Support #1186862
    This reply has been marked as private.
    in reply to: Use Accordion element to create FAQ structured data #1167849

    Thank you Victoria for your reference to another discussion thread. It does not fit. Our desire is to use the ENFOLD Accordion element, which is well designed and shows well on PC and mobile sites and follows the ENFOLD Theme. May I repeat the original question?
    Do you have a suggestion on how to use the ENFOLD Accordion element to create nice structured data that is also displayed well within our template design? I know, there are additional plug-ins, but their design does not integrate well with ENFOLD and then we might also have issues with WPML and YOAST.
    We would prefer to not add another plugin but use ENFOLD elements.

    in reply to: Use Accordion element to create FAQ structured data #1164386

    How can I explain it? Maybe this is helpful for you to understand. Structured data is added directly to a page’s HTML markup. Search engines use structured data to generate rich snippets, which are small pieces of information that will then appear in search results. Google has written a lot about it. https://developers.google.com/search/docs/guides/intro-structured-data But this is a language I don’t understand.

    We have it implemented on our website on one page with a plugin. But it is outside the ENFOLD template and therefore ugly. Look at https://www.m24o.net/product/music-trips-italy/ at the bottom of the page. It is a FAQ structure. When you search in google with “m24o music trip italy” then you see how google shows the page. Nice. It helps to bring us up in the ranking and it covers a lot of real estate in the search display.

    It would be nice if the Accordion element had the code to create this data structure. I think you could make a lot of people happy with that option.

    Have you worked it out? Compatibility with YOAST would be a really good feature. It used to be compatible, but it was kind of lost. With YOAST being one of the best SEO plugins around, the compatibility is kind of essential.
    We see issues that YOAST does not see links that are embedded in buttons, button row, and single buttons. YOAST has published what Kriesi (and other theme builders) need to do to help YOAST to see the content correctly. Would you please get into this?

    in reply to: Portfolio Grid and Portfolio Masonry #1160304

    Thank you, Ismael
    3) Patch that makes the Portfolio Grid and Masonry work with WPML
    Compatibility is a big issue for Theme users. We want to be able to concentrate on content, good design and SEO to drive our business. Knowing that the Theme is compatible with WPML is a good thing and will help everyone. We will spread the word. Having said that, we expect that the issues we debugged so nicely together should really be resolved in the next update of the theme.
    See my note above at the end of the patch code section “It works, however, the selected categories are not visible in the AVIA editor in the translated page. This is something you should fix. It is a programming error in the ENFOLD template.” This is an issue we have not been able to fix, but the developer for sure knows the trick.

    in reply to: Yoast SEO compatibility #1160295

    Even Microsoft Office is now compatible with Apple. Well, it took years.
    It appears to me that there is some reluctance to make it work well again. Why you guys at Kriesi and YOAST are so stubborn to work with each other? Kriesi is not going to implement SEO features in the theme and YOAST is not going to build themes. So you complement each other and website builders would like to use the best theme with the best SEO plugin. YOAST already published what needs to be done in the theme to make it work again.
    Here is what Yoast says Plugin Compatibility with any Visual Page Builder. at “kb.yoast.com/kb/is-the-plugin-compatible-with-xyz-visual-page-builder/”
    When you follow the links on that page you get to Github page that shows what Theme Builders need to do. I think your developers should look into it and marketing guys will be happy to say then that YOAST and ENFOLD are really compatible. Add WPML for multi-lingual sites to the family and we have a winning team.
    Please get to work. It has been a year now that this topic is open in various forums. We will all appreciate the effort and pay our subscription fees happily.

    • This reply was modified 8 months, 2 weeks ago by  milano24ore.
    • This reply was modified 8 months, 2 weeks ago by  milano24ore.
    in reply to: Portfolio Grid and Portfolio Masonry #1158158
    This reply has been marked as private.
    in reply to: Portfolio Grid and Portfolio Masonry #1158139

    Hi Ismael,
    2) we tested the suggested modification, but it does not give a useful functionality. Yes, it displays all portfolio categories in the portfolio grid, but selecting then one of them will not deliver the expected result. In our example, we display the travel products for each city. In the initial load of the page, we show the first 4 product thumbnails (portfolio pages). The headline shows now (after the modification) all categories. What I would expect is that clicking on another category (city) I would see the product thumbnails of that category. But that’s not the case. It would only show them if they had been on the page already. So that is is useless. This feature requires more development work. I will put a feature request, Not something to be solved in the support area.
    3) WPML team has delivered a patch that makes the Portfolio Grid and Masonry settings translatable. The patch should be integrated in the next update from you guys. It is 90% perfect.
    The issue is coming from this file \enfold\config-templatebuilder\avia-shortcodes\portfolio\portfolio.php.
    Find this line:
    $display_cats = is_array($params[‘categories’]) ? $params[‘categories’] : array_filter(explode(‘,’,$params[‘categories’]));
    and add this after it:
    if (defined(‘ICL_SITEPRESS_VERSION’)) {
    $display_cats_wpml = array();
    foreach ($display_cats as $display_cat) {
    $display_cat = apply_filters(‘wpml_object_id’, $display_cat, ‘portfolio_entries’, true);
    $display_cats_wpml [] = $display_cat;
    }
    $display_cats = $display_cats_wpml;
    }
    It works, however, the selected categories are not visible in the AVIA editor in the translated page. This is something you should fix. It is a programming error in the ENFOLD template. Easy to test as well in your own system. Use ENFOLD. Create portfolio categories. Translate them using WPML. Create portfolio items and assign them to portfolio categories. Create a page with Masonry and Portfolio grid and select some Portfolio categories to be shown on the page. Translate the page with WPML and see that the category selection is lost in the front end and the back end. After the above patch is applied, the portfolio category is only lost in the back end. Front end works.
    I give you access to our clone with the test page. Please check it out.

    in reply to: Portfolio Grid and Portfolio Masonry #1156875

    Hi Ismael,
    1. thank you for helping to remove the word “ALL”. All good.
    2. to show the “empty” categories would be much better. I guess that is a feature request.
    3. of course, the categories are translated as you can see in the test page in the masonry. next to it. same categories. the portfolio grid loses the categories altogether and masonry loses them only in the backend. Something to be fixed by the compatibility group.

    Kind regards
    Wolfgang

    in reply to: Portfolio Grid and Portfolio Masonry #1155997

    Thank you Ismael for shedding some light on this. It does not solve all the issues I reported.

    In fact, we had this “.av-current-sort-title {display: none;}” in our customized CSS. I took it out. Now the “…and currently active category” makes sense. No need to customize the CSS. We can just change the settings. We probably just wanted to eliminate the word “ALL”.
    It would be good to show all category names that are selected instead of only showing the ones that are currently displayed. You can see how useful that would be when you look at the test page I created. As you can see, I limited the initial load to 6 items only. However, there are about 25. If the headline would show all used categories then one could quickly select the category of interest. That would be a useful feature to add. Clicking the “All” should display all. That is what you would expect as a user.

    A big issue is that after translation using WPML, the recommended plugin, the translated pages do not look the same. Please kindly compare the EN with DE to see yourself. The Portfolio Grid has lost the category selection in the view and in the editor. The Masonry lost the categories in the editor view only. This is a problem that might need to be solved together with the WPML team.
    Too bad, you do not allow screenshots to be attached.

    Thank you again for your kind support.

    in reply to: Cookie Consent styling not working in 4.6.3.1 #1145764

    Done!

    in reply to: TAB Section animated #1144944

    Of course, I was not happy that I cannot get what I want easily. But your explanation makes it clear why. A bit disappointing still. We thought there is a mechanism to load the bottom part of the page later when the user scrolls down. Or in case of the TAB Section, load the TAB sheet when it is actually needed. That would increase performance for everyone.
    Anyway, thank you for getting back on this.
    Kind regards
    Wolfgang

    in reply to: TAB Section animated #1144135

    The function exists e.g. in the masonry element. All it takes is to share that code segment with us and everyone else that needs this feature. Or even better, add the function to the library.

    But all you are telling us is: “sorry to hear that you are not able to help yourself. hire someone who is smarter than you.”

    Oh happy day.

    You can’t always get what you want, but …
    There is no easy solution. If you can point us to the module that creates the overlay for the featured image then we might have a chance to do something. But we find it impossible to find that code segment on our own. How does one go about to find that module?
    Thank you for your help
    Wolfgang

    in reply to: Problem with SEO Yoast and Enfold theme. #1118717

    ENFOLD says: You are running the latest version! (4.5.7), WordPress and Yoast as well on current version. Same problem as described above a year ago.
    We are using the AVIA editor to build our pages.

    • Yoast does not see the keyphrase if it is brought onto the page with a shortcode.
    • Yoast does not see an outbound link if it is inside a button row element
    • Yoast does not see the inbound links that are on the page as a masonry of portfolio entries
    • Yoast flags problem areas on the page and has a feature to highlight the problems with “eye” icon. It does not work.
    • Yoast says the paragraph has more than 300 words without a sub header, because it does not see the page structure
    • … I am sure thorough testing will reveal more issues

    Is there any plan at Kriesi to make the two dance better together? Will it be after the next update? Does Kriesi recommend a different plugin for SEO work?

    in reply to: Load only used elements (recommended) #1107746
    This reply has been marked as private.
    in reply to: Load only used elements (recommended) #1107679

    Mahalo.
    You are a genius.
    Thank you.

    This reply has been marked as private.

    The login link is below. Are you suggesting that the described effect is an error that might be specific to our instance of Enfold? Please let us know what you find out.

    in reply to: Load only used elements (recommended) #1106617

    Thank you for your interest in resolving this issue that apparently bothers others as well.
    The site is life. We are running it with a manual selection of the elements to be loaded. If you switch to the “recommended” setting then you see the error in the main menu on the homepage. Please see yourself and then revert the change. Login to dashboard is below.

    I created a new topic for Performance recommended settings Please check it out. I will provide login details there if you like.

    Hi Ismael, thank you for your note. I just created a new topic #1104770 for that remaining issue. Please check.

    in reply to: Phone icon requires 'Always load all elements' #1104490

    We have a similar issue. The recommended solution to “Always load all elements” is not a good solution. It slows down the website no matter what other tricks you use afterwords to speed it up again. We should be able to find the root cause. The issue is for both of us that we created custom icons and use these as a font. The custom icons display only when we select “Always load all elements”. To our surprise, this “error” appeared after we copied our website to a new server. On the old server we were able to see the icons with the settings “Load only used elements”. On the new server, same website, the error message came suggesting to change the Performance Settings. Same website. Difference was the php version. Old 7.0 and on the new 7.3 No idea if that makes a difference in the functionality. We would be interested in a solution. Loading all Elements is too slow.

    we are surprised to see that we have not received any support for our website project yet. a dead website can ruin the business. please kindly suggest a different support model that works. One week without support is too long a wait.
    in the meantime we found that we probably had a database error that was invisible through normal tools. we made a local copy of the database and connected that local copy with the wordpress engine. that worked. all errors disappeared. Except one.
    The remaining issue is that Enfold requires that we select in the performance settings > always load all template builder elements. This makes the website slow. We will open a new ticket for that if we are unable to resolve this on our own.

    Hi Victoria, we updated the test page to show the problem clearly. Actually, there are three problems. Maybe related.
    1. Enfold Performance Settings. We selected to always load all template builder elements. The recommended settings to load only what is used does not work. The pages are full of error messages then.
    2. The AVIA elements to display portfolio items. Masonry and Magazine do not work. Masonry fetches a page (itself) instead of the Portfolio Items. Portfolio Grid fetches the correct Portfolio Items. Magazine shows only the Portfolio Categories, but not the Items.
    3. Blog Posts do not show if we select the Grid display format. They do show in the other settings.
    We updated the test page to show the issues clearly. Waiting for you to use the login credentials and have a look. Please help us to understand what went wrong.

Viewing 30 posts - 1 through 30 (of 40 total)