Tagged: 

Viewing 30 posts - 1 through 30 (of 58 total)
  • Author
    Posts
  • #771850

    Hi Team Kriesi,

    I’m testing the new Woocommerce 3.0 on a couple of staging sites.

    I haven’t conducted loads of testing yet but one issue has immediately appeared that you’ll probably want to be aware of – no product images!

    The woocommerce-product-gallery class has inline opacity: 0. Presumably there’s some js that’s supposed to trigger the transition. At the moment it remains at 0.

    There’s also the message:

    <figure class=”woocommerce-product-gallery__wrapper”>
    <br>
    <b>Warning</b>: Missing argument 3 for avia_woocommerce_gallery_thumbnail_description() in <b>/wp-content/themes/enfold/config-woocommerce/config.php</b> on line <b>1360</b><br>
    <br>
    <b>Warning</b>: Missing argument 4 for avia_woocommerce_gallery_thumbnail_description() in <b>/wp-content/themes/enfold/config-woocommerce/config.php</b> on line <b>1360</b><br>

    Is this something you’re aware of?

    #771853

    Hi Joe!

    Thanks for the heads up!

    I just replied to a user who reported that issue and suggested following CSS

    div.product div.images {
        opacity: 1!important;
    }

    We will report it to our devs :)

    Best regards,
    Yigit

    #771857

    That will force the images to display, and also the error messages.

    Thanks, I look forward to an update.

    #771873
    #771875

    Got the same problem here however the code Yigit has provides resolves my problems!

    #771959

    Hey!

    Glad the code fixes the issue. We have reported the issue to our devs :)

    Cheers!
    Yigit

    #772460

    Hello,
    exactly where must I put the code ?

    #772464

    Hey!

    Please go to Enfold theme options > General Styling tab and add the code to Quick CSS field at the bottom of the tab

    Best regards,
    Yigit

    #772474

    Hi Yigit,

    Your CSS fixed my gallery issues. Thanks!

    However, my product categories have inherited a large white line above the title/breadcrumb bar and the text has been transformed to white.

    Can you help?

    Many Thanks
    Adrian

    #772475

    Hey,

    it works, thank you.

    #772480

    Hey Yigit, thats not a solution, because image is to much blurry. Please update.

    Adrian

    #772483

    I had blurry images.
    I cleared total cache and my browser cache and it fixed it.

    #772510

    Actually blurry images are back and they are intermittent.
    When I preview the image in light-box the image clears but if I revisit the page it goes blurry again.

    #772528

    This fix is only partial – the image is, as reported “blurry” – it is not loading in the correct size.

    Woocommerce 3.0 changes the image gallery around a bit, adding a zoom feature. Clicking the pic should open in a lightbox. This doesn’t work so well with Enfold (yet).

    #772533

    The image in question is a 120×120 thumbnail being stretched to fill the whole section, hence the blurry!

    Will await a fix on this issue, as its the only one I can find for Enfold & wc 3.0.

    #772535

    So if you can load the “correct” product image size, rather than the thumbnail image, it will be workable.

    #772552

    You might be interested in overloading the product-image.php from WooCommerce 3.0 with the old one from 2.6.14 a s a temporary workaround.

    For those familiar with child themes
    For those NOT familiar with child themes

    #772567

    We are waiting for the php error fix in the woocommerce gallery, thanks for your work!

    #772578

    Is it a woocommerce bug that’s causing the issue then?

    #772647

    If this helps any, when I tested an update the Product Grid gave me a large error in the first area of the site. We reverted back to the previous version of WooCommerce.

    This was the error:
    Notice: id was called
    incorrectly
    . Product properties should not be accessed directly. Please see Debugging in WordPress for more information. (This message was added in version 3.0.) in /home2/shopjade/public_html/wp-includes/functions.php on line 4137
    class=”post-6479 product type-product status-publish has-post-thumbnail product_cat-tops product_cat-featured first instock taxable shipping-taxable purchasable product-type-variable has-default-attributes has-children”>

    Is this related to us using the Product Grid/Product Grid Slider? Img here: https://www.screencast.com/t/Wj9gt22GT9d

    #772683

    Same here, please fix this problem so we can work without any headaches =)

    #772767

    Same here, our webshop is live with blurred images :/

    #773414

    To solve the image display issue please see this posting

    #776368

    Guten Abend, ich habe 4 oder 5 Lizensen von Enfold und war stets sehr zufrieden und nutze es gerne und kaufe es jedes mal neu für 60 Dollar wenn es für einen Kunden in Frage kommt. Hier finde ich aber den Support nicht i. O. Das Release von Woocommerce ist bereits seit 4 Wochen online, die Probleme mit der Galerie bekannt. Mit Version 2.6.14 funktioniert Enfold mit Woocommerce wunderbar, mit 3.0 nicht mehr.
    Der angebotene CSS-Code funktioniert nicht, ob mit oder ohne Austausch der “product-image.php”. Fehlercode bleibt.
    Kann einer der Moderatoren bitte mitteilen wann mit einer Lösung zu rechnen ist? Solange lasse ich Woocommerce auf 2.6 laufen.
    Vielen Dank.

    #776513

    @georg there are several threads about the issue and the only available solution has been posted many times. Kriesi also stated they are working on an update with no ETA.

    #776515

    @mensmaximus, ok. after my post i read a many threads and fixed it. thx

    #776683

    @mensmaximus
    Muchas gracias for your help and solution!

    Best regards,
    Andy

    #780214

    I put in the CSS code and I am still having issues w/ my website in the store.

    It is still showing [Warning: Missing argument 3 for avia_woocommerce_gallery_thumbnail_description() in /home2/blinkit/public_html/wp-content/themes/enfold/config-woocommerce/config.php on line 1360

    Warning: Missing argument 4 for avia_woocommerce_gallery_thumbnail_description() in /home2/blinkit/public_html/wp-content/themes/enfold/config-woocommerce/config.php on line 1360]

    Is there anything else I could do.. I am a total newb.. if anyone can break it down for me that’d be awesome! thank you

    #780307

    Hi theblinkit,

    You can check your Enfold version because is necessary to have the latest WooCommerce and the Enfold too.

    Best regards,
    John Torvik

    #781516

    Thanks for the solution. @mensmaximus.

    Somehow I updated to WooCommerce on one of my Enfold sites and this fix was much easier than rolling back.

    I have a staging Divi site that is in turmoil because of the new WooCommerce 3.0 product image and gallery changes.

    I’ve spoken with one of their lead developers as well as Elegant themes support.

    From what I understand, and I spent well over a day trying to fix this issue… is WooCommerce changed the way the product page images function based on input from users.

    This forced theme developers to add new support and calls for lightbox, zoom and swipe.

    However, it’s up to the theme developer to integrate the new functions accordingly.

    They provided instructions to theme developers a while ago but I don’t feel they did a very good job explaining how theme developers should execute the changes.

    And it appears theme developers dropped the ball in testing and releasing theme updates to accommodate.

    In my case, both Enfold and Divi used lightbox for the featured product and image gallery.

    Then both themes appear to function incorrectly and that’s likely because the theme developers didn’t make the correct function calls and provide the correct styles accordingly.

    Since both themes, and pretty much every WooCommerce site by default, used lightbox…

    Theme developers should have just loaded the new default lightbox js and adapt their previous CSS and styles.

    Then they should have added a theme option to use zoom and swipe that can be turned on by choice.

    The key is this change should be by choice. Completely changing a product page’s user experience with an update is the worst thing you can do to a business because it will affect conversions and sales.

    I blame both WooCommerce and Theme developers like Divi and Enfold.

    And I honestly believe that both WooCommerce and theme developers have little understanding of ecommerce, conversion optimization, sales, or how important these kind of changes are.

Viewing 30 posts - 1 through 30 (of 58 total)

The topic ‘Woocommerce 3.0’ is closed to new replies.