Tagged: 

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #1159092

    I noticed maps do not run in Safari on latest Enfold. My API Geocoding API is on and I tried modified javascript on from the thread below, however I couldn’t make it work.

    In other browsers all is fine.

    What to do?

    Thanks

    #1160067

    Hey MORTULGAAH,

    What is your web site URL?

    Best regards,
    Basilis

    #1160216
    This reply has been marked as private.
    #1161001

    Seeing the same problem here. For example, the header on this page. This appears to be a relatively recent failure: that page was working when I most recently updated it, a week ago. Safari has updated in the intervening time.

    Chrome and Firefox show maps as expected.

    #1161004
    This reply has been marked as private.
    #1161009

    I tried all other browsers, and it works in them, only Safari seems to block this.

    #1161113

    Hi,

    Yea, this happens because Safari does not support it. Generally it is an old browser which is staying a lot behind into the updates.

    Best regards,
    Basilis

    #1161115

    What Safari doesn’t support? I see Google Maps on other sites without issues.
    Also, it worked well before the last update, never had an issue.

    #1161217

    I think I’ve accidentally fixed this issue on my site while debugging a Gravity Forms embed issue, which turned out to be a result of a cookie consent problem: see this thread for details. Applying the fixes in posts #1145865 and #1146123 has sorted both Gravity Forms embed and Google Maps embed, in Safari.

    @basilis, I get that Safari can be troublesome to support, but Safari clearly can support Google Maps embeds. Whether the changes above work around Safari limitations, or fix behaviour revealed by Safari being strict, is perhaps a matter of interpretation.

    #1161591

    Hi,

    Thanks for sharing your findings @jjsanderson, maybe those fixes will work for you as well @mortulgaah?

    Best regards,
    Rikard

    #1161649

    I just applied the fixes, and they don’t work.

    EDIT

    I then disabled cookie consent message, and reloaded – and the maps worked. When I turned cookie consent back on, everything works. – I don’t know why tho. – This should be investigated.

    • This reply was modified 1 week, 5 days ago by  MORTULGAAH.
    #1162041

    @mortulgaah I had to toggle Enfold’s script and stylesheet compression off and on (bottom checkbox in the Performance tab of theme options) to force it to rebuild the script include. One of those ‘standard practice’ things which keeps tripping me up.

    @rikard: am I right in thinking these fixes will be in the next Enfold point release?

    #1162154

    @jjsanderson That haven’t occurred to me, nice tip for the next time. This definitely should go to next update.

    #1162184

    I’m pretty sure it is in the 4.6.4 update: see this thread, and the line:

    fixed: Bug Safari browsers throw a js error with cookie consent

    #1162189

    That’s it then. :-)

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.