Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #1144992

    Hi there,

    since updating to version 4.6.3.1 neither the cookie consent bar nor the cookie badge work on any Safari browsers (neither desktop nor mobile variants).

    We also noticed an error on line 629 in “avia-snipped-cookieconsent.js” (!undefined is not an Object (evaluating “msTrackingProtectionEnabled”), which might cause the issue.

    Also, when you enable “AUTO RELOAD PAGE” setting in the backend and change your cookie settings in the frontend (like e.g. “accept all”) a “”>” sign appears in the footer, as if a class doesn’t get properly closed.

    It’s very important for us to get the issue sorted as quickly as possible as our customers in Germany rely on a working cookie consent solution.

    • This topic was modified 4 years, 6 months ago by linus303.
    #1145208

    Hey linus303,

    Sorry for the problem. Please send us a temporary WordPress admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,
    Rikard

    #1145331

    Hi, i have the same problem.
    Could you share the solution that I will be able to fix it on my wp?

    #1145443

    Hi mambochic,

    Please open a new thread and include WordPress admin login details in private so that we can have a closer look at your site.

    Best regards,
    Rikard

    #1145696

    Hi there,

    have a look at the login credentials. It affects *every* Enfold installation, by the way. It’s not specific to our case.

    • This reply was modified 4 years, 6 months ago by linus303.
    #1145865

    Hi,

    Could you please replace /enfold/js/avia-snippet-cookieconsent.js file with this one – https://github.com/KriesiMedia/enfold-library/blob/master/temp_fixes/Enfold_4_6_3/avia-snippet-cookieconsent.js?
    Theme Editor is missing under Appearance tab, therefore i could not update the file. I tested on my local installation and it works. Please make sure to flush cache.

    Cheers!
    Yigit

    #1145873

    For me works, now i can see the cookie bar.
    But in Console now i see this error:

    Failed to load resource: the server responded with a status of 404 (Not Found)
    https://www.mydomain.com/undefined

    #1145875

    Hi,

    I cleared cache however i am still seeing the error you mentioned in your initial post in console. 404 error is not present in my localhost.
    Could you please post FTP logins here privately so we can look into it?

    Edit: I checked @linus303 website. @mambochic could you please start a new thread under Enfold sub forum and share FTP and WP admin logins so we can look into it? :)

    Best regards,
    Yigit

    • This reply was modified 4 years, 6 months ago by Yigit.
    #1146096

    Hi there,

    thank your for a quick solution, Safari browsers work now.

    However, there is still a bug regarding the “av-cookie-auto-reload-container” class that doesn’t get closed properly and causes a “<” sign to be shown in the footer after you declined or accepted the cookie message bar.

    I attached a screenshot, have a look!

    EDIT: It’s the /includes/helper-privacy.php file
    EDIT: I fixed it on my own with a temp fix – you should still release an updated version of that file, as everybody else will run into that issue.

    • This reply was modified 4 years, 6 months ago by linus303.
    #1146123

    Hi,

    Thanks and sorry for that.

    The fix is in this file: https://github.com/KriesiMedia/enfold-library/blob/master/temp_fixes/Enfold_4_6_3/helper-privacy.php

    Replace /includes/helper-privacy.php.

    Alternate you can replace in code:

    Around line 1522:

    
    $output .=		'<a class="avia-privacy-reload-tooltip-link" aria-hidden="true" href="#" rel="nofollow" data-avia-privacy-reload-tooltip="' . $reload . '"></a>';
    

    replace with:

    
    $output .=		'<a class="avia-privacy-reload-tooltip-link" aria-hidden="true" href="#" rel="nofollow" data-avia-privacy-reload-tooltip="' . esc_attr( $reload ) . '"></a>';
    

    Will be part of the next update.

    Best regards,
    Günter

    #1146455

    Could you please replace /enfold/js/avia-snippet-cookieconsent.js file with this one – https://github.com/KriesiMedia/enfold-library/blob/master/temp_fixes/Enfold_4_6_3/avia-snippet-cookieconsent.js?

    I had the same problem in Safari (mobile and desktop) and this fix resolved my issue. Thank you!

    • This reply was modified 4 years, 6 months ago by crowdlauf.
    #1147783

    Will this be fixed in the next update? When is the next update coming up?

    #1148027

    Hi,


    @spitsdesign
    yes, it will be included in upcoming version. We do not have ETA yet as there are still some fixes and improvements that we are working on.

    Best regards,
    Yigit

    #1148466

    Hello,

    copied the new code as specified – but it still doesn’t work in Safari – neither mobile nor desktop.

    Alexander

    #1148565

    For me the fix with avia-snippet-cookieconsent.js works for one site, I’ve tried on another site that also don’t display Google Maps but is not working.. We must replace both files helper-privacy.php and avia-snippet-cookieconsent.js ?

    I’ve replaced both files with no results..

    #1148856

    Hi,

    You are using enfold script merging.

    Please try to disable it in theme options, save theme options, clear server and browser cache and check frontend.
    Then enable it again,save theme options, clear server and browser cache again and check frontend.

    Best regards,
    Günter

    #1148864

    Ok Günter, It works..
    Thanks

    #1148947

    Hallo Günter, Danke hat nun funktioniert!

    #1149250

    Hi,

    Glad it works.

    I will close this topic for now. Feel free to come back when you need further assistance.

    Enjoy the theme and have a nice day.

    Best regards,
    Günter

Viewing 19 posts - 1 through 19 (of 19 total)
  • The topic ‘Cookie Consent Bar’ is closed to new replies.