Viewing 30 posts - 1 through 30 (of 63 total)
  • Author
    Posts
  • #995125

    I have recently noticed a problem attempting to update Enfold from within the WordPress dashboard. I saw the error, “Download failed. A valid URL was not provided.” I did not see this error with the other theme that had an update available. This screenshot shows the successful update for Twenty Seventeen and the failure for Enfold:
    Screenshot of Enfold Theme Update Problem

    I have confirmed my Themeforest API key is valid and active, and the update still fails. Is there any issue you are aware of that would produce this error? Thanks for your help.

    #995302

    Hey AJDesignCo,

    Have you tried updating it in Enfold > Theme Update (in your case it’s ideals > Theme Update)?

    Best regards,
    Nikko

    #995476

    I also have the same issue and yes i have tried ried updating it in Enfold > Theme Update.

    Still the same issue.

    Darren

    #995479

    Hey,

    Could you please try updating the theme via FTP – https://kriesi.at/documentation/enfold/how-to-install-enfold

    Cheers!
    Yigit

    #995978

    Hi, I have exactly the same error during updating Enfold.
    I tried it on 2 different websites on 2 different servers that are running on 2 different hosting providers.
    Both servers run DirectAdmin.

    #996031

    I haven’t tried updating via FTP yet. I’ll do that and let you know what I find.

    By the way, I have licensed the Enfold theme 50+ times. I have seen the same issue on several sites. That’s why I posted my question…it seems to be a broad problem. I’ve never had to update via FTP before. And updating the theme through WordPress admin really simplifies management of sites (I have been able to update the Enfold theme through the Plesk WordPress Toolkit).

    Since the update occurs through Themeforest and relies on their API key, is it possible there’s a problem with a recent update the WordPress, the theme software, or the particular latest version of the theme hosted at Themeforest? I know you guys will want to offer a solution to your users that is better than, “Use FTP to update the theme.” — especially for those of us who have 50+ Enfold sites to manage.

    Love your product, love your support. Thanks as always for your assistance!

    #996162

    Hi,

    Thank you for the kind words and mostly for been so an increadible client.
    Yes, we understand the notes and where you are standing. The problem here is that after some last updates we have had to give a version update that required in some cases to update
    through FTP

    Best regards,
    Basilis

    #996185

    Good deal. Thanks for your reply! You really do have one of the best and easiest to use themes available, in my opinion. The recent performance updates make it very hard to beat.

    So as we encounter this issue, is it safe to say that after we do this particular update via FTP. future updates will be possible once again through the WordPress admin?

    #996209

    Hi Guys

    Same issue here. Update via Enfold Theme in WP is not possible. Will update via FTP as suggested, but thought you might want to know.

    All the best,
    Corina

    #996460

    Hi Corina,

    Thank you for letting us know.

    Yes, future updates will be possible.

    Best regards,
    Victoria

    #996769

    Hi Kriesi team,
    You said: ‘after some last updates we have had to give a version update that required in some cases to update
    through FTP’.
    I tried to update via FTP but get an ERROR 500. I would like to know what is going on with normal API-updates, I tried updating different versions of Enfold and they all give the error ‘A valid URL was not provided’. So is the url of the Envato server changed or has the server a technical problem?

    #996954

    Hi corly,

    We would have to have a closer look at your site to say what is causing your problems. Could you start a new thread and include admin login details in private so that we can have a look at your site please?

    Best regards,
    Rikard

    #1004613

    Hi,

    I also get the error-message ‘A valid URL was not provided’ when trying to update theme via wp panel.

    I also get a 500-error when uploading the ‘enfold-directory’ (extracted) via ftp. The old enfold-version works when I put it back (since the new got me 500-errors) so theres nothing wrong with my uploading via FTP.

    What was the solution for Corly above?

    Thanks in advance.

    Best regards
    Christian

    #1004973

    Hi ChristianEnglen,

    Can you please check server log for error?

    There is a solution here for the theme update via WordPress
    https://kriesi.at/support/topic/ (Purchase code hidden if logged out)(Purchase code hidden if logged out) -our-websites/

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #1004980

    Hi,

    Envato Updater must have changed something that causes problems for some users.

    We have a fix for it.

    Please replace enfold/framework/php/auto-updates/class-pixelentity-theme-update.php with

    https://github.com/KriesiMedia/enfold-library/blob/master/temp_fixes/Enfold_4_4_1/class-pixelentity-theme-update.php

    Do not forget to make a backup of the original file for a fallback and clear server and browser cache.

    Best regards,
    Günter

    #1005062

    Thanks Gunter.. Successfully update the theme..

    #1005136

    Hi,

    @newmediologo Glad it worked for you! :)

    We will keep the thread open and will wait to hear from the creator of this thread. If you have any other questions or issues, please feel free to start a new thread.

    Best regards,
    Yigit

    #1011064

    I updated the file (using Günter’s code) and still getting these errors below upon update. Any thoughts? thanks!!

    Warning: preg_match() expects parameter 2 to be string, array given in /home/ucdemo/public_html/wp-admin/includes/class-wp-upgrader.php on line 258

    Warning: file_exists() expects parameter 1 to be a valid path, array given in /home/ucdemo/public_html/wp-admin/includes/class-wp-upgrader.php on line 258

    Warning: strip_tags() expects parameter 1 to be string, array given in /home/ucdemo/public_html/wp-admin/includes/class-bulk-upgrader-skin.php on line 61
    Downloading update from …

    Warning: parse_url() expects parameter 1 to be string, array given in /home/ucdemo/public_html/wp-admin/includes/file.php on line 970

    Warning: preg_split() expects parameter 2 to be string, array given in /home/ucdemo/public_html/wp-includes/kses.php on line 1325

    Warning: strtolower() expects parameter 1 to be string, array given in /home/ucdemo/public_html/wp-includes/http.php on line 517

    Warning: strtolower() expects parameter 1 to be string, array given in /home/ucdemo/public_html/wp-includes/http.php on line 517

    • This reply was modified 2 months, 3 weeks ago by  icentrics.
    #1011210

    Hi,

    Please create me an admin account and I’ll look into it.

    Best regards,
    Peter

    #1011430
    This reply has been marked as private.
    #1011868

    For me it doesn’t work too. Also Gunthers Idea don’t work.
    I fixed that like this:
    Change to an other Theme, delete the old Enfold Version and download at first the actually Enfold Version in my Download Folder. From there i load the updated Theme in my WordPress. All the Content was still there and for me the best method to change in this situation.

    • This reply was modified 2 months, 3 weeks ago by  Micha66.
    #1011994

    I too have updated the file per Gunter’s suggestion and get the following errors (identical to icentric’s errors above):

    Warning: preg_match() expects parameter 2 to be string, array given in /home/fhomespray/public_html/wp-admin/includes/class-wp-upgrader.php on line 258

    Warning: file_exists() expects parameter 1 to be a valid path, array given in /home/fhomespray/public_html/wp-admin/includes/class-wp-upgrader.php on line 258

    Warning: strip_tags() expects parameter 1 to be string, array given in /home/fhomespray/public_html/wp-admin/includes/class-bulk-upgrader-skin.php on line 61
    Downloading update from …

    Warning: parse_url() expects parameter 1 to be string, array given in /home/fhomespray/public_html/wp-admin/includes/file.php on line 970

    Warning: preg_split() expects parameter 2 to be string, array given in /home/fhomespray/public_html/wp-includes/kses.php on line 1325

    Warning: strtolower() expects parameter 1 to be string, array given in /home/fhomespray/public_html/wp-includes/http.php on line 517

    Warning: strtolower() expects parameter 1 to be string, array given in /home/fhomespray/public_html/wp-includes/http.php on line 517
    An error occurred while updating Enfold: Download failed. A valid URL was not provided.
    Please advise. Thanks! :)

    #1012038

    I am struggling with the same issue…. provided solution didn’t work out.

    Please advise

    #1012243

    Hi,

    Envato has also changed the rules for the old API ( (Purchase code hidden if logged out) -api/188055″ rel=”nofollow”>https://forums.envato.com/t/ (Purchase code hidden if logged out) -api/188055 ).

    We have added a temporary fix for it.

    Please replace enfold/framework/php/auto-updates/class-pixelentity-theme-update.php with the updated file

    https://github.com/KriesiMedia/enfold-library/blob/master/temp_fixes/Enfold_4_4_1/class-pixelentity-theme-update.php

    Do not forget to make a backup of the original file for a fallback and clear server and browser cache.

    We are working to switch to the new API asap.

    Best regards,
    Günter

    #1012329

    Hi, Gunter …

    Perhaps there’s a misunderstanding here, but many of us in this thread have already updated the enfold/framework/php/auto-updates/class-pixelentity-theme-update.php file with the one posted on github and are still getting these errors/warnings. I’m having other issues that I’m hoping will be resolved with the update to 4.4.1, but since I can’t update I’m in a bit of a holding pattern. I look forward to the new API so that my issues can be resolved asap.

    Thanks in advance for your assistance.

    #1012333

    Hi,

    This is a new version of the updated class-pixelentity-theme-update.php which also incorporates some changes of the Envato api.

    Best regards,
    Peter

    #1012357

    Hi, Peter …

    Thanks for the clarification on the updated github file. Just updated it on my server and I’m experiencing the exact same warning/error messages. Please advise.

    #1012714

    Hi,

    Can you create me an admin account please – I’ll debug the code and check why the new updated file doesn’t work for you.

    Best regards,
    Dude

    #1012789

    Hi Dude,

    I am having the same issues as intermarketer.
    I tried Gunters’ solution, but no luck.

    Thanks,

    #1012823

    Hi there …

    I went ahead and uploaded the new theme via ftp for now.

    Thanks.

Viewing 30 posts - 1 through 30 (of 63 total)

The topic ‘Problem Updating Enfold: "Download failed. Problem downloading theme"’ is closed to new replies.