Viewing 30 posts - 1 through 30 (of 66 total)
  • Author
    Posts
  • #999315

    Dear Enfold,

    I can not update ENFOLD to the latest version. In the past this worked perfectly.
    On all my different projects I’m getting the following error ( see screenshot ).

    Do you know why this might be happening?

    View post on imgur.com

    Thanks in advance,
    Kind regards

    #999551

    Hey jeroenvandessel,

    Have you attemped to update via FTP?

    Best regards,
    Jordan Shannon

    #999623

    I can try this, but every previous update worked just fine. I realise it’s a pretty basic procedure but I havent done it with FTP before, which means chances of doing something wrong are real :D.

    Suddenly with enfold 4.4.1 it doesn’t work on many of my different projects… weird

    #999643

    Hi,

    Have you had any recent server changes that you know of?

    Best regards,
    Jordan Shannon

    #999774

    Same Problem here… from 4.4 to 4.4.1 there is no update possible. i checked the themeforest api keys. but there is no change. And we have enough valid licences. WordPress 4.9.8, PHP 7.0.24

    wp enfold update fail

    • This reply was modified 1 year, 11 months ago by  roeschke.
    #999790

    Hi,

    Maybe the issue is caused by a known bug in the themeforest api. To fix it use the theme editor (Appearance > Editor) and edit Enfold. Go to enfold/framework/php/auto-updates/ and open the class-pixelentity-theme-update.php file. Clear the entire file (remove the code) and copy the entire code from here https://pastebin.com/raw/epetJ1SG into the blank file. Afterwards save the file and the update should work.

    You can also use ftp to update the file. Save the code from here: https://pastebin.com/raw/epetJ1SG to a file called class-pixelentity-theme-update.php. Then connect to your server via ftp, go to the directory wp-content/enfold/framework/php/auto-updates/ and overwrite the class-pixelentity-theme-update.php with the updated file you created before.

    Best regards,
    Dude

    #999860

    That was the problem. Works now! Thank you!

    #999917

    Hey Dieter,

    Great! I’m glad this was able to be resolved.

    Best regards,
    Jordan Shannon

    #1000258

    It did the trick for me too. Thanks ;).

    #1000367

    Hi jeroenvandessel,

    Glad you got it working for you! :)

    If you need further assistance please let us know.

    Best regards,
    Victoria

    #1006777

    Did not work for me :-(

    #1006808

    Hey Caorda,

    Please elaborate on your specific issue.

    Best regards,
    Jordan Shannon

    #1008896

    Hello,

    at our page it not work. Everytime i want to change the code i get a error.

    The error:
    Deine PHP-Code-Änderungen wurden aufgrund eines Fehlers in Zeile 83 der Datei wp-content/themes/enfold/config-layerslider/LayerSlider/includes/slider_markup_init.php zurückgesetzt. Bitte beheben und versuchen, erneut zu speichern.

    Uncaught Error: [] operator not supported for strings in wp-content/themes/enfold/config-layerslider/LayerSlider/includes/slider_markup_init.php:83
    Stack trace:
    #0 wp-content/themes/enfold/config-layerslider/LayerSlider/wp/shortcodes.php(218): include()
    #1 wp-content/themes/enfold/config-layerslider/LayerSlider/wp/shortcodes.php(159): LS_Shortcode::generateSliderMarkup(Array)
    #2 wp-content/themes/enfold/config-layerslider/LayerSlider/wp/shortcodes.php(49): LS_Shortcode::processShortcode(Array)
    #3 wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow_layerslider.php(129): LS_Shortcode::handleShortcode(Array)
    #4 wp-content/themes/en

    I hope u can help me.

    Thank you

    Regards

    Florian

    #1008903

    Hi,

    Please create me an admin account and I’ll look into it.

    Best regards,
    Peter

    #1009340

    Hi there,
    I have the same problem. Editing the the class-pixelentity-theme-update.php file did’t solve it. I get the same error as jeroenvandessel. the given url is not right. The current version is 3.6.1 and I wish to update to the latest version.
    When I updated through FTP, I had a blank page and couldn’t get to wp-admin (also blank page). Do you have a solution?

    Thanks in advance,
    Dineke

    #1009354

    Hi,

    If you use ftp to update the theme please make sure to replace the entire theme folder. If you just overwrite the existing files you’ll get a blank page. Connect to ftp, go to wp-content/themes and rename the theme folder “enfold” to “enfold_bak”. Then download the new files from themeforest, unzip the theme files and upload them to wp-content/themes/enfold. Make sure the style.css file is located in wp-content/themes/enfold (file path wp-content/themes/enfold/style.css). If the theme works, you can simply delete the enfold_bak folder. If not, delete the enfold folder and rename enfold_bak to enfold.

    Best regards,
    Peter

    #1009396

    Hello,

    in the private Content you see the admin account information.

    Thanks and regard

    Florian Meise

    #1009401

    Hi,

    I tried to log in but I get the error message “FEHLER: Das Passwort, das du für den Benutzernamen XY eingegeben hast, ist nicht korrekt.”

    Best regards,
    Peter

    #1009418

    Thanks, it worked out great!

    Kind regads,
    Dineke

    #1009423

    Hi,

    Great, glad it’s fixed now :)

    Best regards,
    Peter

    #1009827

    Hi Peter,

    i have checked the login with a new password and it worked for me. I give you the new password and then check it that you can login :)

    Best regards,
    Florian Meise

    #1010099

    Hi,

    I modified the file for you – you should now be able to update the theme :)

    Best regards,
    Peter

    #1010627

    Hi Peter,

    i have tried to update and got the same error as befor.

    Der Aktualisierungsprozess beginnt. Dies kann eine Weile dauern, bitte hab etwas Geduld.

    Anschalten des Wartungsmodus …

    Aktualisierung des Themes Enfold (1 von 1)
    Herunterladen der Aktualisierung von T …
    Beim Aktualisieren von Enfold ist ein Fehler aufgetreten: Download fehlgeschlagen. Es wurde keine gültige URL übermittelt.

    Abschalten des Wartungsmodus …

    Alle Aktualisierungen wurden vollständig durchgeführt.

    Can you look it up again and if you got the fix than please update the theme for me ?

    Best regards

    Florian

    #1010687

    Hi,
    I couldn’t update the theme on your website however the download url from envato seems to be correct (I debugged the code). Maybe a third party plugin breaks the update process.

    Personally I’d recommend to use ftp to update the theme ( https://kriesi.at/documentation/enfold/how-to-install-enfold-theme/#update-via-ftp ) otherwise you’d need to deactivate all plugins to chec if they may affect the update. If you use ftp make sure to replace the entire theme folder. If you just overwrite the existing files you’ll get a blank page (500 error). Connect to ftp, go to wp-content/themes and rename the theme folder “enfold” to “enfold_bak”. Then download the new files from themeforest, unzip the theme files and upload them to wp-content/themes/enfold. Make sure the style.css file is located in wp-content/themes/enfold (file path wp-content/themes/enfold/style.css). If the theme works, you can simply delete the enfold_bak folder. If not, delete the enfold folder and rename enfold_bak to enfold.

    Best regards,
    Peter

    #1011132

    Hi. I have just uploaded 4.4.1 by ftp and all looked good.
    Now however, when I try and do something in the dashboard Theme Options I just get a blank window???
    Mark.

    #1011293

    Hi,

    @marko7

    If you have a site with several thousand posts it might be necessary to update themes\enfold\config-templatebuilder\avia-template-builder\php\element-manager.class.php

    with

    https://github.com/KriesiMedia/enfold-library/blob/master/temp_fixes/Enfold_4_4_1/element-manager.class.php

    Do not forget to make a backup of the file for a fallback.

    We need to update the post content of all posts for better performance and this leads to timeout problems. After updating the file you must reload the backend several times after getting the timeout to allow the update process to finish (user reported it took up to 2 hours for very large sites).

    Best regards,
    Günter

    #1012371

    hi,
    I have similar problems but not sure if this is the right place to ask.
    I run Enfold 4.2.2 and for some time it caused me problems to update the theme and plugins. I tried the usual procedures (deactivating single plugins, deleting them, reinstalling them), but nothing worked: Plugins could not be updated; also I couldnt open the WP appearance / themes side (blank page). I switched now to another server with PHP 7.0.30 because I thought that may cause the trouble. But no change at all.
    Updating Enfold doesn’t work (through WP Dashboard or Enfold on my wordpress site directly) – the Error message is “Update failed. Download failed. A valid URL was not provided”. I went to Themeforest and logged in with my buyers account, but all I get to download is the same Enfold version. Any idea what the problems may be and where/how to get the Enfold update?
    many thanks
    Mark

    #1012626

    Hi Mark,

    Please open a new thread and include admin login details in private so that we can have a closer look at your site.

    Best regards,
    Rikard

    #1022714

    Updating without using FTP does not work anymore for me.
    I don’t feel comfortable using FTP.

    I’ve been using ENFOLD for years and it worked perfectly all the time… Hopefully this bug gets fixed soon.

    #1023130

    Hi jeroenvandessel,

    Updating to 4.5 has to be done manually unfortunately, there is a fix in that version though so it should only has to be done this one time. Please try this plugin, it should enable you to update by uploading the Enfold .zip file instead of using FTP: https://wordpress.org/plugins/update-theme-and-plugins-from-zip-file/

    Best regards,
    Rikard

Viewing 30 posts - 1 through 30 (of 66 total)

You must be logged in to reply to this topic.