Tagged: , ,

Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #1092859

    Hi,
    I’ve created a post and edited it. When I now want to preview the draft, I’m presented with an older version of the draft so I can’t publish the post. I’ve purged cache through W3 Total Cache and Autoptimize Plugins, and even disabled these plugins but the older version of the post is the one that shows as preview.
    Then, I updated the theme to the latest version – still the older version shows on preview.- NOT o.k.
    Then, I uninstalled both W3 Total Cache and Autoptimize Plugins – still NOT o.k.
    Then I installed WP Super Cache – one of the recommended cache plugins – still NOT o.k.
    I have the same problem with two posts.
    Regards,
    Eran

    • This topic was modified 5 years, 1 month ago by eransh. Reason: updating regarding several more actions I made, with no success to solve the issue
    #1093238

    Hey eransh,

    Thanks for the link, though we can’t view that unless logged in. Please post admin login details in private so that we can have a closer look.

    Best regards,
    Rikard

    #1093258

    Hi Rikard,
    Thanks for getting back. User&Password in Private Content section.
    I’ve noticed that there are a few open issues in the support forum regarding Preview (one example is “Problem with WordPress/Theme Cache
    Best,
    Eran

    #1093522

    Hi,

    Thanks for that. What happens if you select to use the Classic Editor in the main page of the theme options?

    Best regards,
    Rikard

    #1093598

    Hi Rikard,
    Regarding your request
    A.
    1. I changed “Enfold Child Theme Option” > Select Your Editor > Use WP Classic Editor
    2. The preview mode still shows a prior version of the post (my sign for that are two different dates I put as “published on date”). NOT o.k
    3. I changed back to “Use Block Editor”.
    B.
    1. I created a new post and used the Avia Editor.
    2. I copied the content of the post (not the post as a whole but the each block’s text from the editor).
    3. The preview looked fine.
    4. I edited the new post.
    5. The preview shows the prior version. NOT o.k.

    Remark: The problematic post (and another one which is having the same problem) were originally written in a prior version of WordPress and Enfold, yet the problems are occuring when all versions are up to date.
    Best,
    Eran

    • This reply was modified 5 years, 1 month ago by eransh.
    #1093826

    Hi Eran,

    Thanks for the update. Do you mind if you change the editor and update the post in question for testing purposes?

    Best regards,
    Rikard

    #1093890

    Hi Rikard,
    Thanks for coming back.
    A.
    As you requested, I switched the post in question into “Default Editor”. It gave me a message that there is bad or illegal html and asked me if it could correct it. I agreed. It did not fix any problem. Worth than that, it saved the old old draft as a draft, so I lost the changes I made in the updated draft. I went to “versions” and called the previoos version. So meanwhile – NOT o.k
    B.
    Since I have a feeling that there is a deep problem, I started to copy part by part the post into a Notepad editor, in order to make a clean new post. I’m behind my schedule to post this post.
    The bigger problem will be regarding the other post that has the same problem, since it is longer, has more sections with links, has an Avia Table Content Element with lots of cells. This means that it’s going to take many hours to start that post from scratch. That’s why the problem for the first post must be solved, so we can go forward to see if it was solved in general as well and for the second problematic post.
    C.
    Did you encountr with similar problems so that this is not a unique issue?
    Best,
    Eran

    #1095713

    Hi,

    Thank you for sharing the details of the issue with us.

    There could be multiple reason why some posts or pages stop working properly.

    For testing purpose let’s re-generate the posts which are not working properly. Fortunately Enfold provides an easy way to duplicate the post or page by copying the shortcode.

    . Login to WordPress admin.
    . Open the post which has an issue.
    . Copy the post shortcode
    . Create a “New” post and paste the shortcode in the classic editor and change to ALB.
    . Save the post and preview.

    Let us know if this work properly in the new post.

    Best regards,
    Vinay

    #1095723

    Hi Navy,
    Thanks for coming back.
    How and where do I find the post’s shortcode (I guess you don’t mean the url or the HTML code).
    The problem is systematic – I copied the post using “Duplicate Post” plugin; I copied the html of each section to a new post; I copied a clean text version of the post – all of these tests presented the old draft when I previewd them.
    Best,
    Eran

    • This reply was modified 5 years, 1 month ago by eransh.
    #1096028

    Hi,

    Thank you for contacting us.

    First, we need to enable the debug mode.

    NOTE: Repeating the steps mentioned int he above link, without removing the old code may show some errors.

    When I checked your site last the debug mode was already enabled. So just copy the shortcode visible above the title “Enfold Shortcode Parser” and copy it to a new page.

    For testing purpose edit and save the page a few times and let us know if you face any issue.

    Best regards,
    Vinay

    #1096582

    Hi Vinay,
    I’ve created a new post, copied the shortcode of the original post into it (using the default editor which is Gutenberg) and switched to ALB. At first the preview mode showed the right version, but after some editing it again shows a version which is not the one that is edited.
    The problem holds me from posting this post and another one, both are tied together and were scheduled to be published on April.
    BTW, The debug mode was realy already set in functions.php. I don’t know by whom. does it slow my website?
    Best,
    Eran

    #1098186
    This reply has been marked as private.
    #1098437
    This reply has been marked as private.
    #1098967

    Hi,

    Did you try to switch to classic editor:

    Dashboard -> Enfold Options -> Theme Options tab -> Select Your Editor -> Select “Use WP classic editor”.

    Best regards,
    Günter

    #1099058

    Hi Gunter,
    Thanks for your reply.
    Prior to your reply I created the new post with WP’s default editor which was the new Blocks editor and then switched to Advanced Layout Builder. The preview did not work fine.
    After following your instructions to change the default editor to Classic editor) – [Dashboard -> Enfold Options -> Theme Options tab -> Select Your Editor -> Select “Use WP classic editor”.], it seems that Preview worked fine. I hope that tomorrow I will be able to publish the post that was waiting for almost a month to be published, and next week to publish the other post that was also waiting.
    Four questions:
    1) New posts – should I start them with Classic editor and then switch to ALB (Advanced Layout Builder)
    2) In case I want to edit older posts, should I do the same and copy the shortcode into a new copy of post etc.?
    3) Should I now delete the debug mode phrases from functions.php file? Does the debug mode slows the website?
    4) When are you planning to publish a version with a fix to the preview issue (which as I understand was raised by others as well)?
    Thanks for resolving the issue.
    Best, have a nice weekend
    Eran

    #1102782

    Hi,

    Thanks for the update.

    1.) If you’re intention is to use the advance layout builder (ALB), then you should switch to it immediately. You don’t need to start with the classic editor.

    2.) Are you using the ALB for the previous posts? If you are, then you can save the content as template so that you can use the same content again for new posts.

    3.) It doesn’t affect the website at all. It just displays the actual shortcodes below the ALB.

    4.) We’ll forward the issue to our devs.

    If you have any additional questions at this time we kindly ask that you open them up in a separate thread. The longer threads get in the forum, they become more difficult to support as they tend to drift off topic and they also make it troublesome for users trying to search for solutions. Keeping threads relevant to their original inquiry ensures that we can keep better track of what has been resolved and that users can more effectively find answers to similar issues they might be experiencing.

    Thanks!

    Best regards,
    Ismael

    #1333540

    I know this is an old post, but today I encountered the same problem with a portoflio entry. Therefore, I think the issue is still there…

    I followed the procedure described above (enable debug, copy / paste shortcode in a new page, etc) and I solved the issue with my page.

    I just wanted to add that I noticed the following: when I “update” my not working page, I have a popup message box saying “Post updated – view portfolio entry”. Well, this page preview is CORRECT, and this is the important thing to know if anyboyd encouters the same issue.
    If I select the preview from the “Preview\Preview in new tab” menu, that one is wrong (= it shows a very old version).

    In fact the link used to open these two pages are different. The one used by the popup message is:
    https://www.mywebpage.comit/portfolio-item/testpage/
    The one used from the menu is:
    https://www.mywebpage.comit/portfolio-item/testpage/?preview_id=3212&preview_nonce=cab0d203f5&preview=true

    Bye!
    A.-

    #1333581

    Hi,


    @mistermagoo8691
    : Thanks for the info. Please open a new thread and post the login details in the private field so that we can check the site. For the meantime, try to clone the site to a subdomain or create a development version of it so that we can test the issue without affecting the live site. We will close this thread for now.

    Best regards,
    Ismael

Viewing 18 posts - 1 through 18 (of 18 total)
  • The topic ‘Preview shows not the updated draft of a post’ is closed to new replies.