Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
    Posts
  • #301511

    Hi there,

    I’m having a problem updating my Enfold Theme.

    I purchased it a while ago on Envanto Theme forest, entered my UN and API code in the Theme Update section and although I was notified that there’s an update available, the download failed because it was forbidden.

    I love the theme, I think it’s one of the best out there, but taking care of these rather simple seemingly requires customers to jump through quite a few hoops.

    Does this really need to be so complicated?

    Many thanks.

    #301530

    Hey karl_mohr!

    It could be related with Envato’s API. Can you please try updating the theme via FTP this time – http://vimeo.com/67209750

    Best regards,
    Yigit

    #301554

    Thanks for the quick response Yigit,

    I understand how the updating via FTP works. I’m just concerned that this basically equals a complete new install and thus, I would loose all the design choices/definitions I made in the Theme’s Options section on WordPress.

    I got the theme a while ago; so I’m working with version 2.4… so checking and uploading the files manually may not be feasible either.

    Is this something I’d have to go through every single time there’s update now? Or is there a way to resolve this problem with the automatic update.?

    Many thanks

    #301560

    Hey!

    Can you copy&paste the exact error here? If you API key is correct, it should work fine, as it does for many other users.
    Also, you are using a very old version, after updating the theme, you may need to re-configure header options – http://vimeo.com/channels/aviathemes/91837491

    Regards,
    Yigit

    #650166

    I have this problem ‘Download failed. Forbidden’

    I am trying to update the theme because the “portfolio items’ have stopped working

    Plaese can you help

    Julian

    #650171

    If the username and api are correct in your theme options, have you checked to see if there’s something going on on the server that prevents a download, or do you have security plugins that may be flagging the download. WordFence, if left idle for a long period, would flag it as something nefarious. Resetting it to Learning Mode will fix that.

    Being such an old version, you’d be better off updating via FTP this one time, and then maintaining it more often. There have been a lot of updates since your last upgrade. You will need to tweak the theme options because they have added so many.

    #650191

    Hi!

    Please do update through FTP, it does seem to be the best option.
    Also, remember to always clear transients
    https://el.wordpress.org/plugins/transients-manager/

    when you have to do with such things like API updates etc, keep an eye to the transients, deleting and empty them, does help a lot

    Regards,
    Basilis

    #1058331

    Can’t update the Enfold Theme through WordPress even though my token is fully up to date please help if you can

    #1058336

    We are also having this problem. Have tried updating through Dashboard/Updates, Appearance/Themes, and Theme Update in theme options – same result each time:

    “An error occurred while updating Enfold: Download failed. Forbudden.

    Auto-updating through Dashboard was working fine up until now, and the license token is showing as fine (I revalidated it and tried again, but still the same error). I have a screenshot of the full error message for you, but I don’t see a way to attach it.

    #1058821

    Hi kgalatz,

    Here are some threads to consider:

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #1059237

    Neither of these threads seems to apply to our situation (getting a 403 forbidden error when running the update). As I mentioned previously, we have already performed the manual update to 4.5, and were able to update to 4.5.1 and 4.5.2 through the dashboard with no issues. It is the update from 4.5.2 to 4.5.3 that we are having the problem with.

    Our Envato token is showing as validated. I revalidated before my original post earlier in this thread, as I mentioned, and it continues to show successfully connecting to our account, and being able to access purchases, username and email.

    I have pasted the full error message (or as much of it as I am able to copy) into the private content box. Despite the “all updates have been completed” message, the theme version is still showing as 4.5.2.

    BTW, the link to the changelog that shows when viewing the update in Appearance/Themes results in a blank white page.

    #1060622

    Can I please get a response? I have been trying to apply tghis update for a week.

    #1060865

    Hi,

    I would like apologize for the late response. Have you tried doing the automatic update on incognito mode? It seems to be a cache issue, so updating without cookies or browser history usually works. If it doesn’t, try to update the theme manually via FTP.

    // https://kriesi.at/documentation/enfold/install-enfold-theme/#reinstall-or-update-using-ftp
    // https://kriesi.at/archives/the-complete-guide-to-updating-enfold

    Best regards,
    Ismael

    #1061114

    I was hoping for something a little more specific to my problem than a 3-year-old help page. Installation in incognito mode did not work, and the theme file available for download on ThemeForest is dated June of 2018, so it does not appear to be the theme update in question.

    #1061910

    Hi,

    Did you make sure that you have given your token the correct permissions? https://kriesi.at/documentation/enfold/theme-registration/#toggle-id-5

    The files in your Themeforest account is always the latest version, you can verify that by downloading it and opening up style.css.

    If you still can’t get it to work then please open a new thread and include admin login details in private so that we can have a closer look at your site.

    Best regards,
    Rikard

    #1062926

    The token permissions were correct. I was able to complete the update manually, but downloading and then uploading 1300+ files is quite a hassle, and we still don’t know why the automatic update wasn’t working, when it worked fine for previous versions. I sure hope this is a one-time issue.

    #1063453

    Hi,

    We would like to apologize for the troubles. It might be an issue with the Envato servers not able to handle the requests or them enforcing a limit. In the future, please try to do the automatic update on different time during the day if it doesn’t work on the first try.

    Best regards,
    Ismael

    #1063739

    I don’t think that explains it, as I attempted the update many, many times, at all times of day and evening, over a period of more than a week. However, the first copy of what was supposed to be the update that I downloaded from Themeforest was actually the previous version (4.5.2). I don’t recall exactly when I downloaded it, but it was after the 4.5.3 update was showing up as available in my dashboard, and I had attempted the auto-update, so there may be a problem on the Themeforest end with offering updated versions promptly.

    #1064411

    Hi,

    Thank you for sharing your experience with the automatic update. We are not really sure why that happens but it is possible. It can also be a cache issue on your browser. Anyway, we do recognize the inconsistency in the update process and our developers are still working to improve it. They are currently adding a few improvements to it, which is going to be available in the next update. We hope that your next attempt with the automatic update will work properly.

    Best regards,
    Ismael

    #1066690

    FTP crashed the entire site with the following error:
    Fatal error: Cannot redeclare av_upcoming_events_fallback() (previously declared in /www/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/events_upcoming/events_upcoming.php:15) in /www/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/events_upcoming.php on line 13

    #1066696

    Hi!

    @theurldr /avia-shortcodes/events_upcoming.php is a duplicate file. That file should be inside /avia-shortcodes/events_upcoming/ folder only. This issue occurs when folders are merged and not replaced. To make sure all folders are replaced, please delete Enfold theme and re-update via FTP

    Cheers!
    Yigit

    • This reply was modified 2 years, 9 months ago by  Yigit.
    #1067037

    Following this thread as I’ve had similar troubles and due to intermittent FTP errors could not upload via that route as they’d always be missing files.

    My fix was to rename the downloaded theme folder to enfold-new, compress and upload via the WordPress Themes section. Once uploaded I could rename the folders in the Theme folder to switch over versions.

    Hope that helps?

    Richard

    #1067127

    Hi,

    @raslade that would definitely help. Thanks for sharing :)

    Best regards,
    Yigit

Viewing 23 posts - 1 through 23 (of 23 total)

You must be logged in to reply to this topic.