Viewing 30 posts - 1 through 30 (of 69 total)
  • Author
  • #1021872

    I’m trying updating from dashboard. from version 4.4.1 to 4.5. But show error message
    Aggiornamento fallito: Il download non è andato a buon fine. Non è stata fornita una URL valida.
    It happens in 3 web site
    You can help me

    Best regards


    Hey chribur_marz,
    Theme Forest has changed their API for Token keys, v4.5 fixes this, it is recommend to update manually.
    There is a free plugin that will allow you to manually update via the WordPress Theme panel by uploading the enfold.zip file, otherwise you can update via FTP, please remember to delete the current enfold folder and then upload the new one. Please don’t try to overwrite the theme folder, as this will leave old files behind and cause errors.
    My recommendation is to go to your Theme Forest account and download the updated Enfold v4.5 and manually update it, then going forward it will use the new Token keys. All users will need to generate a new token for updates.
    Please let us know if you would like some help updating.

    Best regards,


    “An error occurred while updating Enfold: Download failed. A valid URL was not provided.”
    Is there going to be a fix that allows people to update within wordpress like normal? I don’t want to screw with uploading the theme via FTP.



    yes the update solves this issue because it supports the new Token system that Theme Forest is replacing the API system with, but you will need to update.

    Luckily there is a very easy plugin that can update for you: Update Theme and Plugins from Zip File just install the plugin and then update your sites with the enfold.zip “installable file” from your Theme Forest account, by going to WordPress > Themes > add new
    the same way you would install a new theme.

    Best regards,


    What all do I need to copy? Custom CSS? Anything else?


    You could use your webhost’s full backup tool to backup your site, this would always be a good idea.
    But you won’t need to save anything else because the plugin doesn’t make changes to the database, only your theme files.

    Best regards,


    okay. done. it seems to have gone okay.


    Glad to hear.

    Best regards,


    Hi – I just downloaded latest enfold and uploaded manually via ftp after removing enfold older copy first. I now get this error:

    Parse error: syntax error, unexpected ”Im’ (T_ENCAPSED_AND_WHITESPACE) in /home/**/public_html/testsite/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/image_hotspots/image_hotspots.php on line 429


    I’m having a similar issue. I wasn’t getting any error message, it just would not actually update the files (even though it reported that the updates were complete). When I return to Theme Options > Theme Updates, it still says it is at 4.4.1.

    I updated my API key at Envato, using their new procedure. It appeared to all work smoothly. The new API key was generated, applied to the website (Enfold) settings, and I got the “all okay sparky” acknowledgement.

    For now I am updating the site manually, but I have another 10 or so Enfold sites to update and I’d like to not have to do each one manually because it takes so much of my time.

    After I manually uploaded to 4.4.5, the website crashed (it just would not view on my browser, as if the website did not exist). I returned it back to 4.4.1 and the site is back. Is there an issue with version 4.4.5 that would cause this?

    • This reply was modified 5 years, 7 months ago by laptophobo.


    Sorry for the problems, but the update to 4.5 will have to be conducted manually or using the plugin Mike is referring to above. The fix for the automatic updates is not included in the previous versions before 4.5.

    Best regards,


    Hi Rikard.

    I did upload the new version manually to wp-content/themes. Once uploaded, I renamed the old Enfold file “enfold-4.4.1” and then renamed the new one “enfold” (a practice I’ve done a hundred times before with no problem). And even after loading in the above plugin, my site still crashes.

    I’ve tried this several times. I’ve replaced the API key with the new and the original, but still no change. I’ve also tried turning off all plugins. No difference.


    Most times I receive a message about an new update. Have not seen it yet.
    But my colleague does have an error code 403 and reinstalled the older version.
    The think about API keys and the Tokens are a bit confusing.
    Can we just make as many tokens as we want?


    I solved temporarily, with the plugin, recommended by Mike.

    many thanks



    Hi Bruno,

    Glad you got it working for you! Thanks for the feedback. :)

    If you need further assistance please let us know.

    Best regards,


    @saucyhotdesign and @laptophobo, please try the following step-by-step procedure which is a manual theme update via SFTP or FTP:

    1) Make a full backup of your website using a backup plugin.
    2) Safe the backup somewhere outside from the webserver of your website (e.g. on your local computer or in any cloud storage you trust).
    3) Sign out from your WordPress website.
    4) Go to your themeforest account, sign in and download the updated Enfold v4.5 to your computer. Extract it and search for the file enfold.zip. Extract this file as well to already have your folder ready to be uploaded.
    5) Sign in to FTP or SFTP using FileZilla or any other tool which is able to do that.
    6) Go to the folder ./wp-content/themes and search for “enfold”. If you want, you can download the enfold folder to your computer as well (just in case you want to restore if afterwards which is easier like that than using the whole backup).
    7) Delete the folder enfold via FTP. This may take 5-10min, depending on the server speed obviously.
    8) Wait until it is finished and the enfold folder is gone. If that is the case, upload the “new” enfold folder including v4.5 to your website in the same directory.
    9) Sign in to your WordPress website again and go to the Enfold tab (or the one from your child theme). Scroll down to the tab called Theme Update.
    10) Your current API token will not work anymore as Envato changed some stuff on their API. Therefore you need to remove your current key and generate a new private key as visible in your themeforest account under “Settings” -> “API keys”. Go to https://build.envato.com and follow the steps there. To me, https://kriesi.at/documentation/enfold/how-to-install-enfold-theme/#toggle-id-5 was also very helpful (scroll down a bit there to find out about the permissions your private API key needs in order to check for future Enfold updates). Without these permissions it will not work.
    11) After revalidating your new private key within the Enfold update tab, you should see a blue rectangle saying when it could be checked for the last time.
    12) Done!

    I hope it helped! Feel free to ask me in case you need any assistance.



    Thanks Michael,

    It seems like a peace of cake. But 15 peaces of cake does’nt make me feel good.
    Hopefully the bugs will be fixed soon.



    Hi Els

    Yeah I know, but this time the manual update is needed.
    You can either do it via FTP as mentioned or with the plugin mentioned by others as well.

    So this time an auto-update via dashboard is not possible due to the changes Envato made on their API.



    Hi Michael,
    My first update went fine, uptil now. Where can I find info about what is new in this Enfold update?




    Hi Else

    Here is the changelog of version 4.5 and previous versions:



    Thanks Michael!


    Hi Michael – as per my original post – I did exactly as per your steps up to step 8. It was when I then visited my live site to try to log back in that I now get the error message. SO to repeat, I MANUALLY UPLOADED 4.5 via FTP AFTER DELETING THE OLD ONE and got an error message as posted above. Luckily this is on a testsite and not live yet.


    If it helps at all – this is what line 429 has on my offline version that apparently is causing an error – does it look right?:
    $params[‘innerHtml’].= ” <span class=’av_hotspot_image_caption button button-primary button-large’>”.__(‘Image with Hotspots – Click to insert image and hotspots’,’avia_framework’).”</span>”;


    I tried uploading 4.4 and got another parse error – could it be my php version is not high enough?


    Hi Michael,
    I may have localized the problem. I have tried to update my enfold theme on 4 different WordPress sites. 2 on a live hosting service, and 2 on my local host. The local host sites update fine. However, the 2 others on hosting service produce the error message:

    Parse error: syntax error, unexpected ” ‘ (T_ENCAPSED_AND_WHITESPACE) in /home/brokenno/public_html/grasp/wp-content/themes/enfold/framework/php/class-framework-widgets.php on line 2050

    When you go to that file and look at it, at the very last line (2050) is this line of code:
    ‘address’ => $postcode . ‘

    So, is this causing the problem?


    @saucyhotdesign are you using PHP v5.6 minimum? Can we see the test site?
    Is there a chance that you had html tags in the title of the hotspot element, such as “strong” ?

    Best regards,



    I see you are getting the same error but in a different element, is there a chance that you had a “strong” or other html tag in a title field? I’m asking the team to help out here, can we see your site?

    Best regards,


    Please see private for details.

    • This reply was modified 5 years, 7 months ago by laptophobo.

    Mike – my testsite is literally a new site with nothing done to it yet, so I doubt there is a html tag issue. I do think that my server may only be running PHP 5.5.33. Would this be the cause of the problem? What version of enfold do I need to go back to to not have a problem until I can get my server to update the php?



    I checked the file enfold/framework/php/class-framework-widgets.php in 4.4.5 folder and it was corrupted – it ended where the parser reported the error in line 2050.

    I uploaded the correct version of the file in the folder. Can you check please.

    Best regards,

Viewing 30 posts - 1 through 30 (of 69 total)
  • You must be logged in to reply to this topic.