Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #249847

    Hi,

    like others I have the pagination issue using the advanced layout editor for building the blog page. The first page displays well but if you try to display the 2nd page or any page below you get either displayed the first page or the 404 error page.

    If I use the pre-build page layouts to display the blog page the pagination works without any issues.

    Even if I build the exact same layout with the advanced layout editor like the pre-build layout (e.g. single author, big preview, full content) pagination does not work.

    All steps mentioned by you in other threads have been taken. All plugins have been deactivated. A new blog has been setup and the content has been imported. It still does not work.

    This is definitely an issue with Enfold and the advanced layout editor and not an issue with third party plugins.

    Regards

    Michael

    #249852

    Update

    Depending on the layout I choose in the blog posts content element within the advanced layout editor the link of the pagination changes. E.g. if I choose [single author, big image, excerpt, read more] the link under the page 2 end correctly with /blog/page/2/. But if I choose the grid layout page 2 points to the last displayed post on page 1.

    Regards

    Michael

    #249866

    Update

    As already mentioned in thread https://kriesi.at/support/topic/blog-style-advanced-layout-editor/ again this is an issues with the uri arguments.

    The avia_pagination function tries to get the page/paged argument and fails.

    if(get_query_var('paged')) {
    		     $paged = get_query_var('paged');
    		} elseif(get_query_var('page')) {
    		     $paged = get_query_var('page');
    		} else {
    		     $paged = 1;
    		}

    Therefor the fallback to 1 is triggered.

    May this be an issue due to the usage of Nginx instead of Apache?

    #249910

    Update

    If you set permalinks to standard and use the advanced layout editor to build the blog page a call to the blog page will have a url like
    http://domain.com/?page_id=22

    If you click on the second page in the pagination the resulting url will be
    http://domain.com/?page_id=22&paged=2

    This must lead to a 404 error because ‘paged’ must be ‘page’ in this case (is_page).

    If you manually call
    http://domain.com/?page_id=22&page=2
    you will get the expected blog page containing the second subset of posts.

    This is definitely a bug within Enfold as it has been tested on a vanilla wordpress install with nothing else than enfold installed (no plugins at all).

    Please fix this bug asap and test it with pretty permalinks as well (/%postname%/).

    Thank you.

    #249958

    Update

    If you set the same page as front and blog page pagination is working. I guess the function avia_custom_blog() might be the key to the issue.

    #249965

    Update

    To temporarily work around the issue until it gets fixed by Kriesi you can follow this instructions. Go to your WordPress admin panel and chose the following settings (dont forget to save settings in each step):

    Settings -> Reading -> Front page displays => Your latest posts
    Enfold -> Theme Options -> Frontpage Settings => select the page of your choice
    Enfold -> Theme Options -> And where do you want to display the Blog? => select the ‘select page’ entry
    (so in fact you select NO page for the blog at all)
    Enfold -> General Settings -> Blog Style -> ‘use the advanced layout editor to build your own blod’
    Create a page (e.g. blog), add the Blog Posts Content Element and modify the layout as you like (with pagination)
    In Appearance -> Menu add the newly created page to the menu used as ‘Enfold Main Menu’.
    Got to your website and click on the newly created menu item.
    Your blog posts should load as expected and you should see the pagination.
    A click on one of the pagination links should now load the corresponding subset of posts as expected.

    I have tested it with my development and production site with different layouts and everything seems to work well.

    Regards

    Michael

    • This reply was modified 5 years, 12 months ago by  mensmaximus.
    #249978

    Fantastic job Michael! Thank you for this solution. As I stated in my thread (https://kriesi.at/support/topic/pagination-issue/#post-249977), THANK YOU for offering this up!

    Gratefully,
    Justin

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Blog Pagination’ is closed to new replies.