Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #248580

    Hi There –

    I have been troubleshooting this issue for quite some time and have not been able to make any progress. I have consulted all the recent forum topics on this but nothing seems to work.

    The issue is the pagination does not seem to work on the blog page. Here is the site:

    The pagination appears here:

    A few background facts:

    1. The site is set to display the home page as the front page and the blog page for the blog. I have configured this in both the Enfold options and the Settings –> Reading area.
    2. I am using “Day and name” for my permalinks
    3. I am running the following plugins:

    • Akismet
    • All In One SEO Pack
    • Blubrry PowerPress
    • CodeStyling Localization
    • Configure SMTP
    • Custom Recent Posts Widget
    • Duplicate Post
    • Google Analytics Dashboard for WP
    • Jetpack by
    • jQuery Updater
    • My WordPress Login Logo
    • Simple 301 Redirects
    • Ultimate Tag Cloud Widget
    • W3 Total Cache
    • WordPress Editorial Calendar
    • WordPress Importer
    • WP Document Revisions
    • WP Mobile Detect
    • WP User Avatar
    • XML Sitemap & Google News feeds

    4. I have the following site pages:

    • About
    • Blog
    • Problem Solving
    • Communication
    • Leadership
    • Contact
    • Home
    • Subscribe

    Here is what I have done to troubleshoot the issue so far:

    1. Disabled all plugins.
    2. Changed the permalinks to default.
    3. Recreated the .htaccess file.
    4. Cleared caches (repeatedly) as well as cloudflare caches
    5. Changed theme and then changed it back

    I have a few other sites running on my server that are working just fine so I know it should be OK…

    Would love any support or assistance you can provide.

    Thank you in advance!


    • This topic was modified 3 years, 6 months ago by  JustinGreis.
    • This topic was modified 3 years, 6 months ago by  JustinGreis.

    Hey JustinGreis!

    Here are my thoughts on your problem :

    1) The pagination on the demo site ( enfold ) it’s working and on my local development is working too, that only says one thing, the problem is on the plugins part.

    2) You have tons of plugins, my advice is : remove 1 by 1 start with the ones are more critical to your workflow so if you have to replace one of them you have some time to thinking throughout.

    3) I’ve checked your site looking for bugs / errors on the console, so far nothing. ( so go back to #2 ).

    OPTION #4
    Backup your site ( there is a plugin for that ) or back up your db, after that remove wordpress completely, and start with a brand new installation, if you backup your data you won’t need to start all over. On enfold options pannel you can back up your options.



    Hi David – Thanks for the reply. I deactivated all plugins, reset the permalinks and still nothing. I am hesitant to do a fresh install as the site is live.

    Any other suggestions or pointers?


    Hi David – I tried to recreate and back up the site and still have the same pagination issues.



    Please reset the settings on Settings > Reading, set it to default. Set the homepage and blog page on the Enfold Theme Options. Reset the permalink settings again on Settings > Permalink panel. Let us know if it works.

    Best regards,


    Hi Ismael – Unfortunately it did not work. I tried doing these steps multiple times.

    • This reply was modified 3 years, 6 months ago by  JustinGreis.

    Sorry for highjacking your post but as I have the same issue and already found the bug I thought it might be useful to tell you:




    Michael – Thank you for validating! I thought I was going crazy here. I have been trying to troubleshoot this for weeks since I discovered it was not working on my site. I sure hope a fix for this is released soon as it seems like such a basic feature. Until then, I may have to show many 50+ posts on the page and turn off pagination.

    Many thanks for confirming I am not crazy. : )


    Please see my latest post at for a workaround I found.


    Michael – You are a genius! It worked! I could have sworn I tried that combination of settings but I suppose I needed to read your crystal clear steps in black and white. Thanks a million for staying connected to this thread and bringing and end to my ongoing madness.

    All the best to you!




    @mensmaximus Thanks for sharing :)

    Best regards,

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Pagination Issue’ is closed to new replies.