Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #239107

    After 4 hours of search I give up. I have created a page (called blog). The page contains the content element “blog posts”. Under Enfold Theme Option in “And where do you want to display the Blog?” is have selected the page “blog”. Under General Settings in “Blog Style” I have selected “Use the advanced layout editor …”. Everything is saved.

    As soon as i reload the page my custom css settings for fonts size get ignored. If i switch back to one of the other default styles (e.g. grid) my custom css settings are applied again.

    I use “Simple Custom CSS” plugin for a long time and never had any issues. The stylesheet is linked within the source code as usual:
    <link rel='stylesheet' id='sccss_style-css' href='https://www.mydomain.xxx/?sccss=1&ver=3.8.1' type='text/css' media='all' />
    If I call the link i get displayed my custom css setting
    body {font-size: 17px !important; line-height: 1.6em !important; font-weight: normal !important; }
    (actually it is much more than this line but that does not matter for now)

    If I change the blog style back to “Use the advanced layout editor …”, reload the page and view the source code i still see my custom stylesheet
    <link rel='stylesheet' id='sccss_style-css' href='https://www.mydomain.xxx/?sccss=1&ver=3.8.1' type='text/css' media='all' />
    However if I open that link again in a browser I get displayed the blog page of my site.

    If I move my custom css to the custom.css file from my child theme or to the quick css field in the styling section everything works.
    However i dont like that approach because the quick css field is to small and the custom.css is makes things complicated. I like to have all custom css settings at one place.

    I have searched through the enfold source code to see what prevents the sccss file from getting loaded if one selects the advanced layout editor. But I cant find it (or I am to tired).

    Can you please check what is going on? This seems to be a bug.

    regards

    Michael

    #239170

    Hi Michael!

    Thank you for using the theme. I hope you’re doing great.

    Can you please post the link to the website? We don’t usually support third plugins especially when the theme already has the plugin’s feature included, in your case the Quick CSS or custom.css. Maybe, you’r not using the right selectors to change the style of a certain element. We’ll try to find the issue with ALB. Please contact the plugin author for more info.

    Regards,
    Ismael

    #239326
    This reply has been marked as private.
    #239429
    This reply has been marked as private.
    #239499
    This reply has been marked as private.
    #240595

    Hi!

    I’ll mark this thread for Kriesi – maybe he can work out another solution to load the blog template but I’ll leave this up to him.

    Best regards,
    Peter

    #252838

    Hallo Michael!

    Danke für deine Hilfe :)
    Ich hab die Blog-Logik nun ein bissl umgekrempelt. Das neue Konzept ist viel einfacher und sollte weniger fehleranfällig sein.
    Bevor ich das Update release würd ich mich freuen (falls du die Zeit findest) wenn du deine test cases mal kurz daran testest :)

    Das neue helper-template.logic.php file findest du hier: http://pastie.org/9087849
    Das update ist hauptsächlich darauf ausgelegt Probleme mit der Pagination zu lösen die andere user hatten aber ich hab die Hoffnung dass es auch bei dir hilf :)

    Best regards,
    Kriesi

    #252845
    This reply has been marked as private.
    #252908
    This reply has been marked as private.
    #252909

    And for the community: the upcoming update for Enfold solves this issue.

    Many thanks to Kriesi for the most wonderful theme and the ongoing support that seems to never sleep!

    #253104

    Vielen lieben Dank für das Lob, freut mich dass du zufrieden bist :)

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Blog Style Advanced Layout Editor’ is closed to new replies.