Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #1369439

    Hi to everybody,
    I searched the forum and tried several solutions but nothing worked.
    On my website I am working with WPML. In the header (where the telephonenumber can be) I will show the flags from wpml, but not the current only the one which can be translated. I did it with custom flags and some css, it works but it always shows me the both languages. (german is the current, the small flag and the other is the big blue icon – leichte Sprache)
    When I try to put it additional in the footer (column 3) it shows nothing.
    I hope somebody can help me. Thank you in advance. The login and more please in the pc.
    Best regards Barbara


    Hey walhai,

    Thank you for the inquiry.

    Instead of using the default language switcher, we added a custom html widget and use the following shortcode to display the theme’s language switcher.


    You can use this css code to adjust the style of the language switcher.

    .avia_wpml_language_switch {
        position: relative;
        padding: 0px 0 0 10px;
        height: auto;
        line-height: 36px;
        margin: 0 0 0 0;
        z-index: 151;
        -webkit-backface-visibility: hidden;
        top: -2px;
        right: 0;
        overflow: hidden;

    Best regards,


    Hi Ismael,
    thank you for the quick answer and the solution.
    It works partially in the footer, but not in the header :(
    I will show only the blue icon and just when I switch the german flag.
    The footer I don’t realy need, it was just for testing.
    Maybe you have any idea??
    Thank you and best regards



    Thank you for the update.

    How did you display the switcher in your header? The following documentation might help.


    You can add the switcher shortcode in a text or code widget, then insert it in the header widget area.

    Best regards,


    thank you for answering.
    I have the [avia_wpml_language_switcher] in the theme options in the header – additional elements – telephone or info
    I solved it now with some css and displayed the current language:
    .avia_current_lang { visibility:hidden }

    Do you think this can make any problems??
    Best regards


    Glad to hear that you were able to sort this out, I don’t see any reason your css would cause any future issues, shall we close this then?

    Best regards,


    thank you, yes this can be closed.
    Best regards


    Glad we were able to help, if you have any further questions please create a new thread and we will gladly try to help you. Thank you for using Enfold.

    Best regards,

Viewing 8 posts - 1 through 8 (of 8 total)
  • The topic ‘WPML don't show the current language’ is closed to new replies.