Viewing 30 posts - 1 through 30 (of 42 total)
  • Author
  • #1141611

    What is this after upgrading to 4.6.2?? (in private content)


    Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

    In this case, WordPress caught an error with your theme, Enfold.

    First, visit your website ( and check for any visible issues. Next, visit the page where the error was caught ( and check for any visible issues.

    Please contact your host for assistance with investigating this issue further.

    If your site appears broken and you can’t access your dashboard normally, WordPress now has a special “recovery mode”. This lets you safely login to your dashboard and investigate further.

    To keep your site safe, this link will expire in 1 day. Don’t worry about that, though: a new link will be emailed to you if the error occurs again after it expires.

    Error Details
    An error of type E_COMPILE_ERROR was caused in line 671 of the file /wp-content/themes/enfold/functions.php. Error message: require_once(): Failed opening required ‘includes/admin/register-dynamic-styles.php’ (include_path=’.:/usr/local/php/pear’)

    • This topic was modified 4 years, 2 months ago by Illingco.

    Also the following in private section that WP Health Check has found. Please advise on how you will fix these errors…


    Any answers on this??



    Thank you for the inquiry.

    Looks like the E_COMPILE_ERROR error occurs intermittently, but the error points to different files in the theme. Have you tried updating the theme manually again via FTP? Please check if the includes/admin/register-dynamic-styles.php actually exists in the theme directory or if it has the correct file permission.


    Best regards,


    It does exist and has the same permissions as all other files, 644. And none of your links explain anything as it pertains to the errors I sent. Please advise further, it seems to be something wrong with the theme’s code.


    Hi Ismail,

    I also have an an admin-ajax error after upgrading to 4.6.2.
    The relevanssi search plugin is not displaying instant searches and in Search Console I get a 500 server error related to Jquery and admin-ajax when typing a search query.

    Any advice would be appreciated.- thanks.


    Hi simbeckhampson,

    Please start a separate thread, describe your issue there and give us a link to your website.

    Can you please check server log for error?

    Best regards,


    Same problem here. Will also start a thread but it seems to affect all users with this setup.


    Seems it would be best to answer this here, as multiple users have the same issue…


    And after again upgrading, this time to, I get yet another error:

    Error Details
    An error of type E_COMPILE_ERROR was caused in line 39 of the file /home/website/public_html/wp-content/themes/enfold/framework/avia_framework.php. Error message: require(): Failed opening required ‘php/inc-autoconfig.php’ (include_path=’.:/usr/local/php99/pear’)

    Why does this keep happening to multiple people with your theme??



    @simbeckhampson: Thank you for providing the site URL. Is this happening frequently? What is the actual error?

    First, visit your website ( and check for any visible issues. Next, visit the page where the error was caught ( and check for any visible issues.

    @illingco: The error is generated from the admin-ajax.php file, so the error occurs during an HTTP request. Please ask your hosting provider if the admin-ajax.php file is being blocked via mod_sec rules, or ask them if mod_sec is enabled in your server.

    Best regards,


    Thanks Ismael (and Victoria) for the reply. The previous behavior, pre-6.2 update was that on typing in the search box an instant search would list results, so no need to click enter and visit the search page. Using filters in the functions file I was able to populate a well organised list of possible search results. When typing in the search box now, the icon spins, as before, but no results are displayed. Checking the Dev Tools lead me to a 404/500 error relating to jquery / admin/ajax. Prior to the enfold update there was a Relevanssi update and a WP core update, so it’s a bit tough figuring out which one may have affected this functionality – but as I remember, it stop working after the 6.2 update.

    If it would help for investigation purposes I can give you Admin access, but would only ask that no changes are made until we discuss the findings – if that’s ok, please confirm and I’ll share access via the Private link.

    Many thanks –


    From our hosting provider:

    “We checked the error logs and we do not see any mod_sec entries, which means that no mod_sec rules were triggered on the server. Mod_sec is enabled on the server, however, since there are no error logs generated from your account in the past 24 hours, mod_sec has not caused the reported error. You could communicate that with the theme developers.”

    So it’s not mod_sec at all. Why do these errors appear every time there is an upgrade? Something seems buggy in your theme code I think. Please advise…


    Hi guys,

    it is affecting many customers on many different hosting providers it seems.




    Could you guys please post FTP and WP admin logins here privately so we can look into it?
    Logins for a staging site would be great but if possible.

    We may need to modify files therefore maybe it is going to be better if we try and troubleshoot the issue on another users installation.



    Info provided, please see what you can find. Note that you may encounter slightly different errors on staging from live site, but all related to the same file and error type.


    Thanks Yigit, I’ll monitor this thread for updates.

    FYI – I’ve now updated to to 4.6.3 and the search issue remains.



    Sorry for the delay.

    @illingco: We installed a plugin to monitor error logs and for that, the debug mode has to be enabled. We’ll need access to the file server. Please post the FTP details in the private field so that we can modify the wp-config.php file.


    Best regards,


    Hi guys, here is the bug in the relevanssi adaption in enfold. This used to work flawlessly:

    [07-Oct-2019 11:46:05 UTC] PHP Fatal error: Uncaught TypeError: Argument 2 passed to Avia_Relevanssi::handler_init_ajax_search() must be of the type array, string given, called in /web/wp-includes/class-wp-hook.php on line 286 and defined in /web/wp-content/themes/enfold/config-relevanssi/class-avia-relevanssi.php:70
    Stack trace:
    #0 /web/wp-includes/class-wp-hook.php(286): Avia_Relevanssi->handler_init_ajax_search(‘avia_relevanssi…’, ‘numberposts=5&p…’, Array, Array)
    #1 /web/wp-includes/plugin.php(208): WP_Hook->apply_filters(‘avia_relevanssi…’, Array)
    #2 /web/wp-content/themes/enfold/functions-enfold.php(255): apply_filters(‘avf_ajax_search…’, ‘get_posts’, ‘numberposts=5&p…’, Array, Array)
    #3 /web/wp-includes/class-wp-hook.php(286): avia_ajax_search(”)
    #4 /web/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array)
    #5 /var/www/ in /web/wp-content/themes/enfold/config-relevanssi/class-avia-relevanssi.php on line 70


    I have enabled debug to be true in wp-config. Please advise what you are finding…


    Thanks for sharing – fingers crossed it’s an easy(ish) fix.



    : We don’t really see any errors in the site because the debug mode is not enabled yet. Please go to the Dashboard panel and look for the PHP Error Log panel. You’ll see an instruction on how to properly create and enable the error logs. Or post the FTP details in the private field so that we can enable it.

    @El: Thank you for the info. Please modify the config-relevanssi > class-avia-relevanssi.php file, look for the avia_ajax_relevanssi_search function around line 155. Include the function name in the parameters.

    function avia_ajax_relevanssi_search( $function_name, array $search_query, array $search_parameters, array $defaults )

    Let us know if the modification changes anything.

    Best regards,


    Hi Ismael,

    it kind of fixed the search but now the function.php Relevanssi mods don’t work anymore. we narrow the search to only products but this is no longer taken into account.




    Thanks El and Ismael, great investigation and solution seeking. I also use filters in the functions.php, so will await further exploration before committing any changes to class-avia-relevanssi.php. El, thanks also for the additional link.


    Here are some errors I found:

    [02-Oct-2019 20:58:33 UTC] PHP Warning: require(php/inc-autoconfig.php): failed to open stream: No such file or directory in /home/website/public_html/wp-content/themes/enfold/framework/avia_framework.php on line 39
    [02-Oct-2019 20:58:33 UTC] PHP Fatal error: require(): Failed opening required ‘php/inc-autoconfig.php’ (include_path=’.:/usr/local/php71/pear’) in /home/website/public_html/wp-content/themes/enfold/framework/avia_framework.php on line 39
    [03-Oct-2019 20:05:02 UTC] PHP Warning: implode(): Invalid arguments passed in /home/website/staging/3/wp-content/themes/enfold/framework/php/class-framework-widgets.php on line 1023

    I also tried to set up the error logging in a new directory, but no matter what I change in wp-config, I keep getting:

    Error Log Monitor setup

    There was an error:
    The current error_log value php_errorlog is not supported. Please change it to an absolute path.

    Does any of this help, or would you still need FTP access?



    : Looks like your site is having a different issue compare to the rest of the users here. We need to check the “class-framework-widgets.php” file directly, or have access to the file server in order to debug the issue. Please post the FTP details in the private field.

    @El: Please continue here:

    : We found an error in your site and it seems to be related to a chat widget. Did you install a chat plugin?

    TypeError: The expression cannot be converted to return the specified type. 2 layout-builder.js:58

    Best regards,


    Hi all,

    I followed the advice on this thread:, including replacing the .php file, amending the filter tip from 4 to 9999, rebuilding the index and clearing the cache – search is working as it was before :-)

    Many thanks to everyone at Kriesi for finding the bug and fixing it, and big shout out to for following the problem through to conclusion and sharing the results.

    Best regards,


    Paul, my pleasure. Glad its working for you now. Best, El


    Please advise on this and any other errors you might see, thanks…



    : Glad it’s fixed. Thank you for the confirmation.

    : We tried to login using the account above and the default FTP URL, but it didn’t work. The login authentication is invalid. What is the FTP URL?

    Best regards,

Viewing 30 posts - 1 through 30 (of 42 total)
  • You must be logged in to reply to this topic.