Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #1100707

    Hi,

    Just today updated bm website to WP 5.2 and Enfold 4.5.7. Thereafter I received an e-mail from WordPress about a technical problem with this website. In short it says that sinds WP 5.2 there is a built in function to recognize fatal errors on a site. In this case the error has been caused by theme Enfold. The details of the error (unfortunately in Dutch, but I assume you will understand anyway):

    Een fout van het type E_COMPILE_ERROR werd veroorzaakt op regelnummer 29 van het bestand /xxxxx/wp-content/themes/enfold/functions.php. Foutmelding: require_once(): Failed opening required ‘config-wpml/config.php’ (include_path=’.:/opt/alt/php70/usr/share/pear’)

    I’d like to hear from you how this can be solved. (Btw: we are not using WPML)

    Thanks & best regards,
    Monique

    #1100870

    Hey Monique,

    Which version of PHP are you running on the site? We recommend 7.1 or above.

    Best regards,
    Rikard

    #1100917

    Hi Rikard,

    Thanks for your reply.

    The site was on 7.0. I just updated it to 7.3 and hope the issue is solved. In the email from WordPress they state that if the issue persists after 1 day, they would send another email. So let’s wait for a day to see if another email comes in or not :-)

    Best regards,
    Monique

    #1101125

    Hi Rikard,

    I just updated another site (see link below) and got exactly the same warning email from WordPress. This time I immediately checked the PHP vversion and it is 7.1.28.

    Please advise what to do.

    Best regards,
    Monique

    #1101283

    Hi Rikard

    Just want to let you guys know that me and quite some other people (I guess) are having the same issue since updating to WP 5.2.
    I am using PHP 7.3 currently and Enfold 4.5.7.

    Error details:
    An error of type E_ERROR was caused in line 212 of the file /home/wp/disk/wordpress/wp-content/themes/enfold/framework/php/auto-updates/class-avia-envato-base-api.php. Error message: Uncaught TypeError: Argument 2 passed to Avia_Envato_Base_API::add_envato_api_error() must be of the type array, null given, called in /home/wp/disk/wordpress/wp-content/themes/enfold/framework/php/auto-updates/class-avia-envato-base-api.php on line 440 and defined in /home/wp/disk/wordpress/wp-content/themes/enfold/framework/php/auto-updates/class-avia-envato-base-api.php:212 Stack trace: #0 /home/wp/disk/wordpress/wp-content/themes/enfold/framework/php/auto-updates/class-avia-envato-base-api.php(440): Avia_Envato_Base_API->add_envato_api_error(Array, NULL, 'Get Product Ver...') #1 /home/wp/disk/wordpress/wp-content/themes/enfold/framework/php/auto-updates/class-avia-theme-updater.php(301): Avia_Envato_Base_API->get_product_infos(Array) #2 /home/wp/disk/wordpress/wp-includes/class-wp-hook.php(288): Avia_Theme_Updater->handler_pre_set_site_transient_update_themes(Object(stdClass)) #3 /home/wp/disk/wordpress/wp-includes/plugin.php(208): WP_Hook->apply_filters(Object(stdClass), Array) #4 /home/wp/disk/wordpress

    To me this looks very much like an API connection issue with Envato/themeforest.
    Any advice or hotfix that makes it possible again to update via Dashboard -> Updates?

    Thanks a lot
    Michael

    #1101380

    Hi,

    @michaelH

    Thanks for reporting this.

    In enfold\framework\php\auto-updates\class-avia-envato-base-api.php line 212:

    
    protected function add_envato_api_error( array $response, array $body, $prefix = '' )
    

    replace with:

    
    protected function add_envato_api_error( array $response, $body = array(), $prefix = '' )
    

    and line 248:

    
    if( ! isset( $body['error'] ) )
    

    replace with:

    
    if( ! is_array( $body ) || ! isset( $body['error'] ) )
    

    You also can replace the file with: https://github.com/KriesiMedia/enfold-library/blob/master/temp_fixes/Enfold_4_5_7/envato/class-avia-envato-base-api.php

    @Monique

    Can you please check if the file enfold/config-wpml/config.php exists?

    If not, please download a new copy from theme forest. It must be there.
    If the file exists, than this message is strange.

    If you do not need WPML you can remove enfold\functions.php line 29:

    
    require_once( 'config-wpml/config.php' );
    

    Best regards,
    Günter

    #1101383

    Hi Günter

    Thank you very much – really appreciate your help.

    Interesting fact: It works again, even without changing some of the code from the files you described. Maybe some kind of caching (just a guess).
    Well the good thing is that if this happens again I know how to get rid of it (if the error message is the same).

    Thanks and have a great day
    Michael

    #1101386

    Hi,

    @michaelH

    Thanks for the feedback.

    Your problem is probably caused by the Envato request returning an error and not responding correctly. So this might also occur in future. I added the fix to be merged in core for the next update – so we should be safe in future releases.

    Best regards,
    Günter

    #1102417

    Hi Günter,

    Re Can you please check if the file enfold/config-wpml/config.php exists?
    I checked it and the file is there.

    Re If you do not need WPML you can remove enfold\functions.php line 29
    For both mentioned sites we do not need WPML.

    What code can I use in the child theme’s functions.php to remove WPML? I never change core files because the changes will get lost in the next update.

    Thanks & have a nice day,
    Monique

    #1102428

    Hi,

    @Monique

    Thanks for checking.

    If the file is there the error message is very strange.

    – Can you check the permissions for the config-wpml folder and the files inside – maybe they differ from the other folders?
    – Are you using a caching plugin or any kind of php caching on the server? Might be this caused the report.
    – Maybe the file is corrupted somehow – can you try to download the zip from Envato and update with FTP

    There is no other way to supress loading of this config file. You have to remove the line in functions.php of the parent theme.

    Do you still recieve the messages or was it only once after updateing to WP 5.2 ?

    Best regards,
    Günter

    #1104469

    Hi Günter,

    – The folder config-wpml inside the folder enfold has the same permissions (0755) as all other folders. The files inside this folder have the same permissions (0644) as files in other folders.
    – I am not using (a) cashing (plugin).
    – I am always using ftp. I have downloaded the latest version of Enfold now various times to update various website and I have the same problem/message for all websites.
    – I believe I have a new problem which tmo is related to this issue. On one site I want to deactivate Polylang plugin. before updating WP/Enfold/plugins I had a HTTP 550 error. Now I am getting a message “The site is experiencing technical problems. Check the admin e-mail inbox of your website for instructions.” [translated from Dutch]. I haven’t received an e-mail for instructions.

    I suppose it is not the best way (nor most favorable way) if I have to create extra code in functions.php of the parent theme for each website… (maybe over and over again?).

    Please advise.

    Best regards,
    Monique

    • This reply was modified 1 year, 1 month ago by  Monique. Reason: Sorry, this was caused by something else
    #1105162

    Hi,
    Please see Private Content area below.

    Best regards,
    Mike

    #1106688

    Hi Mike,

    Please find below.

    Best regards,
    Monique

    #1106884

    Hi,
    Thank you for the FTP access, I renamed your current theme to “enfold-old” then I uploaded the new “enfold” and checked that your site is working correctly. Please also check for yourself.
    Once you are happy you, (or I) can delete the “enfold-old” via ftp, (not the WP theme page)
    Should for some reason you wish to roll-back to the old version, it’s easy to do, simply rename the new “enfold” to “enfold-new” via ftp and then rename “enfold-old” to “enfold” then refresh your page.

    Please check if this solves your issue.

    ** I do note that in your child theme the “class-breadcrumb.php” is quite different than the theme version, so if you still have the issue please try activating the new parent theme to rule out a child theme functions.php or class-breadcrumb.php causing the issue.

    Best regards,
    Mike

    #1129916

    Hi there,

    I´m having the same problem as above. I´ve managed to log-in in recovery mode and found the following error messages:
    “The active theme is broken. Reverting to the default theme.”

    Then as I scroll to the bottom of the themes page I find the following message:
    Broken Themes
    The following themes are installed but incomplete.

    Name Description
    enfold Stylesheet is missing. Delete

    I´ve not deleted the stylesheet or changed anything since the last wordpress update. Could you please advise as to what I need to do to get the site back up and running please?

    Many many thanks!!!

    #1130172

    Hi ProTravelGolf,

    Please open a new thread and include WordPress admin login details in private so that we can have a closer look at your site.

    Best regards,
    Rikard

    #1136705

    Hi Mike,

    See your reply #1106884. It took me a while to reply.

    I just updated my site to the latest versions (WP 5.2.3, Enfold 4.6.1). I also deleted the ‘issue’ with the “class-breadcrumb.php” in my child theme. Not that this was ‘bothering’ anything, but it was not applicable anymore.

    My site just works fine. So there are no functional problems whatsoever. Not as far as I can see anyway.

    However, after updating I again got an email message from ‘WordPress’ saying that my site has a technical problem:

    Foutdetails
    ===========
    Een fout van het type E_COMPILE_ERROR werd veroorzaakt op regelnummer 146 van het bestand /home/u19338p24840/domains/arti-sign.nl/public_html/wp-content/themes/enfold/functions.php. Foutmelding: require_once(): Failed opening required ‘includes/helper-privacy.php’ (include_path=’.:/opt/alt/php73/usr/share/pear’)

    I am not sure if there is really a problem. But these emails are quite annoying.

    Please advise.

    Best regards,
    Monique

    #1136799

    Hi,
    Did this occur one time or more?
    I was not able to login with the old login from months ago, which is understandable, but perhaps this was a server hiccup?

    Best regards,
    Mike

    #1201536

    Hi,

    Hope you are all well and healthy?

    Just cleaning up my ‘mess’. I noticed this error message occurred on various sites but only once after a specific WP update (WP 5.2 in fact). Thereafter it didn’t occur anymore.

    Can you please flag this topic as closed?

    Thanks & best regards,
    Monique

    #1201572

    Hi,

    Thanks for informing us. I will close this topic – feel free to come back when you need further assistance.

    Thank you for using Enfold.

    Best regards,
    Günter

Viewing 20 posts - 1 through 20 (of 20 total)

The topic ‘WordPress sends message about technical problem with Enfold’ is closed to new replies.