Tagged: , ,

Viewing 30 posts - 1 through 30 (of 66 total)
  • Author
    Posts
  • #797146

    Hi guys,

    I have an issue with the cart icon not appearing when running WooCommerce 3.0.7 / Enfold 4.0.7.

    Cart icon set to ‘display floating but only once product added to cart’ in Enfold config.

    It never appears unless I force it’s position (right:0px). If I include this hack in my custom.css this will mean it shows even when it should be hidden with an empty cart.

    Previously reported at https://kriesi.at/support/topic/woocommerce-3-0-1-cart-icon-badge-not-displaying/ but closed without a proper resolution.

    • This topic was modified 3 years, 4 months ago by  Jason.
    #797476

    Hey Jason,

    You need to update the theme to the latest version, that`s 4.0.7

    Best regards,
    John Torvik

    #797526

    I am running 4.0.7 that was a typo.

    Can you please attempt to reproduce this on your end?

    Thanks,
    Jason

    #797544

    Hi,

    I can confirm it’s working well, I have tested on my end using Enfold 4.0.7, Woocommerce 3.0.7 and WordPress 4.7.5. Can you give us a temporary admin access? so we can check further. You can place the login details in Private Content, so it is only visible to the moderators :)

    Best regards,
    Nikko

    #797563

    The issue only occurs after adding the 2nd item to the cart.

    URL in private content.

    • This reply was modified 3 years, 4 months ago by  Jason. Reason: fix image
    #798594

    Hi,

    I added 50 different products and everything is functioning properly ( only your logo not visible )

    Best regards,
    Basilis

    #798651

    Can you provide a screenshot? Did you move between pages in between adding to cart? Were using the add-to-cart link from the product grid (as shown in my screenshot) or from individual product pages?

    You can see in screenshot that the cart dropdown is set to right: -60px; as it’s off the screen… This is from a new browser session with cache cleared.

    • This reply was modified 3 years, 4 months ago by  Jason.
    #798771

    I have the same issue, cart icon is not showing up after upgrading to Enfold 4.0.7 and WooCommerce 3. Works fine with WooCommerce 2.x though.

    You can check it at http://mondiale.de/testumgebung/de/ and just add something to the cart, i.e. this http://mondiale.de/testumgebung/de/produkt/pruefung-telc-deutsch-a1/

    I can force it to always show up by adding this

    .cart_dropdown {
        right: 0px;
    }

    but that’s just a workaround, not a fix.

    • This reply was modified 3 years, 4 months ago by  mchbeck. Reason: added workaround
    #799778

    Hi,

    @Jason And I actually do not see it now.
    Have you removed something?

    Best regards,
    Basilis

    #799914

    I have not changed anything mate. It’s as it was the other day. I am hoping you guys can provide a fix so I can upgrade my Production site to WC3.0. The workaround of forcing the cart icon constantly is a bit ugly.

    Cheers,
    Jason

    #800138

    Hi Jason,

    The cart icon is invisible until a product is added to it. I tested and the cart icon appeared when I added a product to the cart. If you don’t like this behavior, you can add the code from above to always have the cart visible.

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #800141

    Please read above and look at the screenshots. There are multiple people with this problem. Your reply indicates you have not read the thread.

    #800360

    Hi Jason,

    I might have been not very attentive, sorry about that. This issue needs further investigation.

    if($cart_pos == "always_display" || (!empty($cart) && !avia_active_caching()))
    
    if(!function_exists('avia_active_caching'))
    {
    	function avia_active_caching()
    	{
    		if(defined('W3TC') || defined('WPCACHEHOME') || class_exists('HyperCache') || class_exists('\\quick_cache\\plugin'))
    		{
    			return true;
    		}
    		return false;
    	}
    }
    

    Are you using any caching plugin?
    Best regards,
    Victoria

    #800467

    I had a plugin installed but disabled. The WPCACHEHOME variable was still set in my wp-config.php.

    Unsetting the variable seems to fix it!?

    My production site uses the same caching plugin (WP-Cache Manager) and does not have the same bug running WC 2.6.14 and Enfold 4.0.5.

    #800554

    Hi Jason,

    Well, that’s an old WooCommerce version, there could have been quite a few changes. So you got it working for you, didn’t you?

    Best regards,
    Victoria

    #800691

    Let me clarify:

    Production – WC 2.6.14 and Enfold 4.0.5 – WORKING
    Dev – WC 3.0.7 and Enfold 4.0.7 – BROKEN

    I have provided a Dev URL for you to test on and two other people have reported the same issue.

    Please stop trying to dismiss this problem, it’s very frustrating. I paid for the theme and I expect it to work.

    #800765

    Hi Jason,

    It seemed to me that after you disabled the caching it worked. Did you unset the variable? Did it work when you unset?

    Best regards,
    Victoria

    #800770

    Caching was already disabled, I just unset the variable.

    This is not a fix as we obviously need caching in a production scenario. Caching worked with the prior version.

    #800801

    Hi Jason,

    You can put this code to your child theme functions.php

    
    if(!function_exists('avia_woocommerce_cart_pos'))
    {
    	add_filter( 'avf_header_classes', 'avia_woocommerce_cart_pos' , 10 , 3);
        
        function avia_woocommerce_cart_pos($class, $necessary, $prefix)
        {
        	if($prefix == 'html_') // only for the html tag
        	{
    	    	global $woocommerce;
    	    	$cart = $woocommerce->cart->get_cart();
    	    	$cart_pos = avia_get_option('cart_icon');
    	    	
    	    	if($cart_pos == "always_display" || !empty($cart))
    	    	{
    				$class[] = "visible_cart";
    			}
    			
    			if($cart_pos == "always_display_menu")
    			{
    				$class[] = "cart_at_menu";
    			}
        	}
        	
        	return $class;
        }
    
    }
    
    

    and see if this helps.

    Best regards,
    Victoria

    #800810

    Is this a temporary fix? Will you be fixing this bug in a coming version of Enfold?

    #800974

    Hi there,

    Adding Victoria’s code to the functions.php does indeed fix it for me as well.

    Jason has a crucial point though: Will this be fixed with the next release? I don’t want to add workaround after workaround to my child theme files, because those workarounds might break something when the next version is released.

    Thank you!

    #801367

    Hi,

    That filter already exist in the theme but @victoria modified it so that the html classes will still be applied even if there are no caching plugins installed in the theme. Please provide the WP and FTP login details so that we can test your installation further.

    Best regards,
    Ismael

    #801369

    Hi,

    UPDATE: We were able to reproduce the issue. The cart icon is not displaying if the first option (“Header Shopping Cart Icon”) is selected in the “Header Shopping Cart Icon” settings and when the page is refresh. Please remove the filter then edit the config-woocommerce > woocommerce-mod.js. Replace it with the following script.

    // https://pastebin.com/FKgHQhuK

    Please remove browser cache or hard refresh after the modification.

    Best regards,
    Ismael

    #801385

    Thank you, will test it soon.

    The question remains though: Will this be fixed with the next release?

    #801394

    Hi,

    If the solution above works then it’s going to be included in the next update. We already reported the issue to Kriesi.

    Best regards,
    Ismael

    #801395

    That’s good news!

    I just tested it and can confirm that it works :)

    Thank you, Ismael.

    #801698

    Hi,

    Glad to hear that. Thanks for using Enfold :)

    Best regards,
    Nikko

    #830345

    It is still not working after upgrading to 4.1.2

    #831778

    Still broken for me with 4.1.2 also.

    Can we please get a confirmation as to when this will be fixed in the theme release?

    I can’t upgrade from 4.0.7 until you fix this bug. It’s been months.

    Thanks,
    Jason

    • This reply was modified 3 years, 1 month ago by  Jason.
    #833198

    Hi,

    Please remove the previous modification that we provided here then purge all cache or hard refresh the page. The patch is included in the latest version already. If you’ve added some css modifications for the cart, please remove those temporarily.

    Best regards,
    Ismael

Viewing 30 posts - 1 through 30 (of 66 total)

The topic ‘WooCommerce Cart Icon Broken – WooCommerce 3 / Enfold 4’ is closed to new replies.