Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1133784

    Hi,

    I use ENFOLD’s Instagram Widget and added this to a page created with ALB and this “widget area”.
    In ENFOLD 4.5.7 it worked perfectly.

    In ENFOLD 4.6 as well as in version 4.6.1, that I just installed, it worked so far as it fetches the images from Instagram correctly.
    It works, when I use the setting to open the images in a new browser tab, so it is not an issue of being something wrong with the images from Instagram itself.

    But when clicking on these images, they don’t open any more in the lightbox.
    Error message: “Image could not be loaded”.

    Don’t know if this has something to do with the new privacy settings, because I need an opt-in setting there?

    I deleted the Instagram cache folder in wp-content as @ismael suggested here, but this had not helped.

    See private data below. Thank you.

    • This topic was modified 1 year, 1 month ago by  BeeCee. Reason: works also not in v4.6.1
    • This topic was modified 1 year, 1 month ago by  Jordan Shannon.
    #1134901

    Hey COLORIT,

    Thank you for the inquiry.

    Did you verify your instagram account, or do you have a verified badge?

    // https://help.instagram.com/854227311295302

    We are still not sure why the widget is not working. All we know is that it’s not returning a valid data. Not being verified might have something to do with it.

    Best regards,
    Ismael

    #1135019

    The widget is working, it fetches the images and caches them, but opening these images in the lightbox does not work.
    Guess this is something different …

    No, I do not have a verified account or badge.

    #1135902

    Hi,

    Sorry about that. I misunderstood your inquiry. The lightbox is not working properly because the href value is invalid. The protocol in the url is duplicated. Please edit the framework > php > class-framework-widgets.php file, look for this code around line 2947:

    echo '<a href="https:' . esc_url( $item['link'] ) . '" target="' . esc_attr( $targeting ) . '"  class="' . $aclass . ' ' . $imgclass . '" title="' . esc_attr( $item['description'] ) . '" style="background-image:url(' . esc_url( $item[ $size ] ) . ');">';
    

    Replace the “https” part in the href attribute:

    echo '<a href="' . esc_url( $item['link'] ) . '" target="' . esc_attr( $targeting ) . '"  class="' . $aclass . ' ' . $imgclass . '" title="' . esc_attr( $item['description'] ) . '" style="background-image:url(' . esc_url( $item[ $size ] ) . ');">';
    

    Best regards,
    Ismael

    #1137107

    Thank you very much, this works fine now!

    Is this a bug with v4.6.2, where it still does not work like in v4.6 and v4.6.1?
    Because in 4.5.7 it worked fine – and with your fix it is also working fine now (my site is indeed running with https).

    #1137789

    Hi,

    You’re welcome! Glad it worked.

    Yes, this seems to be a bug. The protocol in the URL is not included previously, but now they added it in the image data, so it’s duplicated and broke the script. We’ll report the issue to the dev team.

    Best regards,
    Ismael

    #1137841

    Thank you, Ismael, you can close this ticket now, appreciate your help!

    #1138088

    Hi,

    If you need additional help, please let us know here in the forums.

    Best regards,
    Jordan Shannon

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘v4.6.1: Instagram Feed with cached images: lightbox not working any more’ is closed to new replies.