Viewing 30 posts - 1 through 30 (of 36 total)
  • Author
    Posts
  • #961975

    Hi,

    I have been using Thrive Architect builder on enfold and was able to finish the whole site.
    But after I have updated Thrive architect plugin it just stopped working. When you try to edit a page through Thrive Architect, it just loads forever.
    All my plugins are updated, Enfold is updated too.

    I tried using a different theme to test if its a theme conflict and the Thrive Builder worked on other themes.

    Please help check on it.
    The site is live.

    Thanks and regards.

    • This topic was modified 2 years ago by  LM2012.
    #962055

    Hi,

    I have the same topic. Just spoke with Thrive support. They said:

    “The most common cause of conflicts is different versions of jQuery loaded directly by one of your plugins or your theme.
    WordPress comes with jQuery included in /wp-includes/js/jquery/ and every theme and plugin should load it from there. However, some developers choose to include a different version of jQuery in their products and this might cause issues with ThriveThemes products.”

    Perhaps Enfold still loading the old WordPress Jquery library? I don´t use a Child Theme and don´t now how to change things like that. Need advice please.

    How can we fix that? Have to fix things because of GDPR.

    Thanks also for help.

    Best regards,
    Nicole

    #962924

    I tried to inspect through the browser console and these errors showed up.

    ReferenceError: avia_framework_globals is not defined[Learn More]
    avia_edit_dynamic_templtes.js:20:2

    ReferenceError: avia_framework_globals is not defined[Learn More]
    avia_dynamic_templates.js:20:2

    TypeError: $(…).avia_edit_dynamic_templates is not a function[Learn More]

    • This reply was modified 2 years ago by  LM2012.
    #962946

    Hi,

    Thank you for using Enfold.

    The theme loads the jQuery library with the default wp_enqueue_script(‘jquery’) function so it’s loading the latest version or at least the stable one. Where did you see these errors? Please provide a link to a test post or page.

    Best regards,
    Ismael

    #962953

    Hi,

    Try to edit the homepage using thrive architect, wait for it to load and the error will show on the console.

    Thanks and regards.

    #963027

    Hi,

    great to hear from you.
    The default is when editing ANY page with Thrive Architect.
    Here is a picture: https://www.screencast.com/t/yf3125Fr

    Thanks for quick help.

    Best regards,
    Nicole

    #963262

    Hello? Is there anybody who can help here?
    Or is there any other support-E-Mail address? I can`t work in WordPress. Since friday I am waiting for support here. Would be very glad for answers and help here. Am I in the wrong place here for Enfold support?

    Thanks for further advise.

    Best regards,
    Nicole

    #963585

    Hi,
    I have the same problems.
    “I have been using Thrive Architect builder on ENFOLD and was able to finish the whole site.
    But after I have updated Thrive architect plugin it just stopped working. When you try to edit a page through Thrive Architect, it just loads forever.
    All my plugins are updated, Enfold is updated too.”

    Please let me know …

    #963587

    I have reply here because I have the same error. Please Help me.

    #963681

    I asked for further help by Thrive Architect because of the missing service here.
    They released a new update – now it works again.

    Best regards,
    Nicole

    #963683

    Hey,

    @freelancer444 thanks for the info!

    @lightmerger and @syynapse, could you please try updating plugin as well and report back if issue remains?

    Regards,
    Yigit

    #963695

    Yes @lightmerger and @yigit
    Now work again.
    Thanks so much!
    But please note that in debug console I note follow error:

    sdm_editor_plugin.js?wp-mce-4711-20180425:76 Uncaught ReferenceError: sdm_admin_ajax_url is not defined
    at HTMLDocument.<anonymous> (sdm_editor_plugin.js?wp-mce-4711-20180425:76)
    at i (jquery.js?ver=1.12.4:2)
    at Object.add [as done] (jquery.js?ver=1.12.4:2)
    at n.fn.init.n.fn.ready (jquery.js?ver=1.12.4:2)
    at a.fn.init.n.fn.init (jquery.js?ver=1.12.4:2)
    at new a.fn.init (jquery-migrate.min.js?ver=1.4.1:2)
    at n (jquery.js?ver=1.12.4:2)
    at sdm_editor_plugin.js?wp-mce-4711-20180425:71

    • This reply was modified 2 years ago by  syynapse.
    #963706

    Hi!

    @syynapse it seems to be related to “Simple Download Monitor” plugin

    Cheers!
    Yigit

    #963721

    Thanks so much.
    Have a nice day.

    #963734

    Hi,

    You are welcome! You too!
    We will keep the thread open to hear from @lightmerger. Please feel free to start a new thread under Enfold sub forum if you have any other questions or issues :)

    Cheers!
    Yigit

    #1007001

    I also have a problem with Thrive Architect and Enfold

    When i import a Thrive Architect landingpage template from one of my other pages (where i use no enfold),
    it will not import the settings / changes for the mobile and tablet view. And it breaks some other small things like backgrounds.

    The LP file is in the media director if you want to try. When i change the theme to another than enfold, then it works. Also when the page is already imported.
    So it does not have to do with chache or any plugin ( which i checked before)

    Would be great if you solve this problem. Because i love to work with both in combination.
    Thanks Simon

    • This reply was modified 1 year, 9 months ago by  simonac.
    #1008095

    Hi,

    Please do consult with the Plugin developers, we do not offer compatibility from our side.

    Best regards,
    Basilis

    #1013137

    Did you ever resolve this?

    Here is a post, and video, illustrating the issue. I posted this on the Thrive support forums. It is NOT related to any 3rd party plugins.

    Thrive works fine in the WP2017 theme, but mobile views break in the Enfold theme.

    To eliminate the usual talk about 3rd plugin incompatibilities, I have

    A brand new WordPress Install
    The only plugin installed is Thrive Architect
    The only themes intalled are WordPress 2017, and Enfold

    #1013145

    Hi,
    Enfold ships with the advanced layout builder which is deeply integrated into the theme framework and which may conflict with other page builders. There’s (at least) no fix from our side.

    Best regards,
    Peter

    #1013149

    Right.

    So the fact that this worked perfectly well for the last 3 years and is now broken is no concern for you? And customers (like me) who have built multiple sites this way are now stuck.

    BTW, I’ve continued to test this with 12 other themes I have access to. No problems for any of them. I guess there is a lesson in there somewhere for me …

    Dude, I’ve loved the Enfold theme over the years. But I’ve also had to rely on Thrive and the ability to design landing pages with it.

    And I just wished that for popular combinations like this there was less finger pointing and an effort on both the Enfold and Thrive side to communicate and resolve such issues.

    #1013155

    Hi,
    I can understand your frustration but I do not consider this a popular combination. Popular plugins (which we support) are WooCommerce, BBPress, Yoast SEO, etc. If I search our Enfold forum with over 686,340 posts I get less then 50 relevant posts, around 20 of them are part of this thread. All page builders (Enfold’s ALB or Thrive Architect Builder) are very complex, hard to debug and even harder to debug if you’re not familiar with the code. It’s a question of time and resources on both sides and I do not consider this as finger pointing – the question is where to set the priority.

    That said – when I find some spare time I’ll contact the plugin developers and ask them to send me a copy (we can send them a copy of Enfold too btw). Maybe I’m lucky and can find the culprit.

    One possible reason I can think of could be a missing media script – this script is deactivated by default since Enfold 4.4.x (to increase the loading performance). You can activate it again by adding this code to your child theme functions.php:

    
    add_filter( 'avf_enqueue_wp_mediaelement', 'avia_always_load_mediaelement', 10, 2);
    function avia_always_load_mediaelement($condition, $options)
    {
    	$condition = true;
    	return $condition;
    }
    

    You also need to modify the functions.php file of the parent theme – this customization won’t be necessary with the next theme update. Open up enfold/functions.php and replace:

    
    $condition  = !( isset($options['disable_mediaelement']) && $options['disable_mediaelement'] == "disable_mediaelement" ) && av_video_assets_required();
    

    with

    
    $condition  = !( isset($options['disable_mediaelement']) && $options['disable_mediaelement'] == "disable_mediaelement" ) && av_video_assets_required();
    		$condition = apply_filters( 'avf_enqueue_wp_mediaelement', $condition, $options );
    

    Best regards,
    Peter

    #1013206
    This reply has been marked as private.
    #1013273

    I would love to see a solution here, too!

    Thanks

    #1013445

    Here is what the Thrive developers have found after investigating:

    Kurt wrote:

    Hello Juergen,

    Thank you for your patience.

    Our developers investigated this issue and it seems that the issue is a
    style-sheet that comes from the theme. Here’s the style and the elements being
    targetted: https://cl.ly/828d75e78405

    The style-sheet brings among many things a min-width to the HTML tag. Having
    this results in a non-responsive page.

    Here when you try to block the request from that style-sheet in Chrome
    Developer tools ( https://cl.ly/fca46fd0b21b ) and when this is loaded (without
    the themes CSS) the page becomes mobile responsive again:
    Image 2018-09-23 at 4.18.35 PM.png

    We’d recommend that you get in touch with your theme developer and have them
    fix the issue and this should work. This is a 3rd party application so we
    can’t help further here, it’s just outside of our support scope.

    Peter, could you comment on workarounds or ways to fix?

    #1014063

    Hi,

    I added this code to the quick css field:

    
    html.js_active{  min-width: auto; }
    

    Please check if it fixes the issue on your end too.

    Best regards,
    Peter

    #1014159

    Hi,
    this is not working on my end.
    Cleared all caches.
    Regards simon

    #1014371

    Hi,

    Please create me an admin account and post a link to the architect page – I’ll check why the code doesn’t work for you.

    Best regards,
    Peter

    #1014586

    Hi Dude,

    i tried the the code with important and now it works!

    html.js_active { min-width: auto!important; }

    Thanks.

    #1014595

    Hi,

    Great, glad it works now :)

    Best regards,
    Peter

    #1014993

    Hi Peter, Thanks from my end as well. I can confirm this is working.

Viewing 30 posts - 1 through 30 (of 36 total)

You must be logged in to reply to this topic.