Tagged: , , ,

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #908932

    I would like to bring to your notice, and looking forward to a resolution to this.

    See screenshot here:

    I don’t want Google to index these pages.

    I use All in One SEO (though I have used Yoast SEO plugin as well for one of the other website using same theme):
    I have marked them as NoIndex, see screenshot here: http://prntscr.com/ib7t9x

    But they still appear.

    If I block them using robots.txt then my website is marked as Unfriendly for Mobiles on Google Tool. As it is well known, the emphasis is more on Google Searches, and Google rates the mobile friendliness pretty highly, specially after AMP and things like that.

    Can you suggest a feasible solution. Thanls.


    Hey sigerik,

    Can you uncheck portfolio items? Maybe them being blocked is what Google does not like?

    Best regards,


    Portfolio items has nothing to do with the Framework pages that got indexed, probably you are not the right person to answer this. Can you pass it on to another more experienced and technically sound moderator.



    Actually you are right.
    We are note technically qualified to assist with SEO help or any other third party plugin.

    Please contact the plugin developers who will be able to help you further on how to use their plugin properly.
    If they raise an issue that comes with our theme on the way it is developed, we will be happy to help you out.

    Thanks a lot

    Best regards,


    It is not actually the issue with SEO plugin. I admire Enfold theme due to ease of use and customization, but these framework pages getting indexed is certainly an issue with it. So, no SEO plugin will address there. It is an issue specific to the Enfold theme.


    Lots of people are facing this problem, but with advent of Mobile First indexing, this issue needs to be addressed by Enfold team, because we cannot just block it using robots.txt, as it will make the website look mobile unfriendly by Google Mobile tool.




    The “Avia Framework” in the plugin’s noindex settings refers to theme’s text domain. It has nothing to do with the framework/avia_framwork.php file. Only post types should be included in that list, not text domains. You need to block the files via robot.txt or password-protect the directories (https://support.google.com/webmasters/answer/6062602?hl=en). I don’t really think there’s any other way.

    Best regards,


    When we block this directory, it leads to website showing as Mobile Unfriendly by Google Tool, that.



    Unfortunately, that is how google works and how things work.
    It is an automated robot that can go through the scans but there sults it output are not so accurate.
    Not something we can do from our side.

    Best regards,

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.