Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #277173

    Hello

    I recently found out that my website with Enfold theme making mysterious pages indexed on Google Search engines.

    Can you please tell mw what caused this issue and error?
    Attached you find the error of pages that get indexed by error?

    Google search: site:pengeportalen.com

    Results:

    Index of /wp-content/themes/enfold/config-layerslider
    pengeportalen.com/wp-content/themes/enfold/config-layerslider/
    Index of /wp-content/themes/enfold/config-layerslider. Parent Directory .DS_Store · LayerSlider/ · config.php · update.txt. Apache Server at pengeportalen.com …
    Index of /wp-content/themes/enfold/framework/css
    pengeportalen.com/wp-content/themes/enfold/framework/css/
    Index of /wp-content/themes/enfold/framework/css. Parent Directory .DS_Store · avia_admin.css · avia_colorpicker.css · avia_sidebar.css · conditional_load/.
    Index of /wp-content/themes/enfold/framework/images
    pengeportalen.com/wp-content/themes/enfold/framework/images/
    Index of /wp-content/themes/enfold/framework/images. Parent Directory . DS_Store · colorpicker/ · icons/ · layout/. Apache Server at pengeportalen.com Port 80.
    Index of /wp-content/themes/enfold/framework/images/icons
    pengeportalen.com/wp-content/themes/enfold/framework/…/icons/
    Index of /wp-content/themes/enfold/framework/images/icons. Parent Directory . DS_Store · accept.png · add.png · alert.png · bin_closed.png · blog.png …
    Index of /wp-content/themes/enfold/framework/images/layout
    pengeportalen.com/wp-content/themes/enfold/framework/…/layout/
    Index of /wp-content/themes/enfold/framework/images/layout. Parent Directory · FIND_API.jpg · arrow.png · bg-bottom-shadow.png · bg-button.png …

    #277228

    Hi!

    Refer to this article:
    http://www.ducea.com/2006/06/26/ (Purchase code hidden if logged out) -indexes/

    Regards,
    Josue

    #277230

    Hello

    Thank you for your answer, but I also read this article:
    https://kriesi.at/support/topic/ (Purchase code hidden if logged out) -folders/

    Could this article not solve the errors by adding this noindex to the google robot.txt?

    #277233

    Yes, try Peter’s solution first.

    User-agent: *
    Disallow: /cgi-bin
    Disallow: /wp-admin
    Disallow: /wp-includes
    Disallow: /wp-content/plugins
    Disallow: /wp-content/cache
    Disallow: /wp-content/themes
    Disallow: /*?*
    Disallow: /*?
    Allow: /wp-content/uploads

    Cheers!
    Josue

    #277245

    Is this copy/paste directly into google webmaster in the section google robots?

    #277253

    No, that should go in a robots.txt file located at the root of your installation.

    Cheers!
    Josue

    #316921

    I also have lots of unwanted pages indexed by google…
    A google search of indexed pages (site:websitename.com) returns many pages inside folder “shortcodes”

    My WordPress Address (URL) is http:website.com/blog
    My Site Address (URL) is http:website.com

    I tried the code mentioned above and also tried this:

    User-agent: *
    Disallow: /cgi-bin
    Disallow: /blog/wp-admin
    Disallow: /blog/wp-includes
    Disallow: /blog/wp-content/plugins
    Disallow: /blog/wp-content/cache
    Disallow: /blog/wp-content/themes
    Disallow: /blog/*?*
    Disallow: /blog/*?
    Allow: /blog/wp-content/uploads

    But I’m getting “allowed” for lots of enfold content from the dummy data I guess (although I did not publish it – draft only) like http://websitename.com/homepage/home-v5/ and from a “shortcodes” folder.
    pages like: http://websitename.com/shortcodes/promo-box/

    Should these disallow statements have a slash on the end of them /blog/wp-content/themes/ ?

    Plus, I guess, how do I get rid of the dummy data? I thought that not publishing it (setting it as draft only) would keep it from being indexed while I learned how to use the various options…wrong I guess ;{

    #316947

    Hi!

    Those pages should only be accessible to logged users, perhaps at one point they were public and were crawled, give it a few weeks to re-index or use the Webmasters removal tool:
    https://www.google.com/webmasters/tools/removals?pli=1

    Cheers!
    Josue

    #666780

    Hey there!

    I’ve added what you suggested above; however, Google is still indexing all of that stuff. I’ve recently added a subdomain and despite I tried to discourage it from happening, it did, so now there’s a long list of “index of” items on the results. Any more effective approach to this annoying matter, pls?

    Great thanks!

    hacart

    #666833

    Hi,

    Can you post the link to your website please?

    Regards,
    Josue

    #666923

    Sure,

    http://www.casadelmedia.com

    subdomain:

    hache.casadelmedia.com

    The thing that makes is suspicious is that I know the indexing is working good, cos’ I published some articles recently. By this time all those “index of” should have desappeared long ago.

    Best,

    hacart

    #666939

    Hi,

    Please refer to these two links and let us know if that helps.

    https://support.google.com/webmasters/answer/1663419?hl=en

    https://support.google.com/customsearch/answer/2631051?hl=en

    Best regards,
    Vinay

    #667930

    Hey Vinay,

    Thanks for answering. I’ve sent the the URL deletion requests through the Search Console and they were apparently solved, so thanks again!

    Best,

    H.

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘Issue with indexing of theme on Google’ is closed to new replies.