Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1395137

    I was unable to reply to Yigit as post was marked as closed. So had to open a new post…
    https://kriesi.at/support/topic/speed-up-backend/#post-1395113
    ———————————–

    Hiya,
    Sorry I have come across more problems that appear to be related to PHP?
    These errors display with the Query Monitor:

    I have logged into Plesk’s php settings but they appear to be set up in the same way as the error says???

    • This topic was modified 5 days, 12 hours ago by ColinWalton.
    #1395214

    Hey ColinWalton,

    Sorry about that, I think Yigit misunderstood your post. The warnings you posted are not related the theme, you might want to try reaching out to your hosting provider to see if they can give you an explanation as to why they are appearing.

    Did you install the plugin I recommended, and did it give you any clues as what could be the problem on your installation?

    Best regards,
    Rikard

    #1395216

    No worries.

    Yes the plugin has shown up loads of odd problems amounting to this site being grindingly slow.

    I have a feeling the hosting company will say it is beyond their remit in their eyes.

    It is the php errors that are on every page I am most worried about – and presumably they are the main cause of the delays. (see in private)

    Not to worry if it isn’t something you can look into. I will have to sort it out somehow.

    Thanks, Colin

    #1395242

    Hi,

    Thanks for the update. Do the same errors appear if you switch to a different theme? You could also try to deactivate all plugins, and remove any custom code you might have added.

    Best regards,
    Rikard

    #1395333

    Hi Rikard,

    Just tried using Twenty Twenty One theme and the same problems are there, except only one of each total 2.

    Using Enfold I get 3 warnings with two each total 6.

    It’s the same error though : (

    #1395343

    PS, I have kept the Twenty Twenty One theme active still. Then disabled all the plugins.

    In a new tab I have opened the back end of one of the pages to see if the error occurs.

    Going through them all the culprit looks to be SHORTCODER, with a total 2 php errors as above.

    BUT as soon as I switch to Enfold I get a drastic decrease in back end speed – from 2 seconds to 7.8.

    There also is a script error on the Theme Options page of enfold:
    Missing Dependencies avia_template_save_js (xdomainnamex) wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/js/avia-template-saving.js avia_element_js (missing) 5.4

    Keeping Shortcoder inactive I went back to the same page I did the testing above I get the same PHP errors as before and it gets grindingly slow again at 12 seconds to display the page.

    Warning is_file(): open_basedir restriction in effect. File(/en.js) is not within the allowed path(s): (/var/www/vhosts/xdomainnamex/:/tmp/) 2 +
    wp-includes/class-wp-editor.php:516
    WordPress core
    Warning is_file(): open_basedir restriction in effect. File(/en_dlg.js) is not within the allowed path(s): (/var/www/vhosts/xdomainnamex/:/tmp/) 2 +
    wp-includes/class-wp-editor.php:520
    WordPress core

    Reactivating Shortcoder increases the refresh time on the plugins page from 2 seconds to 12 ! But no errors.

    Refreshing the test page the PHP errors totalled 4 when shortcoder was deactivated, but now go to 6 when activated and a refresh time of 11 seconds.

    So although Shortcoder seems to be a problem, Enfold itself seems to be a problem too.

    I hope this all helps!

    C

    #1395362

    Hi,

    I closed the thread after you said everything was okay. When editing your posts, please do not remove your initial post and add an “edit” section instead :)

    It seems like suggestions here: https://hoststud.com/resources/how-to-fix-the-wordpress-warning-open_basedir-restriction-in-effect-issue.878/ will fix the issue you are having. Could you please check if that helps?

    Best regards,
    Yigit

    #1395366

    Reading through this it’s going to generate another load of problems!

    Why would I want to change the uploads folder and change the URL to all files?

    By web-config do they mean web.config?

    Oh and this line: If that doesn’t work, create a new .htaccess file and replace old files with new ones. Huh?

    As far as I can see the problem hasn’t be caused by ME ??? Why do other sites using Enfold and Shortcoder NOT have this problem??

    Sorry not to be more enthusiastic.

    #1395369

    PS see query below

    #1395402

    Sorry for being a bit grumpy about your reply. I know you are trying to help and I am grateful!

    I suddenly remembered the log files on the server which seem to perhaps give some clues as to what is going wrong. See below

    Thanks

    #1395890

    I have finally found the answer!

    In Plesk php settings for my website the open_basedir needs to be set to NONE !

    Refresh the screen and it all works.

    #1395894

    Hi,

    Glad you figured it out and thanks for sharing your solution!

    Best regards,
    Yigit

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.