Viewing 24 posts - 1 through 24 (of 24 total)
  • Author
  • #1259652


    I have a 3rd party form I am trying to insert in a code block. Inserting it works fine (despite the warnings in red below the entry) however, when I go back to the page, the block is broken and I am unable to edit. I tried replacing the <>[] with the suggested ###gt###, ###lt###, ###91###, ###93### but the front end just displays the raw code instead. Help!



    Hi Amanda,

    The default WordPress login URLs are not working on your site, please share the login URL in private as well.

    Best regards,


    Sorry about that. The URL is below.



    Thanks for that. The code block on the contact page looks broken unfortunately, could you share the full code which you are trying to use please?

    Best regards,


    Hi! Code below in private section…



    Thanks for that. I tried the code you posted on a local installation, but it’s breaking the code block element unfortunately. I tried it in a WordPress widget as well, but it’s not working there either. Please see screenshot in private. There looks to be something wrong with the code you are trying to use, could you try to reach out to the authors of the code to see if they can help you out please?

    Best regards,


    OK will do – thanks for your help.


    Dear all, I am facing the very same issue as stated above. Pls see code-snippet shared in private content.
    I have followed all steps mentioned in
    But no success yet.
    Thanks for sharing some thoughts on this one, Christoph.


    Hi Christoph,

    Where can we see and reproduce the problem you are having? Also, what is the code you posted supposed to do? You could try to replace all ” characters with


    and all ‘ characters with


    to see if that works.

    Best regards,

    • This reply was modified 2 years, 6 months ago by Rikard.

    Hi Rikard,
    thanks for following-up. I have tried out your recommendation but no luck.
    Enfold is throwing:
    Warning: Characters <,>,[,] might break ALB backend or frontend. Read more if you want to use them.
    Hence, the issue lies within < > and [ ].

    Use Case on my end:
    This code wraps a Mautic-form as manual copy in order to cope with decent styling.
    Main-connection to Mautic is being established by Plugin:
    This has been working fine ever since. Just recently, I am getting this warning in Enfold-Code-Block.
    And once I publish a page, backend is getting corrupted and I can no longer edit an existing page.

    Let me share creds below for reproduction on your end.



    Thank you for the inquiry.

    You may need to use this plugin in order to properly use those symbols in the text or code block element.


    As described above, you will have to use special placeholders for the symbols such as ###lt### for less than symbol or ###gt### for greater than symbol and the plugin will then convert these placeholders to the actual symbols in the front end.

    Best regards,


    Hi Ismael, thanks a lot for sharing. I have executed all mentioned steps.

    Current Result:
    Content of Code-Block is shown as clear-text after publishing the page.

    Code-Block should show formatted form.

    Thanks for sharing further insights on this one.


    i’m in the same boat as @cz – the “Code Block” seems to be useless lately. i used to be able to enter <style>css code</style> and <script>js code</script> and any other html. but now, it’s ignored. if i replace all the greater-than/less-than symbols with ###lt### and ###gt### then all the code is simply printed in plain text on the frontend webpage.

    and yes, i have the special characters plugin installed & activated.

    this didn’t used to be an issue. i noticed the red warning text “Warning: Characters <,>,[,] might break ALB backend or frontend. Read more if you want to use them.” appeared recently after an update – i’m not sure if it was a WordPress update or Enfold update (or both) that caused this.

    is it possible to have custom code like we used to with the Code Block? is there another method of entering custom code that will work as expected?


    fyi, just discovered if i minify the code, then it seems to work (at least in my single test instance). curious if others try this if it works consistently.

    to be clear, i have a Code Block and in it put…
    <style>minified single line of css code here</style>
    <script>minified single line of js code here</script>


    Hi SyberKnight,

    Could you share example code which is not working please?

    Best regards,


    Hi @SyberKnight @Rikard – thanks for sharing. The code itself is working when published with special characters. The issue on my end is that once the page is published it does affect backend and I can no longer edit an existing page. Need to start from scratch for every single page. – FYI. Thanks.



    I actually missed the info about adding internal styles. Adding internal style using the code block element should work fine even without the plugin that we mentioned above.

    Adding this css style in a code block works properly on our own installation.

    body { 
      display: none !important; 

    Please test it on a fresh installation without plugins to see if it works.

    Best regards,


    Hi @ismael – thanks a lot for sharing.

    Tested with a plain instance running on enfold 4.5.6 – in this scenario, the alert for special characters in code-snippet does not prompt and the site as well as edit-mode in enfold are working fine.

    However, doing the same steps on my PROD-instance with enfold, I can add the code along with the style. After publishing, the site works fine and the integrated form with styles is being shown as expected.

    Current issue remains:
    Navigating to edit-mode of the published page is breaking back-end and does show edit-mode in non-workable way.

    I am still at the starting-point. Hope you do have some additional hack ready.

    Thanks for following up on this one.



    Current issue remains:
    Navigating to edit-mode of the published page is breaking back-end and does show edit-mode in non-workable way.

    Do you mean that you cannot edit the text block after adding the style? Please post the style or code that you are trying to add to the code block using pastebin so that we could test it on our own installation.

    Best regards,


    Hello, I also have display problems, I added your plugin, modified the code as you indicate, but it’s buggy! Need help please


    Hi Ismael,

    correct, after pasting to Code-Snippet and publishing the page, editing page is no longer working.

    Let me add contents below as private.

    Thanks for checking on this one.



    : You do not have to use the conversion plugin for that snippet. Please try to add the snippet as is without using the placeholders for the less and greater than symbols.

    : It is probably not working because of the textarea or the input fields. You may need to create a custom shortcode for the form or the input fields so that you do not have to embed them directly in the code block. Please check the shortcode API on how to create custom shortcodes.


    Best regards,


    Hi @ismael – thanks a lot for your input.
    Tested with
    Result: working as expected.
    Thanks, Christoph.



    Glad to know that it is now working. Please do not hesitate to open a new thread if you need anything else. We will keep this one open for the OP.

    Best regards,

Viewing 24 posts - 1 through 24 (of 24 total)
  • You must be logged in to reply to this topic.