Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1150607

    After updating Enfold from 4.5.x to latest version we noticed the following:

    – Additional Google Fonts used in header is replaced by a default font
    – Contact form with reCAPTCHA displays the following msg: “This contact form is deactivated because you refused to accept Google reCaptcha service which is necessary to validate any messages sent by the form.”
    – Google maps in our custom footer using the following plugin “WP Google Map Plugin” is not displayed at all, only a text msg “Maps were disabled by the user”

    After some investigation we found this is related to the new Privacy and Cookies settings in Enfold 4.6
    This is not a good first impression for the new visitors!

    What settings can be used in Privacy and Cookies so all 3 points above are displayed on our site as they should?

    I have the following settings in Privacy and Cookies:
    “All cookies and services are accepted on first page load, user can opt out”

    It sounds this should make everything work? But it doesn’t so I’m not sure what this setting does.

    Currently the visitors of our site have to click the accept cookies button, after that, the page reloads and everything is working.
    But again, not a good fist impression. I want everything to work without the user having to click accept, and instead can choose to opt out.

    • This topic was modified 1 month, 2 weeks ago by  belinger.
    #1150980

    I also just noticed that the privacy and cookies box does not work at all in Safari and latest version of Enfold. It is not displayed at all. I tried switching between the different message bar positions but it does not appear in Safari no matter what. In Enfold 4.5.x it worked perfectly. (Yes I deleted all cache and cookies before testing)

    #1151800

    Hi,

    Thank you for the inquiry.

    Where can we see the issue? Services such as the Google map and fonts should work immediately on page load when the cookies are set to be silently accepted on load, even when the user hasn’t consented to the cookies yet. Did you install the most recent version of the theme v4.6.3.1? If the site is already using the latest version of the theme, please try to toggle the Performance > File Compression settings to regenerate the scripts and stylesheets.

    Best regards,
    Ismael

    #1152098

    Ok so this problem is caused by WPEngines inbuilt cache-system.
    I don’t know if this is a common problem with different caching plugins or some specific case for WPEngine.
    I talked to their support and here is their answer:

    “Okay so in chatting with my colleague the caveat is that if the cookie travels with the user from page to page then we would have to exclude all pages which can put a strain. So the best way to go about this is to reach out to the theme developer and see if they can program the theme to where that won’t be the case or possibly handling session data via javascript.

    However getting the cookie name from the developer can be an easier route so we can possibly exclude it.”

    That last sentence, getting the cookie name from the developer. What is the cookie name?

    #1152348

    Hi,

    Thank you for the info.

    The name of the cookie is “aviaCookieSilentConsent”. It enables the services on load, even without the users’ explicit consent. Let us know if that’s what the WPEngine guys need. They might want to exclude the following cookies as well.

    aviaCookieConsent
    aviaPrivacyRefuseCookiesHideBar
    aviaPrivacyEssentialCookiesEnabled
    aviaPrivacyGoogleTrackingDisabled
    aviaPrivacyGoogleMapsDisabled
    aviaPrivacyGoogleReCaptchaDisabled
    aviaPrivacyGoogleWebfontsDisabled
    aviaPrivacyVideoEmbedsDisabled

    Best regards,
    Ismael

    #1153111

    Okay so we got everything working in IE, Firefox and Chrome thanks to WPEngine
    But problem still remains in Safari:

    1. Cookie module/infobox is not visible/does not work at all. So no visitor using Safari can read any info about cookies or choose to opt-out. This is a bug in Enfold that needs to be fixed! It has nothing to do with any caching as caching is turned completely off on our staging environment in WPEngine
    2. After WPEngine excluded the cookies, the Enfold setting “All cookies and services are accepted on first page load, user can opt out” makes it so that for the most part things loads as it should in Safari (google fonts and Contact form with reCAPTCHA), except for 1 important part of our website. Enfolds Google maps module. It does not load at all. No error message, just a blank white space on our website.

    Here is some more technical details what WPEngine did to make everything work in IE, Firefox and Chrome (But it does NOT work for Safari) if its any help for you:

    “So initially it looks like we wrote an argument to exclude a lot more than just the cookies or specific avia args from cache; it was essentially uncaching the primary path of the site; rather than nested paths like I was trying; or the cookie arguments / avia args – so I re-applied that rule; but typically it’s best practice on our end (and general cache rules) to not let the homepage be served that way; since, depending on traffic, it’ll result in the occasional 50x for a user or two; but if you’re not experiencing heightened traffic that elicits evictions; it can solve most cache issues”

    #1154885

    Hi,

    Thank you for the update.

    Where can we see the issues? Please provide a link to the site so that we can inspect it. And make sure that it contains the latest version of the theme, v4.6.3.1.

    The following thread might help fix the consent bar issue on the Safari browser.

    // https://kriesi.at/support/topic/enfold-google-maps-dont-work-at-multilanguage-page/#post-1153139

    Best regards,
    Ismael

    #1155094

    I tried replacing /enfold/js/avia-snippet-cookieconsent.js file with this one – https://github.com/KriesiMedia/enfold-library/blob/master/temp_fixes/Enfold_4_6_3/avia-snippet-cookieconsent.js as mentioned in the post above, but it didn’t help.
    Google maps is still not visible in Safari. Everything works perfect in IE, Firefox and Chrome. The problem is ONLY in Safari.

    I provided link in private content

    #1155451

    Hi,

    Thank you for the update. Did you toggle the Performance > File Compression settings after adding the code? Toggling the option on or off will regenerate the scripts and ensure that the changes are applied. Or post the login details in the private field so that we can check the issue further.

    Best regards,
    Ismael

    #1155704

    Yes I’ve tried that, didn’t help. Problem remains in Safari, all other web-browsers works perfectly
    Provided details in private content

    #1156507

    Hi,

    Yea, this is an issue of Safari because it is not following the latest Web Design trends.

    Best regards,
    Basilis

    #1157256

    So what can we do about it? Most people using Apple products including Macbook and iPhone/iPad are using the default Safari browser.
    We cant use this module at all until this is fixed. And its pretty important for us to display this information as we are located within EU:s rules of Cookies and GDPR.

    #1158190

    Any update on this?

    #1158458

    Hi belinger,

    Please try the solution posted here:

    If you need further assistance please let us know.
    Best regards,
    Victoria

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.