Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #1376993

    some time ago you did some changes for me in the enfold/config-wpml/config.php
    see thread:
    Since I updated to Enfold 5.3.1 the WPML switcher is not shown anymore.
    I tried to put the old changes in the new enfold/config-wpml/config.php but it does not work.
    I hope you can help me. More informations please find in PC

    The other problem is:
    I would like to have my links in text underlined
    I think it have to do with the new css
    #top a:where(:not(.wp-element-button)) {
    text-decoration: none;

    Found another strange thing: on the blog sidebar the link to the archive page is not working. It opens always the startpage

    Thank you for any help and best regards

    • This topic was modified 5 months, 1 week ago by walhai.

    Hey walhai,

    Thank you for the inquiry.

    Would you mind providing a screenshot of the previous flag switcher or of the previous modifications made to the switcher? You can use imgur, savvyify or dropbox for the screenshot. Thanks.

    Best regards,


    Hi Ismael
    Thank you for answering.
    Please find in PC a link to the staging site, where the flag switcher is working.
    I think you did some modifications in October:
    If you need anything else, please contact me.
    Thank you and best regards


    Thank you for the link to your staging site, as I see your language switcher looks like this:
    I see this on both sites, and the url changes on both sites to /en/ for English but the text doesn’t change to English on them, when I check the backend neither seem to have any translated pages:
    is this what you mean?

    Best regards,


    Hi Mike,
    thank you for the answer.
    Yes, this problem is solved. We had to mark in enfold header “Show the default language flags”.
    In the version before the update, this was not allowed.
    Translation is coming later.

    The problem with the underlined links solved my partner with a lot of tricky css. It is working now.

    Still not solved:
    on the blog sidebar the link to the archive page is not working. It opens always the startpage

    Maybe you can help me with this.
    Thank you and have a good new year!


    Your archive link is not correct, it should be a month and year but yours is only showing the year:
    I commented out this custom function on your staging site:

    // Blog Archiv nur Jahre anzeigen
    function my_limit_archives( $args ) {
        $args['type'] = 'yearly';
        return $args;
    add_filter( 'widget_archives_args', 'my_limit_archives' );
    add_filter( 'widget_archives_dropdown_args', 'my_limit_archives' );

    and now your archive links are working correctly:
    Try this on your live site.

    Best regards,


    Thank you!
    That is the problem. Before the enfold update (like staging site) it worked with this function.
    After the update it is not working.
    But I would like to have the archive only in years. Is there a possibility?

    Best regards


    I tested your custom function on my test site using v5.3.1.1 and it worked for me without any plugins, try updating to v5.3.1.1 and checking, if it still doesn’t work then disable all of your plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    Best regards,


    Hi Mike,
    thank’s. You are right.
    I found the it: it is the Yoast Seo Plugin which causes the problem.
    Until know it did not find anything to solve this.
    There have been some similar problems in the forum (permalinks…)
    I tried some things but no luck until know.
    Best regards


    Glad to hear that you have this sorted out, and thanks for sharing your findings. If you have any further questions please create a new thread and we will gladly try to help you. Thank you for using Enfold.

    Best regards,

Viewing 10 posts - 1 through 10 (of 10 total)
  • The topic ‘Problem with WPML since update to 5.3.1’ is closed to new replies.