Viewing 30 posts - 1 through 30 (of 37 total)
  • Author
    Posts
  • #1007284

    See private content for more details.

    #1007292
    This reply has been marked as private.
    #1007521

    Hi,
    Thanks for the link, the page was password protected for me using Chrome, actually the password you posted didn’t work so I was unable to see the protected content, which is fine because you only wanted to make sure it was protected.
    Please see the screenshot in Private Content area.
    Unless there is anything else we can assist with on this issue, shall we close this then?

    Best regards,
    Mike

    #1007523
    This reply has been marked as private.
    #1007570

    Hi,
    I found many people have had this issue using the default WP theme, this was the only solution that I found…

    I had this

    <meta name="referrer" content="no-referrer">

    in the -section of the template.
    Once removed, the password protection works again!

    it seems to be a new WP issue, let us know if this helps.

    Password Protected Pages Not Working
    Password protected page not accessible / wp-login.php?action=postpass error

    Best regards,
    Mike

    #1007577

    Hi,
    I did some more testing using Chrome incognito, and found that if I try to login I get redirected back to the login prompt, but if I do a “hard refresh” the page shows.
    2018-09-09_062615

    So I believe that this is related to caching, are you using any caching plugins?
    I did find another post on the WordPress forums that talked about your issue and caching, which makes since now:

    We had to add our password protected pages to the “do not cache” list which seems to have resolved it.

    So if you are using a caching plugin try to exclude the page from the cache, if you are not using a plugin but are using WP Engine, try adjusting the cache-control headers

    Please let us know if this helps.

    Best regards,
    Mike

    #1007884
    This reply has been marked as private.
    #1007921

    Hi,
    The code above was not to be added, but removed, I checked your site and you don’t have it, so your good on that.
    Are you using WP Engine as your host? If so they use server side caching, so I would ask them to help with a rule to not cache the page. They probably have seen this before and can assist. I looked at “WP Engine Advanced Cache” but don’t see a exclusion setting.

    If you are not on WP Engine the plugin won’t help, but I would still ask your webhost to deactivate the server caching, at least to test.

    Another possible solution could be to try adding this code to the end of your functions.php file in Appearance > Editor:

    	function add_nocache_meta(){
    		if ( is_page('3746') ) { ?>
    		<meta http-equiv="Cache-Control" content="no-cache, no-store, must-revalidate" />
            <meta http-equiv="Pragma" content="no-cache" />
             <meta http-equiv="Expires" content="0" />
    		<?php
    		}
    	}
    		add_action('wp_head', 'add_nocache_meta');

    It is designed to give the no-cache headers on your one page.

    Best regards,
    Mike

    #1007972
    This reply has been marked as private.
    #1007990
    This reply has been marked as private.
    #1008066
    This reply has been marked as private.
    #1008136

    Hi,
    We will keep this ticket open, can you create a test page that is password protected and include a admin login so we can continue to test. I would like to ask the rest of the team to take a look at this for their thoughts.
    I tried to reproduce this on my localhost, but couldn’t.

    Best regards,
    Mike

    #1008440

    Hi Mike,

    Here’s a test page and link to work on, along with the password:

    Is it possible to receive a status update by Thursday, 9/13? My client would like to get this resolve in the next week now. It needs to be ready for a client meeting since a majority of people using this page will be Chrome users.

    Thank you,
    Christy

    • This reply was modified 3 years ago by  Mike. Reason: moved password to Private Content area
    #1008999

    Hey Mike,

    I didn’t realize my last reply wasn’t private. Can you and your team change the password of that admin login to be on the safe side?

    Thank you,
    Christy

    • This reply was modified 3 years ago by  Mike. Reason: password updated per customer request
    #1009040

    Hey!
    I noticed an “insecure content warning” in Google Chrome (which means resources are loaded over http:// urls and not secure https:// urls). I fixed this warning by replacing the http:// favicon url (Enfold > Theme Options) with a https:// url. Please check if this solved the password protection issue too.

    Cheers!
    Peter

    #1009058
    This reply has been marked as private.
    #1009468

    Hi,

    The issue is probably caused by cookies which are not stored/accepted by Chrome. WordPress uses cookies to save the password and to unlock the content. Maybe a browser extension breaks or blocks this cookie. Did you try to deactivate all Chrome browser extensions?

    If yes this post: https://en.forums.wordpress.com/topic/cannot-access-password-protected-pages-using-chrome/ suggests to clear the “browser data, including browsing history, download history, cookies and other site and plug-in data, saved passwords and Auto-fill form data via Tools/Clear browsing data.”

    Best regards,
    Peter

    #1009684
    This reply has been marked as private.
    #1009737
    This reply has been marked as private.
    #1010066

    Hi,

    Based on the screenshots and the fact that the unlocked website shows up after some minutes I’m pretty sure it’s not a cookie issue. However it indicates that the password page is cached for a few minutes by the Chrome browser and thus the browser does not show the “updated/unlocked” content.

    We’ve tried installing the latest Enfold theme update, but it hasn’t been successful. My supervisor has installed it twice and I got an error message “Download failed. A vaild URL was not provided” when I tried installing it again. Has the update gone away?

    No but this is a known bug in the Envato update api. We found a fix/workaround for it on our end and we’ll include it with the next update. You can add this fix manually – use the theme editor (Appearance > Editor) and edit Enfold. Go to enfold/framework/php/auto-updates/ and open the class-pixelentity-theme-update.php file. Clear the entire file (remove the code) and copy the entire code from here https://pastebin.com/raw/epetJ1SG into the blank file. Afterwards save the file and the update should work.

    You can also use ftp to update the file. Save the code from here: https://pastebin.com/raw/epetJ1SG to a file called class-pixelentity-theme-update.php. Then connect to your server via ftp, go to the directory wp-content/enfold/framework/php/auto-updates/ and overwrite the class-pixelentity-theme-update.php with the updated file you created before.

    Best regards,
    Peter

    #1010129
    This reply has been marked as private.
    #1010131

    Hi,

    We’ve no ETA for the next update yet – I’d recommend to patch the file manually.

    Do you think having the update helps resolve the issue?

    I’m not aware of any changes or fixes regarding this issue but it’s worth a try.

    You could also try to switch to a third party plugin like https://wordpress.org/plugins/content-protector/ which might work better for you. I’ve not tested it with Enfold but I’m pretty sure it will at least work with the “Default Editor”.

    Best regards,
    Peter

    #1010539
    This reply has been marked as private.
    #1010691

    Hi,

    To be honest I don’t know other plugins to protect pages with a password.

    Another possible solution would be to protect your pages by simply hiding them from the public. Make sure the page is not indexed by a search engine (set the robots meta to noindex and nofollow) and use a random slug for the page (i.e. you could generate a long hash here: https://hashgenerator.de/ and use it as a slug). Then you could send out the url with the random slug (let’s say it looks like https://mywebsite.com/8617f366566a011837f4fb4ba5bedea2b892f3ed8b894023d16ae344b2be5881 ) to your users and it works like a password you send to them. With such a slug it’s impossible for others to guess the right url, also search engines won’t find it unless you add it to the sitemap.

    Best regards,
    Peter

    #1011035
    This reply has been marked as private.
    #1011195

    Hi,

    If I stumble over a solution for your problem I’ll let you know asap.

    Best regards,
    Peter

    #1011498
    This reply has been marked as private.
    #1011515

    Hi!
    Please update Enfold to the latest version (4.4.1) and I’ll try to reproduce the issue on my end. Please use ftp ( https://kriesi.at/documentation/enfold/how-to-install-enfold-theme/#ftp-install ) to update the theme. Make sure to replace the entire theme folder. If you just overwrite the existing files you’ll get a blank page (500 error). Connect to ftp, go to wp-content/themes and rename the theme folder “enfold” to “enfold_bak”. Then download the new files from themeforest, unzip the theme files and upload them to wp-content/themes/enfold. Make sure the style.css file is located in wp-content/themes/enfold (file path wp-content/themes/enfold/style.css). If the theme works, you can simply delete the enfold_bak folder. If not, delete the enfold folder and rename enfold_bak to enfold.

    Cheers!
    Peter

    #1011523

    Hi,
    I have seen the password option used on many Enfold sites that we assist with working without issue.
    I have a clean install test site in the Private Content area that I set a password to that is working correctly, please check.
    I only thing I can think of that might be causing your issue is a rule in your .htaccess file, perhaps if you can post it’s content here we can take a look at it.
    I tried looking back, but did you try disabling all of your plugins?
    Until we figure this out, you could put a notice on your page that says to may need to reload the page, but it’s really not much of a solution.

    Best regards,
    Mike

    #1011945
    This reply has been marked as private.
Viewing 30 posts - 1 through 30 (of 37 total)

You must be logged in to reply to this topic.