Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #1438297

    Hi Support,

    I am using your Enfold theme on a website and I have an issue where video has no sound on ALL browsers on my iPhone (Safari, Chrome, Firefox).

    On my iPad the same video DOES have sound using Safari and Firefox, but NO sound using Chrome.

    The sound plays correct on all desktop browsers.

    Please let me know if there is a way to fix this issue.

    Thanks
    Scott

    • This topic was modified 2 weeks, 5 days ago by scotthill89.
    #1438408

    Hey Scott,

    Thank you for the inquiry.

    You cannot directly control the volume of the video on mobile phones, especially on iOS devices. You will need to use the physical buttons of the device to adjust the volume. However, since the video is set to autoplay, it initially plays muted. You have the option to disable autoplay, unmute the video, and allow users to manually play it.

    Best regards,
    Ismael

    #1438460

    Hi Ismael,

    On my iPhone the video has NO SOUND AT ALL! There is not an option to turn the volume on or even up. Eve with the volume controls on the device. It’s muted without any controls at all on ALL browsers on the phone.

    On my iPad the same video DOES have sound using Safari and Firefox, with an icon to turn the volume on or off. But there is NO sound using Chrome and there are no icon to even turn the volume on or off.

    This is the issue I am trying to fix.

    Thanks
    Scott

    #1438518

    Hi,

    On my iPhone the video has NO SOUND AT ALL!

    It’s because the video is muted. You can adjust this in the Video element’s Content > Player Settings toggle. Please note that when autoplay is enabled, the theme will automatically mute the video because unmuted autoplay is not allowed (link below). If you prefer your video to remain unmuted, you’ll need to disable the autoplay option and let the users manually play it

    // https://developer.chrome.com/blog/autoplay#:~:text=Muted%20autoplay%20is%20always%20allowed,previously%20played%20video%20with%20sound.

    Chrome’s autoplay policies are simple:

    Muted autoplay is always allowed.
    Autoplay with sound is allowed if:
    The user has interacted with the domain (click, tap, etc.).
    On desktop, the user’s Media Engagement Index threshold has been crossed, meaning the user has previously played video with sound.

    Best regards,
    Ismael

    #1438553

    Hi Ismael,

    The settings in Enfold for the video is NOT SET TO MUTE!
    There is STILL NO OPTION FOR SOUND AT ALL ON ALL PHONE BROWSERS!!!

    AGAIN…
    On my iPhone the video has NO SOUND AT ALL! There is NOT AN OPTION TO TURN THE VOLUME ON OR EVEN TURN THE VOLUME UP. There is NO ICON TO TURN ON THE VIDEO SOUND ON AT ALL ON PHONE BROWSERS! Even with the volume controls on the device. It’s muted without any controls at all on ALL browsers on the phone.

    On my iPad the same video DOES have sound using Safari and Firefox, with an icon to turn the volume on or off. But there is NO sound using Chrome and there are no icon to even turn the volume on or off.

    The settings in Enfold for the video is NOT SET TO MUTE! The video DOES HAVE SOUND using Safari and Firefox ON IPAD, with an icon to turn the volume on or off. THERE IS NO OPTION FOR SOUND AT ALL ON CHROME. THERE IS NO ICON AND NO OPTION TO TURN ON SOUND AT ALL!

    PLEASE HELP WITH THIS PROBLEM!
    Scott

    #1438875

    Hi,

    The settings in Enfold for the video is NOT SET TO MUTE!

    Yes, that is correct, but it is set to autoplay, and as we mentioned before, the theme automatically mutes the video if autoplay is enabled. Please review the link to the browser policy for autoplay provided above.

    Best regards,
    Ismael

    #1438909

    I understand that the videos are muted with autoplay on.

    The problem is there is NO WAY TO UN-MMUTE THE VIDEO AT ALL. IT CANNOT BE UN-MUTED ON ALL BROWSERS ON THE PHONE! There is NO option to click anything anywhere and UN-MUTE the volume on ANY browser on the phone. If you click the video it just pauses it. IT DOES NOT UN-MUTE the video. There is NO option to click the sound icon and turn the sound on AT ALL! It’s COMPLETELY MUTED WITH NO OPTION AT ALL TO HEAR THE SOUND AT ALL ON THE THE PHONE.

    Same issue on Chrome on the iPad. There IS NO WAY AT ALL ANYWHERE TO TURN THE VOLUME ON! Click the video DOES not turn on the SOUND! There is NO icon anywhere to turn on the sound!

    How can you hear the video sound on a phone?

    Thanks
    Scott

    #1438955

    Hi,

    Have you tried disabling autoplay (Enable Autoplay) and making sure that the video is not muted (Mute Video Player)? The theme will automatically set the volume to 100% if autoplay is disabled, and users can then control the volume using the physical buttons on their devices. Alternatively, you can upload the video to YouTube or Vimeo to use their default media players.

    Best regards,
    Ismael

    #1439005

    Of course I have tried that and it DOES NOT WORK! As I have been saying for one week…

    THERE IS NO WAY TO UN-MMUTE THE VIDEO AT ALL. IT CANNOT BE UN-MUTED ON ALL BROWSERS ON THE PHONE! There is NO option to click anything anywhere and UN-MUTE the volume on ANY browser on the phone. If you click the video it just pauses it. IT DOES NOT UN-MUTE the video. There is NO option to click the sound icon and turn the sound on AT ALL! It’s COMPLETELY MUTED WITH NO OPTION AT ALL TO HEAR THE SOUND AT ALL ON THE THE PHONE.

    Have you even logged into the site to try and test and fix this issue? Or are you just replying with the standard reply about the videos and auto mute? It seems you are not even putting any effort to help with this issue. I provided the site login when I first created this ticket.

    I need to get your managers contact info as I am going to report that you are not even trying to help fix this problem. It has now been one week and you have obviously done NOTHING expect keep telling me Chromes auto mute features. This is NOT ONLY ON CHROME. THIS IS ON ALL PHONE BROWSERS. I really don’t know why I have to keep saying the same thing over and over and over.

    Scott

    #1439024

    Hi Scott,

    I’m very sorry for the confusion.

    I could reproduce the issue and reported it to our developers. The unmute icon is removed from the source code when loading the site on mobile so unfortunately I don’t have a workaround at this time. If our developers provide a workaround, we’ll share it with you here.

    Best regards,
    Yigit

    #1439074

    Hey!

    To test this, we disabled Autoplay on the Video element. The video has sound by default when played manually, even in mobile view. You cannot control the volume using the video controls, but you can adjust it using the physical volume controls of your phone.

    Best regards,
    Ismael

    #1439113

    My client wants the video to play WITH AUTO-Play ACTIVATED and have sound.

    Thanks
    Scott

    #1439116

    Hey Scott,

    Apparently, I misunderstood you. I thought you wanted a button to unmute the video on mobile. Our developers might add a button to unmute the video on mobile but it is not possible to autoplay an unmuted video as Ismael mentioned.

    It’s a bad user experience to auto-play a video with sound. That’s why browsers are disabling it.

    If you really need that, please hire a freelance developer to implement it.

    Regards,
    Yigit

    #1439136

    Hi Yigit,

    OK thanks for the update. I think my client is happy with how it’s working now. At-least it can be played with sound.

    So there is no a way to have auto-play on and also have the sound icon available to turn the sound on? That is what I was trying to do originally.

    Thanks
    Scott

    • This reply was modified 1 week, 3 days ago by scotthill89.
    #1439187

    Hey Scott,

    You can do this on a child theme ( https://kriesi.at/documentation/enfold/child-theme/ ).

    Please create a folder inside your child theme called “js”, create a file called avia.js inside the js folder, and place this code https://pastebin.com/PqAWvVSg into the file. Then, create a file called avia.min.js, and place this code https://pastebin.com/BEqb50uK into that file.

    Then, add the following code to the functions.php file of your child theme

    
    add_action( 'wp_print_scripts', 'ava_change_wp_enqueue_scripts_mod', 100 );
    function ava_change_wp_enqueue_scripts_mod() {
        $vn = avia_get_theme_version();
        $options = avia_get_option();
        $min_js = avia_minify_extension( 'js' );
        wp_deregister_script( 'avia-default' );
        wp_enqueue_script( 'avia-child-default-js', get_stylesheet_directory_uri() . "/js/avia{$min_js}.js", array('jquery'));
    }
    

    Please note that this may not work as expected or cause issues with the Video element’s functionality. Please test it on a staging site to make sure there are no issues before using it on your live site.

    Best regards,
    Yigit

    #1439212

    Hi Yigit,

    Thank you for all the info on trying to get that to work. I think I will just leave it as is since it may not work as expected or cause issues with the Video element’s functionality. Maybe you guys will add this to updates in the future.

    Thanks
    Scott

    #1439215

    Hi Scott,

    No problem! Please see the private content field.

    Best regards,
    Yigit

    #1439221

    See private message.

    #1439225

    Hi,

    Best regards,
    Yigit

Viewing 19 posts - 1 through 19 (of 19 total)
  • The topic ‘NO Sound on Videos on Mobile Phone and iPad using Chrome’ is closed to new replies.