Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #1313046


    In the new version of Enfold, there are new css rules for flex columns that interfere with custom css settings.
    Usually, when I want to customize a flex colum – usualy to add padding -, I give it a custom class, and can just make a customo css rule using that custom class, like so :
    .custom-class {
    But in the last version of Enfold, there are new css rules that take priority :
    #top .flex_column.(a long, custom id) {
    border-radius: 0px;
    -webkit-border-radius: 0px;
    -moz-border-radius: 0px;
    padding: 0px;
    Granted, that can be solved most of the time by adding a #top in front of my custom css rule (and even so, not always), but I have a lot of different websites with Enfold and would rather not have to go through every line of custom css to make the changes on every website.

    Is that new change that necessary ? Isn’t there a way you could do that without interfering with custom css based on custom classes ?

    Thanks !


    Hey JaimBateman,

    Thank you for using Enfold and bringing this up.

    There was a reason why we added #top because of selectors that have #top and override options.

    I scanned the themes CSS files and think it is only margin settings that seem to make problems.

    I removed #top for all other rules and left it only for margin.

    But we need the (element id) in selector (prior 4.8.4 these rules were all added to inline style tags).

    If you want to test, here is a link to the modified file. Replace enfold\config-templatebuilder\avia-shortcodes\columns\columns.php with the content of

    Using #top #wrap_all …. should be safe to override our selectors also in future (we try to keep them as weak as possible).

    Best regards,



    Thanks for your help. Sadly, it didn’t seem to work… The padding rules are still affected. I put in private two links : one is the actual website (still with 4.8.3) and the other is a copy with 4.8.5 and the new file you gave me.
    I did empty the caches (site + browser) ; but it appears that the new css rules still apply, and still have #top in front of them for padding and corners. Look for example at the white ‘Focus’ block.

    I’d appreciate if you could take a look !

    Thanks !



    Sorry, I forgot to mention:

    – Save theme options to invalidate all post css files and allow a rebuild
    – clear server and browser cache again

    btw: latest version of columns.php (there had been more modifications):

    Best regards,


    Ah, yes, I forgot about that option…
    Thanks, it does work much better now (there are still a couple of problems, but if it’s just one, that’s much better !)

    Any idea when the corrected file would be integrated into an official Enfold release (if there is one coming soon) ? Or should I just use your temp file for now ?

    Cheers !



    Glad that this fix helps.

    We plan a release on monday evening including this fix and also others.

    You can check here:

    Best regards,


    Excellent !

    As usual, you guys are doing a top notch job.

    Thanks for everything !
    (we can close this ticket)



    Thank you.

    Enkoy the theme and have a great day.

    Best regards,

Viewing 8 posts - 1 through 8 (of 8 total)
  • The topic ‘New css rules for flex_column’ is closed to new replies.