Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1173751

    Hi!

    On the menu of the mobile website, the styling has drastically changed. The colors are different, and the element is too big for the screen. I’m not sure when this happened, and can’t recall any changes or plugins that have been updated that may have caused this change.

    I’ve checked this across different devices/ browsers, and the broken styling is consistent across all.

    How Menu Should Look:

    How Menu Should Look

    Menu Now:

    Menu now?

    #1173862

    Hey WebDevDept,

    I see that you are running an old version of the theme, could you try to update to the latest version (4.7.1) to see if that helps please? The update to 4.7.x has to be done manually from the version you are running, please refer to my replies in this thread: https://kriesi.at/support/topic/enfold-4-5-theme-update-update-failed-download-failed-a-valid-url-was-not-pro/#post-1021541

    You can either update manually via FTP: https://kriesi.at/documentation/enfold/how-to-install-enfold-theme/#theme-update, or use a plugin to upload the theme zip file: https://wordpress.org/plugins/update-theme-and-plugins-from-zip-file/

    If that doesn’t work then please try to delete the whole theme folder, then replace it with the new version. Make sure that you have backups of the site before starting updating.

    After you have updated then try to activate the Classic Editor in the main page of the theme options.

    Also please read this after you have updated: https://kriesi.at/documentation/enfold/theme-registration/

    Best regards,
    Rikard

    #1174700

    Hi Rikard,

    We’ve tried to update this site in the past and unfortunately, it completely breaks every time.

    Is there anything else you’d recommend to repair the menu element?

    #1174925

    Hi,

    Thanks for the update. What exactly breaks when you update the theme? We can’t really support very old versions like the one you are running. Could you copy the site to a staging area where we can see the problems you get once you have updated?

    Best regards,
    Rikard

    #1175181

    I did copy the site to a staging area. The notable things that are affected by the new enfold theme file are these:
    Strange space above header
    Footer Menu Area (When logged in parts of plugins/ theme elements and all of these links pop up)
    Missing Hero Image + Form
    No Mobile Menu

    Other stylistic issues with text/spacing are easy enough to remedy with CSS but the structural ones I don’t understand (such as the mobile menu).

    #1175752

    Hi,

    – Strange space above header; that is because you have header.php in your child theme and there has been changes to that file since you updated last. Please copy the new header.php to your child theme and re-add the changes you have made to that file.

    – Footer Menu Area; I’m not sure I understand what you mean by this, is it the two images in the left column which are misaligned?

    – Missing Hero Image; please try to remove the LayerSlider element and save, then add it back again to see if that helps.

    – Missing mobile menu; updating header.php should likely fix this problem as well.

    Best regards,
    Rikard

    #1176954

    Hi,

    I updated the header file and tried to implement some changes – however, I wasn’t the developer who added changes into the file and it didn’t work well.

    The hero image is back, but the header and menu are broken.

    #1177431

    Hi,

    I see an error message at the top of you site, what exactly did you do with header.php?

    Best regards,
    Rikard

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.