Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1296412

    We have ~29 hotspots and when we load the page some work and some don’t. We need to reload the page and then some of the ones that didn’t work do work and the ones that worked the time before don’t work. In short, not all hot spots work and reloading the page is not ideal. In the console I see a number of errors (e.g. ” VM10:1 Uncaught SyntaxError: Unexpected token o in JSON at position 1″) and wonder if this is the cause of the issue?

    #1296684

    Hey lzevon,

    Could you try updating the theme to the latest version (4.8.2) to see if that helps please? https://kriesi.at/documentation/enfold/how-to-install-enfold-theme/#theme-update. If not, then please include admin WordPress login details in private so that we can have a closer look.

    Best regards,
    Rikard

    #1296819

    Updated to the latest version of the theme, but still not showing us all the hotspots. Info below…

    #1297248

    Hi,

    Thanks for the update, and login details. I can’t see what is causing this problem unfortunately, did you try disabling all plugins to see if that changes anything? We can try it out for, if you give us permission to disable plugins temporarily.

    Best regards,
    Rikard

    #1297389

    You can try it if you’d like to, i always test this, refresh (no cache) and didn’t note a difference, but maybe you will.

    #1297765

    Hi,

    Thanks for the update. I tried disabling plugins and child theme, but that didn’t make any difference unfortunately. I can’t see what is going wrong, but I’ve asked the rest of the team for help as well.

    Please reply to this thread, so that it gets added back to our support queue.

    Best regards,
    Rikard

    #1297794

    Hi,
    Thank you for your patience, I copied your test map page to my test server and found that the hotspots that were not showing had the hotspot colors set to transparent, so they were not showing. This happened to be all of the “Significant Trees” hotspots so I edited these to be the same as the others. I also noticed that many of your images were not using https you may want to review this on your other pages to help with CORS errors, anyways this solves the case of the missing hotspots.
    But I notice that your hotspots are acting erratically, please compare your test page with mine in the Private Content area, my test install has no caching and only woocommerce for a plugin, I see your site is manually disabling template builder elements including the Image with Hotspots Element and you are using W3 cache which is minifying JS while the theme is also merging and compressing JS, this double minifying can cause issues.
    I recommend disabling all of your plugins and any object-oriented caching on your server and all minifying and compression in the theme and allow all elements to load, once your site is done being built you can start caching, minifying, and tweaking a little at a time. Anyways I hope this helps.

    Best regards,
    Mike

    #1298028

    Thank Mike, I will double check all the images to make sure they all use HTTPS. The transparent markers are so the map graphic is used and I can’t see how that would be an issue only some times (should either work or not, no)? I tried disabling W3 Cache (and all plugins in several tests) and it made no difference in the way the hotspots acted. The builder templates is something I have not tried toggling, should I enable all builder templates to test?

    Thank you

    #1298272

    Hi,
    Perhaps I misunderstood about your “Significant Trees” hotspots, so when you have those hotspots set as transparent there is no indication that there is something there to mouse-over, except for the map image, so I thought that you thought that the hotspots were not working there, thus my pointing out that the hotspots were transparent.
    Now I believe that you want the “Significant Trees” hotspots transparent so I reverted my test page, linked below, to show that while the hotspots are transparent, the mouse-over effect does show the popups.
    CPT2105040710-249x225.gif
    (the image above links to a gif that shows the mouse-over popup)
    Please clear your browser cache and check the test page linked below.

    Best regards,
    Mike

    #1298329

    Thanks Mike. I can see console errors (JSON) on my install …

    storage.html:1 Uncaught SyntaxError: Unexpected token o in JSON at position 1
        at JSON.parse (<anonymous>)
        at receiveMessage (storage.html:1)

    …and need to figure out why it’s happening and what role storage.html plays in all of this. If you or your team can shed any light on that please let me know.

    When I disable all plugins I still get an error…
    (index):486 Uncaught ReferenceError: jQuery is not defined
    … and some of the hotspots randomly don’t work. So I suspect it’s a configuration setting, possibly under Performance in the theme control panel. I have attached a fullscreen screenshot of that. I believe someone from Enfold made some adjustments in there as part of this ticket.

    Thanks for your continued help.

    #1298608

    Hi,
    I didn’t make any adjustments in your theme settings, but you will note above I pointed out that you were manually disabling template builder elements including the Image with Hotspots Element which you are using on this page. I recommend disabling all of your caching plugins and JS minifying and compression in the theme and allow all elements to load
    jQuery is not defined typically means that the script is loading before jQuery, jQuery has to load first so the script can use it.

    Best regards,
    Mike

    #1298631

    Hi Mike,
    It turns out there was some custom CSS…
    .av-tt-xlarge-width { width: 530px !important; display: block !important; text-align: left !important; }

    “display: block !important;” was forcing the tooltips to block the buttons when it would normally be completely hidden. When disabled the tooltips work as expected. Also all the tooltips are 55pm lower than they should be because of the WordPress admin bar, which caused them to show/hide.

    At any rate, things appear to be working now and I appreciate your support!

    #1298777

    Hi,
    Good catch, glad to hear that this is sorted out now we will close this now, and thank you for using Enfold.

    For your information, you can take a look at Enfold documentation here
    For any other questions or issues, feel free to start new threads in the Enfold forum and we will gladly try to help you :)

    Best regards,
    Mike

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘image with hotspots – some hotspots don't work until reload’ is closed to new replies.