Viewing 30 posts - 1 through 30 (of 34 total)
  • Author
    Posts
  • #616700

    After the latest Enfold upgrade I am having a problem with media upload of images of any size.
    I am getting an http error every time I try an upload.
    I increased my upload limit to 64 MB but still does not work.
    The images I am trying to upload are less that 60 k.
    Any suggestions?

    I’ve seen this problem report by other users in the past. I am using Go Daddy for hosting and have 5 other sites with them, but no problems with uploading on other Enfold themed sites.

    #617088

    Hi GailSabol!

    Thanks for getting in touch with us!

    Could you please provide a link and login details to the site with the issue, so that we can have a closer look. You can place the information in the Private Content section of your reply.

    Best regards,
    Jordan

    #617790

    Thank you Jordon.
    I have been able to load a few images, but as I was about to try to upload many images for a gallery I continue to get the HTTP error.

    I created a login for you.
    See Private Content area.
    Hopefully you can fix my issue.
    Thank you.
    Gail

    #619769

    Hi!

    does this happen when activating a default WordPress theme as well? please let us know about your results.

    Best regards,
    Andy

    #620079

    I believe I resolved it with Go Daddy who is the host provider.
    I am currently running 10 sites with Enfold and each of them had the same upload images problem (http error) following the WP and Enfold updates.

    Here’s is what they told me they had to do:
    Re-submit the account
    Clear Cache
    Re-initialize (INI)

    I do not know what all of that means, but if anyone else should contact you with the same problem and they are running Enfold hosted on Go Daddy, that is what they did. Go Daddy had to do this to each site separately.

    #620434

    I am also facing uploading any media as it’s notified as HTTP ERROR….

    What I should do now…

    #620494

    Hi

    I am having exactly the same issue. I receive the HTTP error when trying to upload small images (.jpg and .png files). I am able to upload images when using a different theme.

    I use Enfold on a number of sites and this is the first time this has happened. It is on a new Godaddy WordPress install so using latest WordPress and Enfold theme (set it up on Tuesday this week).

    I am happy to provide login details for you to have a look.

    Many thanks

    Faye

    #620958

    Hi @FayeMcC,

    I tried to upload the Kriesi logo and had no problems doing so, please check link in private. Could you upload an image you are having problems with to a service like imgur.com so that we can have a go from our end please?


    @ShaikhHafizurRahman
    , please open a new thread an post admin login details in private so that we can have a look.

    Thanks,
    Rikard

    #621676

    Hi Rikard

    Thanks for getting back to me.

    I can see your image there.

    If you look in the media library you will see I have tried to upload an image called MK8.jpg. I have received the HTTP error for it. I have been able to upload to Imguru. I will post the link in the private section.

    Let me know if I can provide any further information.

    Many thanks

    Faye

    #623293

    Hi Kriesi,
    As an avid fan … I wanted to assist your clients who host with GODADDY or a GoDaddy reseller and have an http error with media upload.

    Please note:

    Anyone using GoDaddy hosting account may have issues. I have this same issue with other themes, and it all has to do with GoDaddy accounts.

    Add this to the child theme function.php

    add_filter( ‘wp_image_editors’, ‘change_graphic_lib’ );
    function change_graphic_lib($array) {return array( ‘WP_Image_Editor_GD’, ‘WP_Image_Editor_Imagick’ );}

    All the best!

    • This reply was modified 7 years, 10 months ago by Wildwood.
    #623359

    Hi,

    Thanks a lot! Got a quick question for you: is this code snippet also necessary if you are updating to wordpress 4.5.1 (which fixes a few image upload errors as well)

    Best regards,
    Kriesi

    #623362

    Yes, it has worked with the current WP upgrade too. So I think so. GoDaddy proprietary process causes a lot of issues … if you notice … that snippet is a direct GoDaddy snippet.

    You may want to include that in your foundational theme files as an added measure since SO MANY people use them for hosting.

    I am happy to help … as I love your theme and helpful support team.

    • This reply was modified 7 years, 10 months ago by Wildwood.
    #623374

    Thank you for your help.

    I have WordPress 4.5.1 running and still have the image upload problems.

    Sorry to ask this basic question but how to I add the code suggested to the child theme function?

    Where is the ‘child theme function’? Will I have to SSH into the backend, or is there an easier way? Happy to provide login details, if you could help with this?

    Many thanks

    Faye

    #623383

    I was so excited to see the code from Wildwood above since I have had this HTTP error for weeks now, and it has gotten much worse with the latest updates. Josue provided some code in another thread which eliminated most of the photo sizes, which seemed to temporarily fix the timeout issue but it is back with Go Daddy. This seems to impact photos of any file size, and at one time users were theorizing it was photos over a certain pixel width.

    Right now, I have to get a page built and I am having a hard time uploading photos….. lots of HTTP Errors even though I added Josue’s code, other thread, and Wildwood’s code above, this thread, to my child theme functions.php, then cleared browser cache and Go Daddy cache.. I am so glad to see Kriesi is on this thread… I love this theme but this http error with Go Daddy is killing me.

    If there’s something Go Daddy needs to do from their end, please tell me specifics and I can try that and report back.

    Thanks,
    Rob

    #623388

    So Rob, it didn’t work?

    There is one other thing about the GoDaddy hosting that you may need to resolve this. It has happened only once with my sites.

    When you upgrade your memory limits … GoDaddy asks that you upgrade using .user.ini. (This is really a good default.) But I had trouble on one site … and used the same code on .php.ini and it cleared up the issue.

    Have you updated the two files?
    (The first are system files. I store them on my hd without the (dot) at the beginning, and then change the name to include the (dot) once uploaded.

    1. .user.ini (or .php.ini)

    (This is a direct upload or you can write it in the file manager.) My generic code is here:
    max_execution_time = 600
    max_input_time = 300
    post_max_size = 100M
    max_input_vars = 10000
    file_uploads = 1
    max_file_uploads = 20
    upload_max_filesize = 200M
    and
    2. wp-config
    This file requires a line-item add in the code:
    /** WordPress upload */
    define( ‘WP_MEMORY_LIMIT’, ‘512M’ );

    Kriesi … please confirm these for your users.

    I hope this helps.

    #623392

    Wildwood, no the original code you gave a few posts ago did not make a difference… I wonder if that is because I am also using Josue’s code that stripped out some of the photo sizes? I am going nuts right now trying to get a page up so can’t try the above suggestion but will give it a little time later today. I REALLY appreciate your help!! Thanks, Rob

    PS Looks like I will need to Filezilla in to try the above, right?

    #623397

    Why is it that this theme is affected but others are not? My current work around to uploading images, is switch between themes. Activate a basic theme, load the images and then reactivate Enfold.

    btw Godaddy suggested the same memory limit changes…they charge $29 to do it!

    #623399

    Hi Faye,

    GoDaddy has countless servers. The issue is only on some older servers. I have tried to ‘assign’ my clients to certain ones, but they cannot/do not do that.

    When a website is on the older server it affects ALL the themes I work on. It is not Enfold. It is the GoDaddy server that causes the issue.

    Sorry, from what I can tell it is the luck of the draw.

    #623527

    I haven’t made the mods yet but I do seem to be getting a new error when trying to upload….

    Fatal error: Maximum execution time of 30 seconds exceeded in /home/content/p3pnexwpnas08_data02/27/2854827/html/wp-includes/class-wp-image-editor-imagick.php on line 383

    Sigh.

    #623570

    If you search the Enfold support forum, it is littered with customers with the same problem. I wonder whether it would be worth Kriesi talking to Godaddy directly. I think the Enfold is fantastic…but this problem is really bad news. There seems to be so many different responses and courses of action to take, i don’t know where I am. I’m not a hardcore programmer…that’s why I use Enfold. That means I need a very clear ‘how to guide’ on how to fix this!

    #623868

    Yes, Faye, I agree… I hope Kriesi takes this one on, but I’m guessing he’s busy with all the upgrade issues… I would consider this an upgrade issue since it worsened significantly during the last upgrade.

    Are you on Go Daddy Managed WordPress or just another regular plan?

    #623872

    Hi Faye, I don’t think it is realistic to think that GoDaddy would heed the advice of Kriesi or most other companies.

    I work from satellite and (on some GD servers) the caching interferes with updating websites. I worked for two years (over 80 hours!) with Dish Network and GD to resolve the issue … and GD didn’t assist at all. Finally Dish Network created a work-around for clients, which was to disable their ‘Internet accelerator.’

    I have worked with Kriesi for a number of years now on many websites, and I am certain that if they can ‘build in’ a solution, they will. They are a great team.

    I have both managed and cpanel accounts. (Both can be affected.)

    • This reply was modified 7 years, 10 months ago by Wildwood.
    #623877

    Hi Wildwood, I don’t think any of us expect Go Daddy to fix this… but the excellent support team have thrown out a number of options over the last few months to fix this issue. Some of them work for a while (Josue’s reduce the picture sizes in functions.php) but most did not, at least for me. The aforementioned fix has stopped working with the latest updates.

    What would be great is if someone from Enfold could speak to someone from Go Daddy to help diagnose and figure out what’s going on… and then give us all a recommendation on settings, or better yet make a patch to Enfold. If that’s unrealistic, I would be happy to give someone from Enfold access to my staging environment so they could play around in a Go Daddy environment and try to find a fix that they can push out to everyone.

    Still need to look at your suggested fix… When I increased the max upload time before it caused some other problems and “broke” the site so I’m a little nervous about that one.

    Thanks!!

    #623884

    Hey GoldenGate,

    What format did you use to increase the max-upload? Did you put it in a .user.ini file or a .php.ini file?

    I always use .user.ini, per GD, but one time it caused other issues and ‘broke’ the site. That is when I learned about using .php.ini instead.

    There is a difference for these. The .user.ini works on sub-directories, and the .php.ini if placed in the root directory applies to all sub-directories. (As defined by GD rep, I have not confirmed this.)

    If you experienced a break with .user.ini (like I did once), then switch to .php.ini and see if that works. (It did for me.)

    Good luck. I hate these types of things! I hope you resolve it soon.

    #623958

    Yigit has found a solution that works for me!!! See last entry in this post https://kriesi.at/support/topic/http-error-when-uploading-images-5/

    It is very simple to apply. Just add the following code Functions.php file. This file can be found by looking in the left sidebar click on Appearance > Editor and you will find it there.

    add_filter( ‘wp_image_editors’, ‘change_graphic_lib’ );
    function change_graphic_lib($array) {return array( ‘WP_Image_Editor_GD’, ‘WP_Image_Editor_Imagick’ );}

    I just pasted it right at the bottom of the file.

    Wildwood I hope this works for you :-)

    #623961

    Hi Faye,

    Yes, I initially provided that code earlier in this thread. I’m glad it worked.

    #624002

    I tried the above mod in functions.php and also tried removing the earlier code from Josue:

    function ava_image_sizes() {
    remove_image_size(‘masonry’);
    remove_image_size(‘magazine’);
    remove_image_size(‘widget’);
    remove_image_size(‘featured’);
    remove_image_size(‘featured_large’);
    remove_image_size(‘extra_large’);
    remove_image_size(‘portfolio_small’);
    remove_image_size(‘gallery’);
    remove_image_size(‘entry_with_sidebar’);
    remove_image_size(‘entry_without_sidebar’);
    remove_image_size(‘square’);
    }
    add_action( ‘after_setup_theme’, ‘ava_image_sizes’, 11 );

    No luck… still HTTP error….

    Does it take a while for the modified functions.php to take effect?

    #624025

    Hi Goldengate415

    It worked straight away for me….doesn’t make sense how all the different ‘fixes’ are so hit and miss.

    To answer your other question – yes I am a managed WordPress Godaddy customer :-/

    #624044

    Thanks Faye.

    I got it all working on my staging site — all HTTP errors gone!! I just did a massive upload of 30 pictures which in the past would have caused errors like crazy, and it worked like a charm ,with ALL photo sizes again working and loading.

    Here’s what I did:

    – Deleted Josue’s mod (above) from the functions.php
    – Added Wildwood’s mod to functions.php in my child theme
    – Added user.ini with above parameters from Wildwood to root directory of my staging site using Filezilla
    – Added lined of code above from Wildwood in functions.php

    So far, so good in my staging site… I am going to keep using the site to make sure nothing else broke as a result of these mods and if all is OK I will push into production….

    thank you so much Wildwood and Faye!!

    And if anyone from Enfold is still watching this thread… please… this comes up a lot and will come up more as more and more of us move to Go Daddy Managed WordPress… put together a tutorial for people to make these changes, or perhaps figure out a different way to achieve the above result through the theme.

    Thank you!! So happy this is fixed!!!

    #624062

    I spoke too soon.

    When I moved these mods into my production site, the problem is back.

    I think I know what’s going on but I do not know how to fix it.

    Go Daddy Managed WordPress uses mandatory caching — it’s built into their Managed WordPress platform — and something about Enfold / Media uploading and the Go Daddy Managed WordPress Cache is not set up correctly. This is why the above solution works on my staging site but not on the production site. Go Daddy does not use caching on the staging site.

    Enfold support, can you help us figure this out? And Faye is your problem still solved – have you tried to upload 15-20 photos at once? Enfold team, if you tell me to call Go Daddy, they will say this is an issue with my theme and to go back to you…. please help!

    Thanks

Viewing 30 posts - 1 through 30 (of 34 total)
  • The topic ‘HTTP Error with Media Upload’ is closed to new replies.