Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #624617

    Hello Enfold Support-
    There is currently a thread spanning now 2-3 pages where Enfold support tried to help, but seems to have left it to the users to carry on the discussion:
    https://kriesi.at/support/topic/http-error-with-media-upload/

    This issue has become a “real issue” as more and more users are migrated to Go Daddy Managed WordPress, a product they are pushing very much. Just yesterday there were 2 threads started about this error. Some of the fixes from user “Wildwood” are included in the other thread, and work on my staging environment, but when I push to production, the fixes don’t work.

    Why?

    I think it’s because Go Daddy forces us to use their automatic caching system. There are no adjustments we can make on this caching and we cannot turn it off. Somehow Enfold does not “play” well with the caching system, though default themes on WordPress work fine. Disabling plugins and updating to latest version are step one and of course we have done that.

    Or it could be another reason, I’m not technical enough to know… but the fact that Wildwood’s fixes fix it in the staging site which doesn’t use caching leads me to believe it is GD Managed WordPress caching and Enfold not playing well together. Since uploads work fine with default themes, Go Daddy will send me back to Enfold for support.

    Please help.

    Thank you!
    Rob

    #624619

    PS I just tried to upload a photo and got a new error in addition to HTTP:

    “Fatal error: Maximum execution time of 30 seconds exceeded in /home/content/p3pnexwpnas08_data02/27/2854827/html/wp-includes/class-wp-image-editor-imagick.php on line 358”

    #625835

    Hi,

    contact your host about this issue. Try with a default WP theme, to check if you get the same results there too.

    Best regards,
    Andy

    #625903

    Code from Yigit in another thread fixed it… not sure if this is the same code Wildwood provided in post several pages back on this thread:

    add_filter( ‘wp_image_editors’, ‘change_graphic_lib’ );
    function change_graphic_lib($array) {return array( ‘WP_Image_Editor_GD’, ‘WP_Image_Editor_Imagick’ );}

    In past it has been “fixed” but then has come back. I hope this time it’s really fixed permanently. Since this issue does not impact other themes, Go Daddy just tells me to switch themes, which I do not want to do since I love Enfold.

    Thanks

    (for those searching who have this same issue, you have to make the mods earlier in this thread via FTP, then at the very end add this code to functions.php)

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘HTTP Error On Photo Upload With Go Daddy Managed WordPress’ is closed to new replies.