Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1309259

    Hi

    I try to create a right side bar on my blog site in order to show the archive of my blog posts. I want to show the 4 latest on the main page and the elder ones in the sidebar as a small picture with title.
    In the backend I went to Design – Widgets. I put “Enfold Child Latest News” in the field “Sidebar Blog” and inserted the title and how many posts it schould show. Actually nothing happens and when I go back to the page, the widget is not there anymore though I saved it bevor changing the page.
    There’s another place on the website where I can change sidebars: Enfold Child – Sidebar settings. But nothing happens when I change anything here. Thanks for your advice.

    Best
    Angela M.

    #1309467

    Hi Angela,

    Please send us a temporary WordPress admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,
    Rikard

    #1310104

    Hi Rikard
    Thanks for your reply. Below I send you the Login URL, the login and the password.
    Thanks for your help.
    Angela M.

    #1310338

    Hi Angela,

    Thanks for that. I see that you have selected to not show a sidebar in the Layout menu on the blog page, and your widgets are empty. I added the widget you wanted in the Blog sidebar, and set the blog page to use that sidebar in the settings, and it’s working as it should. Please review your site.

    Best regards,
    Rikard

    #1310521

    Hi Rikard
    Wow, that looks great, thanks a lot!
    Now I’d like to show only the 6 latest blog articles on the main side while in the side bar all the elder articles (means, starting from the 7th article).
    I tried to adjust it the way I want to but couldn’t manage. Could you explain me how to do it. Thanks a lot!
    Best regards
    Angela M.

    #1310667

    Hi Angela,

    Offsetting posts is not possible in the widget unfortunately. But you might be able to achieve the same thing if you use the Blog Posts element shortcode. If you add the Blog Posts element to a new page, then make the selection of you choice. Then activate debug mode in order to see builder shortcodes: https://kriesi.at/documentation/enfold/intro-to-advanced-layout-builder/#debug-mode. After that you can copy the shortcodes into a text or code widget.

    Best regards,
    Rikard

    #1311135

    Hi Rikard
    Thanks for your answer. I tried to follow your instructions. What do you mean by “make the selection of your choice” and where do I have to activate the debug mode? Moreover I wouldn’t know where I have to copy the shortcodes into. I’m sorry, but honestly this is too complicated for me to understand…
    Best regards
    Angela

    #1311411

    Hi,

    Thanks for the update. You would make the selection of your choice in the actual element which you would drag onto the layout of a temporary page. From there you can then copy the shortcodes into your widget.

    The documentation I linked to include instructions on how to enable debug mode, please try following them.

    Best regards,
    Rikard

    #1312488

    Hi Rikard

    On the side with the widgets there’re are seven same messages on red ground showing up which say: “Der Block „newsbox“ ist von Fehlern betroffen und funktioniert möglicherweise nicht richtig. Bitte prüfe für weitere Details die Entwicklungswerkzeuge.” Did you use blocks called newsbox? There’s one field opening but not fully loading in “Sidebar Blog” and six in “Inactive Widgets”. Is this normal?

    Since this way is to complicated for me I’ll leave it with the side bar on my blog and the archive. Can you take the boxes away so the widget area looks like before? (I tried to delete them but then a failure message occured and I recalled the latest backup).

    Thanks a lot
    Best
    Angela

    #1312914

    Hi Angela,

    This is happening due to a WordPress update, Enfold is not fully compatible with the way WordPress handles widgets yet. Please try updating the theme to the latest version (4.8.5) to see if that helps please: https://kriesi.at/documentation/enfold/how-to-install-enfold-theme/#theme-update.

    If not then please try installing this plugin: https://wordpress.org/plugins/classic-widgets/

    Best regards,
    Rikard

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.