Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #1323848


    Each time I try and upload new Theme zip file into WP I’ve getting

    “The link you followed has expired”

    I followed the advice given below by Customer Service at Envato, specifically increasing the PHP Limits (increased to maximum) and I still got the “The link you followed has expired” message.

    Beyond the PHP limit I wonder if on my WP Dashboard under Media the fact that I only have a Maximum upload file size of 2MB is an issue that needs to be changed?

    The other option Customer Service mentioned was;
    – Place the unzipped theme folder in your /wp-content/themes/ via FTP

    That 3rd option sounds complicated though.

    Will await direction from you.

    Thanks in advance

    Kino (Market)

    Oct 7, 2021, 15:20 GMT+11

    Hi Aaron,

    My name is Kino from Envato Customer Success Team. We’re happy to help you.

    If you are installing your theme from the WordPress theme installer, but get a message that says “The link you followed has expired”, most likely your web server is configured with PHP settings that are too low to allow the theme ZIP file to upload.

    Specifically, PHP is configured to a maximum file upload size limit of 8 megabytes or less. The theme ZIP is larger than the maximum limit. Thus, the webserver is rejecting the upload. WordPress is giving you a rather ambiguous message in response. This is not a theme fault or bug.

    Three options:

    – You can get your web host to increase your PHP limits.
    – You can do it yourself:
    – Place the unzipped theme folder in your /wp-content/themes/ via FTP

    Theme Support is provided by the author. If you need further assistance, please follow this link:
    Kind regards,




    Hey atravers70,
    Thank you for the login, could you upload the theme file you are trying to use to DropBox or something similar and link to it in the Private Content area so we can check.
    I see that you are using WordPress 5.8.1 with the Replete theme from 2012 on a server using PHP v5.6.40
    your server is also set to
    Upload max filesize 2M
    PHP post max size 8M

    The file size of the Enfold theme zip is around 16M, so this is why you can’t upload it.
    It looks like your site is a live shop with almost 400 products, considering that you are using PHP v5.6.40 I would not try to add Enfold to this site.
    I would recommend building a new staging site on a different server because you will need to use PHP v7.4 minimum for WordPress, here is a screenshot of your WordPress Site Health:
    but if you change your PHP version with the Replete theme there is a possibility of your site crashing.
    Also, note that Enfold is not a drop-in replacement for Replete, so you will need to make changes to your pages & posts to get the same look and feel of your site and this will take time and I’m concerned that you will have to have your site down for a time.
    So you would be better to not make changes to this site of server and build your new site on a new server so you and get it up and running the way you like.
    I also note that you have Thrive Architect installed and there is a builder conflict with it and Enfold that Thrive nor us have been able to solve, so you may not be able to use it.

    Best regards,


    Hi Mike,

    I’ve managed to work through the issues of PHP version, file upload size etc.

    Enfold is now running as the Theme.

    I want to build the site out using the Enfold Shop Template

    Last night when I was orientating myself with setting up I thought I found in “Theme Options” a section where I could choose the ‘Shop Template’ to overlay the buildout from but for some reason I can’t seem to find how to do that now.

    I’m assuming the Shop Template is there somewhere in Theme Options? Sorry but can you please let me know what to do. Or if it’s easier for you to just do it yourself, my WP login details are below.

    Thank you


    Hi Aaron,

    I tried to import Enfold Shop demo in Enfold theme options > Demo Import – however it did not work. It seems like PHP ZipArchive Extension is disabled on your server. Could you please contact your hosting providers and ask them to enable it for you? After that, you can import the demo in Enfold theme options > Demo Import

    Best regards,


    Hi Yigit,

    Thanks for your reply.
    Hosting Provider activated Zip Archive and I’m up and running.
    All good.

    Thanks again



    Great, I’m glad to hear that things are working as they should now. Please let us know if you should need any further help on the topic or if we can close it.

    Best regards,

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.