Tagged: , ,

Viewing 28 posts - 1 through 28 (of 28 total)
  • Author
    Posts
  • #964498

    Hi,

    even though I uploaded my own fonts zip files in the custom font manager of the Enfold theme options, I can see via Firefox network analysis that the fonts still seem to load from Google. I just can’t explain why this is happening :o( .

    Can you help and tell how to solve this urgent issue? Really do hope you can help, feel kind of helpless.

    I send you my login details in private content box, in case you should need them.

    Kind regards,
    Sophie

    #965626

    Hey Sophie,

    Are you using any plugin related to gstatic? It’s loading the external fonts.

    Please try to disable active plugins and check if this helps.

    Best regards,
    Vinay

    #966239

    Hi,

    I just found out that in advanced settings of Theme settings I have not changed the body font to my local font, so it’s working now. But I just saw that the font Lato regular and lighter are displaying same way, even though I imported them via custom font manager. But I need to have the lighter one. Can you help?

    Also, how can I make the p style <p style=”font-size: 26px; font-family: ‘Chelsea Market’;”>example text</p> and my blockquote styling CSS blockquote { font-family: Chelsea Market;} load my local font? Currently it is still loading from Google server https://fonts.gstatic.com.

    Furthermore I am using the following code for enabling the header scroll effect on mobile devices that I got from your support forum and for loading font awesome for my recipes. This is loading 2 icons (print and check mark) from maxcdn.bootstrapd. Can you help and tell how to load these both icons from Enfold or rather from my local server to reach GDPR compliance:

    
    function enfold_child_custom_script() {
        wp_enqueue_style( 'font-awesome', 'https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css', array(), 1.0);
        wp_enqueue_script( 'avia-main-child', get_stylesheet_directory_uri().'/js/main.js', array('jquery', 'avia-default'), 2, true );
    }
    add_action( 'wp_enqueue_scripts', 'enfold_child_custom_script', 100 );
    

    Really hope you can help. Thank you so much for your kind efforts in advance.

    Best regards,
    Sophie

    #968117

    Hi,

    1. To upload a lighter version of lato please use the same method to upload from Enfold > Import/Export > Custom font manager

    2. Please upload custom font ” Chelsea ” and assgn it to p and blockquote from Enfold > Advanced Styling

    3. Disable the “font-awesome” script by removing the first line inside the brackets and upload similar icons from http://fontello.com/ to Enfold > Import/ Export > Iconfont Manager

    for more info please check
    https://kriesi.at/documentation/enfold/typography/#how-to-upload-custom-fonts and

    Best regards,
    Vinay

    #970002

    Hi Vinay,

    thank you so much for your detailed information.

    1. Okay, I loaded each font weight of my requested font Lato separately, even though I loaded a zip file with all font weights in one zip file before. It seems to work, but I wonder why the local fonts do look different than Google fonts. For example, bold is not bold (it’s kind of “light bold”), even though I loaded Lato 700. Do you have any idea what is happening here?

    2. That’s what I tried, but in blockquote in Enfold > Advanced Styling it is only possible to change font color, border color, font size and line space. No font family can be added. Same with p style.

    3. The icons I need for my recipes are „check“ for marking the ingredients and recipe steps and “print” for printing the recipe (please find in private content box a link to my website where you can see print button and check marks) and these icons are already included in Enfold theme. So, do you mean by “Disable the “font-awesome” script by removing the first line inside the brackets” to disable like as follows? I am not quite sure how to do :o( :

    function enfold_child_custom_script() {
        wp_enqueue_style( 'font-awesome', array(), 1.0);
        wp_enqueue_script( 'avia-main-child', get_stylesheet_directory_uri().'/js/main.js', array('jquery', 'avia-default'), 2, true );
    }
    add_action( 'wp_enqueue_scripts', 'enfold_child_custom_script', 100 );

    Thank you so much for your kind help in advance.

    Wish for you a good day!

    Best regards,
    Sophie

    #972405

    Hi Sophie,

    We apologize for the late response.
    1. Instead of using font-weight of 700, you can use 400 instead and just change font-family instead, using this code:

    font-family: 'lato-v14-latin-bold', 'Helvetica Neue', Helvetica, Arial, sans-serif;

    or

    font-family: 'lato-v14-latin-bold', 'Helvetica Neue', Helvetica, Arial, sans-serif !important;

    2. Enfold > Advanced Styling is limited in options atm though there are plans to improve it in the future releases, for now I would suggest using Quick CSS in Enfold > General Styling, if you are having difficulty with the selector to use, you can always ask us :)

    3. As for loading font awesome, try to replace your code with:

    function enfold_child_custom_script() {
        wp_enqueue_style( 'font-awesome', get_template_directory_uri().'/config-layerslider/LayerSlider/static/font-awesome/css/font-awesome.min.css', false, 1.1);
        wp_enqueue_script( 'avia-main-child', get_stylesheet_directory_uri().'/js/main.js', array('jquery', 'avia-default'), 2, true );
    }
    add_action( 'wp_enqueue_scripts', 'enfold_child_custom_script', 100 );

    Hope it helps :)

    Best regards,
    Nikko

    #973591

    Hi Nikko,

    thank you so much for your kind help.

    1. I am a little confused about that. Not sure where to put your a/m code? Can you help and tell?

    font-family: 'lato-v14-latin-bold', 'Helvetica Neue', Helvetica, Arial, sans-serif;
    

    or

    font-family: 'lato-v14-latin-bold', 'Helvetica Neue', Helvetica, Arial, sans-serif !important;
    

    2. For blockquote styling I already used custom CSS as follows, but then the font will be loaded from Google server again. Can you help and tell how to load my local font that I already imported to Theme settings > Import/Export?

    blockquote {
    	font-family: Chelsea Market;
    }

    3. Awesome! Your code helped me to prevent loading font awesome from bootstrapcdn. Thank you so much, really do appreciate all your help!

    Again, I thank you so much for all your efforts that you put in my issues. I am so happy! Thank you!

    Best regards,
    Sophie

    #974002

    Hi Sophie,

    You’re welcome and glad we could help :)

    1.) You can apply this in Enfold > General Styling > Quick CSS, can you tell us where you want it applied? we’ll try to give you css codes that should help.

    2.) Try using:

    blockquote {
    	 font-family: 'chelsea-market-v5-latin-1';
    }

    In Enfold > Import/Export you should see how font family’s are declared.
    Hope this helps.

    Best regards,
    Nikko

    #974459

    Hi Nikko,

    thank you for your kind help.

    1. I think I got it. First, I had to change all the fonts for example for H1, H2, menu links etc. in Theme Options > Advanced Settings, because these fonts have of course not changed automatically and loaded locally. Second, I had to add your a/m code to my recipes Custom CSS as well, now it works perfecty :-) . But, still the local fonts do not look the same as they did when they were loaded via the Google server (as comparison I use your Church demo). Cannot figure out. Do you have any idea?

    2. Oops! I should have known, right ;-) ? Now that I have the code it’s clear to me. And yes, it is working :-) . Your a/m code for my blockquote font makes it loading from my local server instead of Google server :-) ! Thank you so much!!!!!!

    As always, thank you so much for all your help in solving my issues :-) !

    Wish for you a great day!

    Kind regards,
    Sophie

    #974960

    Hi,

    Glad we could help!

    Please take a moment to review our theme and show your support https://themeforest.net/downloads
    Don’t forget to bookmark Enfold Documentation for future reference.

    Thank you for using Enfold :)

    Best regards,
    Basilis

    #975289

    Hi there,

    number 1 still not solved ;-) .

    Regarding local fonts they still do not look the same as they did when they were loaded via the Google server. As comparison: I use your Church demo. Your Church demo with Google Font Lato looks different then mine with local Google font Lato. Cannot figure out. Do you have any idea?

    Can you help?

    Best regards,
    Sophie

    #975674

    Hi Sophie,

    Glad that almost everything is all good :)
    As for our Church demo, it uses Droid Serif and Open Sans.
    Also I forgot to mention to add

    font-weight: 400;

    after the font-family codes that uses custom code, since it does make it look a bit different since it uses a different thickness.

    Best regards,
    Nikko

    #980488
    This reply has been marked as private.
    #981094

    Hi swotes,

    You may need to use a caching plugin for it so it loads the fonts faster, since it uses alternative fonts first when the primary font you want to use is still not loaded.
    Another option I would suggest is to use Page Preloading in Enfold > Theme Options, so it shows a preloader first and once the site is properly loaded the page is revealed.
    Hope this helps.

    Best regards,
    Nikko

    #981112
    This reply has been marked as private.
    #981168

    Hi Nikko,

    I hope the above private message of participant “swotes” does not mess up my thread. Can you please tell where to put the code

    font-weight: 400;
    

    Would be great! Thanks a lot in advance.

    Best regards,
    Sophie

    #981228

    Hi Sophie,

    Thanks for the reminder, you can add it on all selectors you used a custom font, for example the code I gave:

    blockquote {
        font-family: 'chelsea-market-v5-latin-1';
    }

    should be changed to:

    blockquote {
        font-family: 'chelsea-market-v5-latin-1';
        font-weight: 400;
    }

    Best regards,
    Nikko

    #981238

    Hi swotes,

    Just to make this thread not confusing, please try to create a new thread and please put the link to this thread.
    Also Please post us your login credentials (in the “private data” field), so we can take a look at your backend (in the other thread).

    1. Install and activate ” Temporary Login Without Password “.
    2. Go to ” Users > Temporary Logins ” on the left-side menu.
    3. Click ” Create New “.
    4. Add the email address for the account ( you can use (Email address hidden if logged out) ), as well as the ” Role ” making that the highest possible and the expiry about four days
      ( do be sure that we have enough time to debug ).
    5. Click ” Submit “.
    6. You’ll now have a temporary account. Please provide us here in the private section the URL, so we can login and help you out.

    When your issue is fixed, you can always remove the plugin!
    If you prefer to not use the plugin, you can manually create a admin user and post the login credentials in the “private data” field.

    Best regards,
    Nikko

    #981474
    This reply has been marked as private.
    #982981
    This reply has been marked as private.
    #983010

    Hi Swotes,

    You have “Load google fonts in footer” checked in Enfold theme options > Performance tab. As mentioned in description “Loading the fonts in your footer will speed up the site rendering, but also cause a small flicker of text on page load”. Please uncheck the option to solve flickering issue.

    If you have any other questions or issues, please start a new thread under Enfold sub forum and we will gladly try to help :)

    Best regards,
    Yigit

    #983034
    This reply has been marked as private.
    #983287

    Hi Bernd,

    Glad you got it working for you! :)

    If you need further assistance please let us know.

    Best regards,
    Victoria

    #985021

    Thank you for your info regarding font-weight: 400, Nikko. I think I got it now :-) . You can close this thread now.

    Thanks again for all your help! Wish for you a great weekend!

    Kind regards,
    Sophie

    #985024
    This reply has been marked as private.
    #985396

    Hi Sophie,

    Thanks for the feedback. So everything is ok? Should we close the thread for now?

    Best regards,
    Rikard

    #985500

    Yes, everything is okay. Please close this thread :-) . Thank you!

    Kind regards,
    Sophie

    #985592

    Hi,

    Great, thanks for letting us know. Please open a new thread if you should have any further questions or problems.

    Best regards,
    Rikard

Viewing 28 posts - 1 through 28 (of 28 total)

The topic ‘Google web fonts still loading despite Custom Font Manager’ is closed to new replies.