Viewing 29 posts - 1 through 29 (of 29 total)
  • Author
  • #1141070

    I have a list of properties that I am creating a map for using the Maps widget – however when I preview the page, the map does not load. I have checked the API key in the Enfold settings and it says it is up to date and was able to connect.

    Any insight here on how I can get the map to display again? Page in question:


    Hey kelsycolbeth,

    Sorry for the problem. Could you try updating the theme to the latest version (4.6.2) to see if that helps please?

    Best regards,


    Hi there,

    Thank you for your reply. I’ve updated the theme and still no luck. I see all of the properties when I am within the map widget but still no luck getting the map to appear on the screen.



    You do not have latest enfold. Latest is 4.6 :)

    Best regards,


    What’s the secret here guys. I have an activated account. A verified domain. I created a Maps EMBED API and pulled the key and installed in your theme only to get the same message every time.

    “Could not connect to Google Maps with this API Key.”

    Google has really over-complicated this.

    Any pointers?


    I have the same problem with multiple websites (for clients)

    They regularly display “Could not connect to Google Maps with this API Key.” when entering the API key into the Enfold settings.

    Even when the API setup is completely unrestricted and I’m using my own Google account (which works for other maps), or their accounts. This problem seems to have happened in the last 2-3 months. Enfold and Wordprsess are up to date.

    I will link you privately to a specific site where it is not working, can you take a look at that and see what is causing it?


    I’m having the same problem. I have tried old keys, new keys, restricted keys, unrestricted keys, working keys from other accounts, attached billing, unattached billing – nothing works. I think this is a theme problem.


    Hi JamesC,

    Sorry for the problem, could you try updating the theme to the latest version (4.7.2) to see if that helps please?

    Best regards,


    Hi cadema,

    Please open a new thread and include WordPress admin login details in private so that we can have a closer look at your site.

    Best regards,


    I do have the latest version of Enfold.
    Account with Google is verified. Valid Credit Card on file.
    Geoloation API is on. Static Map API is on.
    Added the API to Enfold. No luck.

    Maybe there is a plugin you could recommend that works with the theme? That way I can determine if it’s the theme or something on my end?


    Thanks Rikard and my apologies, I thought we had already updated the theme on this site.

    However I have now updated to 4.7.2 and the same error appears – “Could not connect to Google Maps with this API Key.”


    Hi Justin,

    It would be great if you could open a new thread and provide us with details so that we can see the problem on your actual site.

    Best regards,


    Hi JamesC,

    You have selected to disable Google Maps under Enfold->Google Services, please try to activate it again and add your API key in the same place.

    Best regards,


    Hi Rikard – I must select the “enable” option in order to enter a key. I have done that, when I get the error. Whether I hit save or not, or whatever I do, it gives the same error.

    View post on


    Hi JamesC,

    Thanks for the update, could you keep the API key in the backend so that we can see which error message you are getting on the front end please? Or simply post it in private in your next reply.

    Best regards,


    Thanks Rikard

    I’ll put the API key in the private field below here. It doesn’t seem to save long-term in the theme settings area. (I am not deleting it as far as I know, but the field is regularly empty when I load that settings page.)


    Hi JamesC,

    I’ve added the API key for you and I see that it can’t connect to the Google Maps API, I can’t see it disappearing though. Note that you have to click Save all changes on the top or bottom of the page for it to save. Could you try to generate a new API key to see if that helps?

    Best regards,


    Have generated a brand new key and still get the same error.

    Could you try generating a test key from your end to confirm it works for you?

    View post on


    I’m also having the exact same issues. I’ve updated to the latest Enfold.

    I’ve generated multiple keys but nothing works, I keep getting the “Could not connect to Google Maps with this API Key” message.


    Hi ESB,

    Please start a separate thread, describe your issue there and give us a link to your website.

    Best regards,


    Hi, I’ve finally managed to get it working.

    God I hate how Google keep changing everything. After multiple tries setting up billing it finally worked.

    I can’t find the option to disable payments though. I’d rather have the maps stop displaying than pay google as if I get that many visitors I can assure you they won’t be legit visitors!

    anyway. It’s a google issue not enfold.

    • This reply was modified 4 years, 5 months ago by ESB.

    Hi ESB,

    Glad you got it working for you! :)

    Yes, it’s Google and their rules, there is nothing we can do. Use their maps or look for something else.

    If you need further assistance please let us know.

    Best regards,


    I’d love to see a google maps alternative built in to Enfold! Perhaps the maps widget can give options for different suppliers one day? :-)


    @ESB *how* did you get it working? I’d love to know :)

    TEAM have any of you successfully got this to work? A quick video or update of documentation showing the COMPLETE walkthrough would be very helpful


    Hi JamesC,

    The issue is on the Google side and Google provides plenty of documentation and there might be videos on how to get the key and set up billing.

    On the website, you just have to paste the key and the map will work.

    Best regards,


    I too would agree that the issue is likely with a Google. They say the new structure with Maps is “Developer friendly”, but it took me a handful of tries with a validated Credit Card on file with the associated account in order to make it work. Also ensure the account is verified with the website. Then create a new API.

    That worked for me. Best moving forward.



    Hi Justin,

    Thank you for weighing in. We cannot set up the billing or verify the account with Google, it has to be done by the website owners or their developers.

    Best regards,


    @Victoria. I am not sure you understood my post.
    But I was making recommendations on what a Developer can do to get the maps working. Verifying their Google account and adding a Credit Card to it will help. Google states their new process is ‘Developer friendly”. But to date, it has seemed like more of a challenge for most.


    Hi @Justin,

    Thanks for sharing your experience, it’s much appreciated :-)

    Best regards,

Viewing 29 posts - 1 through 29 (of 29 total)
  • You must be logged in to reply to this topic.