Tagged: , ,

Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #1085599

    Hi there,

    I am using Enfold’s google map feature on my website and I see the following error when I view that page “This page can’t load Google Maps correctly”. I first saw this error last fall, and I set up an API and added billing, and all was working as it should. The error is back again! I have just double-checked that the Google account set up is correct (it is). I also double checked the enfold API, and reverified (all is working as it should there as well). When I look at the Javascript error in my browser I see this error “Google Maps JavaScript API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys“. As I know that there is an API, and billing associated with it, and the API in the Enfold console is valid, I’m a bit at a loss. Can you help?

    #1086644

    Hey 1lizcollins,

    You have the header.php and the helper-main-menu in your child theme. Did you have them updated with the fresh version from the parent theme?

    Best regards,
    Victoria

    #1090487

    Thanks, Victoria.

    I replaced my header.php and helper-main-menu and the map still won’t work. I now see several errors, including a 404 error that has caused my google adwords campaign to be suspended. I’m also seeing some styling issues, but these are far less important than my google ads and map which are urgent and pressing respectively. You can see everything on my staging site, credentials below. Thanks for your help!

    #1090939

    Hi,

    Thank you for the update.

    We were able to verify or connect using the keys, so they’re valid. Did you add the site in the list of http referrers?

    // https://developers.google.com/maps/documentation/javascript/get-api-key#key-restrictions

    Best regards,
    Ismael

    #1091494

    I had not restricted the API so this step isn’t necessary, right? But in case it helps I have now done so, and added the site’s url as a referrer. The map still won’t load :(

    #1092184

    Hi,

    It is now necessary. It will throw the following error if the site is not listed.

    // https://developers.google.com/maps/documentation/javascript/error-messages#referer-not-allowed-map-error

    You have to add the site in the http referrers list.

    // https://cloud.google.com/docs/authentication/api-keys#securing_an_api_key

    Best regards,
    Ismael

    #1092450

    OK, I added the http referrer and now I am receiving several errors:

    – Google Maps JavaScript API warning: NoApiKeys
    – You have exceeded your request quota for this API.

    Billing is enabled and has been working just fine. And I know the API keys are correct, and set up properly because all has been working fine until very recently.

    #1092520

    Hey!

    The Geocoding Services API is probably not be enabled. Please turn it on by following these steps.

    // https://kriesi.at/documentation/enfold/google-map/#enable-services-for-google-api

    Are you using the keys on another project?

    Best regards,
    Ismael

    #1092531

    I checked and the Geocoding API is enabled. I’m not using the keys for anything else.

    #1093182

    Hi,

    Thanks for the update.

    We were able to verify the API key before but it’s not connecting now because the http referrer name or url is invalid (see error below). Please check the site url in the http referrer list. Make sure that it has a wild card pattern for protocol and relative urls.

    Example:

    *sbidemo.wpengine.com/*
    

    or:

    *.site.com/*
    

    What is the actual site url when the site goes live? You will have to add that url as well.

    Error:

    RefererNotAllowedMapError
    https://developers.google.com/maps/documentation/javascript/error-messages#referer-not-allowed-map-error
    Your site URL to be authorized: https://sbidemo.wpengine.com/wp-admin/admin.php?page=avia
    

    Best regards,
    Ismael

    #1101528

    Hi there,

    I have added both my indev install and my live site correctly. I see a “no api keys” error when I load the site, but when i look in the google services tab my api is clearly there and working. I’m now also seeing an error that says I have exceeded my request quote for this API even though I have not gone over budget. Can anyone help? This has been a revolving door of issues, that seem related to the theme not to google directly.

    #1101940

    New link to view page with map below…

    #1101986

    Hi 1lizcollins,

    Could you try updating the theme to the latest version (4.5.7) to see if that helps please? https://kriesi.at/documentation/enfold/how-to-install-enfold-theme/#theme-update.

    Best regards,
    Rikard

    #1122819

    Pardon for my pause. I have updated the theme and the map still won’t load. Help! My client really needs this to work, and I’m stumped.

    #1122913

    Hi 1lizcollins,

    Best regards,
    Victoria

    #1134970

    Hello all,

    I have checked my Google Maps API settings many, many times. I have even created a new API and applied that one. I continue to get this error, even though I can see the API in my google API account.

    I have successfully set this up on other sites and even with Enfold, so I am completely stumped here. I cannot fix anything on the google side as it is not broken. There seems to be an issue with the theme which is why I keep coming back to you guys. I am attaching new screenshots showing all of this. Please, please help. My client needs a map that works, and I don’t see anything that I can do to fix this.

    #1135892

    Hi,

    Thank you for the update.

    Do you have the version 3 of the key? Please make sure that you’re using the latest version of the API. Or post your GMAIL account here so that we can check the console.

    Best regards,
    Ismael

    #1136103

    I just created the newest API two days ago so I believe so! Login credentials are below. Thank you!

    #1136464

    Hi,

    Thank you for the update.

    The account is asking for a phone number confirmation. (see private field)

    Best regards,
    Ismael

    #1136471

    Hello Kriesi team,

    Please help urgent. I have the same problem now…
    Now we want transfer the page to the customer!
    it worked for several weeks, then just not anymore.
    Regards Stefan

    I fixit for me, but i think the is a a bug in version 4.6.1

    • This reply was modified 4 months, 2 weeks ago by  stimmungshoch.
    • This reply was modified 4 months, 2 weeks ago by  stimmungshoch.
    • This reply was modified 4 months, 2 weeks ago by  stimmungshoch.
    #1136597

    Thanks Ismael. See below.

    #1137764

    Hi,

    Thank you for the update.

    The option to just add the phone number is no longer available. It was available initially, but now I always get this when I try to access your account.

    // https://imgur.com/a/DdrwAVH

    You should probably try again and start from scratch. Delete the current google project and create another. Make sure that a billing account is attached to the new project.

    Best regards,
    Ismael

Viewing 22 posts - 1 through 22 (of 22 total)

You must be logged in to reply to this topic.