Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
  • #1354507

    I have buttons displayed over images & videos within Fullscreen Slider and a Fullwidth Easy Slider.
    Since updating to Enfold 5, the buttons appear as they always have and ‘dip’ when clicked but have no effect.


    Hey Steve,

    Please send us a temporary WordPress admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,


    Hi @Rikard

    Thank you for your reply.
    I’ve included the required details in private content.




    Thanks for that. I’ve tried to reproduce this problem on a test installation but I haven’t been able to, that means it’s likely caused by something local on your site. What happens if you remove all customisations, or temporarily deactivate all plugins?

    Best regards,


    I can reproduce this issue.
    Buttons on Easy Slider and Full Width Easy Slider are not working.

    The link address is there but the element is not clickable.


    Really sorry I cant leave the link active for much longer If you try the private data link I sent and the link has been removed it is because the client has woken up for the day.

    I can leave it active for a few hours more just yet.



    I’ve tested with all plugins deactivated, all additional CSS removed from Quick CSS, an empty functions.php file and CSS File & Javascript Merging And Compression deactivated in performance.

    The issue is still there, even when testing with a different browser in incognito mode.

    I have the exact same issue on another site which I’ve had to roll back for the time being as the slider button is the only way to progress into the rest of the site.




    thanks for the login, I copied your page to a test server but the buttons on the Fullwidth Easy Slider are working correctly, I saw that you had a custom avia.js in your child theme so I tried enabling your parent theme and disabling some of your plugins but it didn’t help on your site.
    I also see that we are using the same PHP version: 7.4.29 so I’m not sure what could be causing this but I couldn’t reproduce.

    @thinkjarvis thanks for the link to your site, I created a page with the Fullwidth Easy Slider and the Fullscreen Slider and tested buttons with page links, post links, manually links but I couldn’t reproduce your error.

    Best regards,



    You could see the issue on the link I sent over though right? Its not possible to click the button.


    Yes, I did see the issue on your site, but I’m not sure what could be causing it, if you post a link to a plain text file with your page shortcode I can test it on my test site, perhaps it is caused by a combination of elements?

    Best regards,


    Hi @Mike

    I’ve removed the avia.js as I’m not even sure why it was there. I’ve also cleaned the functions.php of the /shortcodes/ loading as this too wasn’t required. Upgrading the hosting to PHP8 has made no difference either.



    It seems to only be a problem if it is the first element on the page.

    • This reply was modified 1 year, 3 months ago by thinkjarvis.


    Its something to do with the combination of options selected within the slider.

    Found it!
    Use first slides caption as permanent caption

    If you turn this on the button links stop working in version 5.0.

    Try that on your test server. You can now see the button is working on my example site.

    Please can you add this to the bug fix list for version 5.1


    @thinkjarvis I tried switching around my elements, removing the second slider, and even adding a grid row like your page, but still couldn’t reproduce.

    only has two sliders on his page without other elements: clone of his page
    Best regards,



    Brilliant, excellent work, I’ve been creating test pages and duplicating sliders until my brain hurts!



    I can confirm that @thinkjarvis is 100% correct. As soon as I uncheck ‘Use first slides caption as permanent caption’ the links work as expected.



    & @thinkjarvis thank you I misunderstood. I reported to the Dev Team and will reply when I hear back.

    Best regards,


    Thank you for your patience, the Dev Team has replied with this file update:
    DropBox link to file
    Once you replace your slideshow.js file Please clear any cache plugin and your browser cache and check.
    Please note that clearing javascript files can sometimes require a couple of tries and Safari can be hard to clear the cache, often you need to also clear the history to fully purge the cache, following these steps for Safari and note Step 4 where you will Clear the History.
    This has been added to the next update.

    Best regards,


    Thanks Mike / Steve,
    Really appreciate the fast response.
    I’ll try the fixed code when I am next working on the clients site.

    Thanks for highlighting the issue with Safari and Caching its been a pain to deal with when some of my clients dont own laptops. Safari on Tablet (older versions in particular) has some serious issues with checking cache age thats for sure! Normally on mobiles a swipe down action in the browser will do the job but not every time.


    Thanks @Mike

    Do you have any idea when this will be included in an updated version?

    I have sites waiting for 5.0 to be installed but will wait if this fix will be included in 5.0.1 in the next few days rather than replace this file THEN have them all to update to 5.0.1 anyway.



    This has already been merged into our core files, so it will be in the next version, but I don’t know when that will be released.
    Please see this sticky thread: Enfold 5.0 is now available – please read this before updating we recommend that users update on a staging or development sites first.
    Please try testing each of your sites on a staging site before updating all of them at once, we have tried to test the v5 update as a team before releasing, but as you see this error slipped past us. Please note that this is a major update.

    Best regards,

Viewing 21 posts - 1 through 21 (of 21 total)
  • The topic ‘Fullscreen Slider and Fullwidth Easy Slider buttons not working in Enfold 5.0’ is closed to new replies.