Tagged: 

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #961864

    Hello,

    I’m having some problems with my bold and italics since the most recent Enfold update. Because the bold and italic fonts for Open Sans were not available by default, I added them by adding the following code to my functions.php doc:

    add_filter( 'avf_google_content_font',  'avia_add_content_font');
    function avia_add_content_font($fonts)
    {
    $fonts['Open Sans'] = 'Open Sans:400,400i,700,700i';
    return $fonts;
    }

    Then I added the following to my style.css doc:

    strong {
    	font-family: Open Sans, sans-serif  !important;
    	font-weight: 700 !important;
    	color: inherit !important;
    }
    
    em {
    	font-family: Open Sans, sans-serif  !important;
    	font-weight: 400 !important;
    	font-style: italic !important;
    }

    This was working great until I updated to the most recent version of Enfold (v4.4). After I updated, everything turned to Helvetica, so I went back into my General Styling tab and changed it back to Open Sans, but now the css I added isn’t taking. Everything with a strong tag is using Open Sans 600 rather than 700 and everything with an em tag is forcing an italic rather than pulling the italic weight.

    I’m not sure how to get it back to how I had it before and any help would be appreciated. Thanks!

    #962726

    Hey Kirstie,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Best regards,
    Victoria

    #963778

    http://valleyeyeassociates.com/wp-admin

    There is a double-password on this site because it isn’t live yet, so you’ll need to enter this password to get to the WP login page:

    Thanks!

    • This reply was modified 1 year, 2 months ago by  Victoria.
    #964924

    Hi,

    Best regards,
    Victoria

    #965012

    The problem is that what is in the code is not matching up with what is showing up on the website. When I use a font finder plug-in, it shows that all of the em tags are showing up as Open Sans Regular (400) even though the code says that they should be Open Sans Regular Italic (400i) and all of the strong tags are showing up as Open Sans Semibold (600) but the code says Open Sans Bold (700). I’ve tried clearing my cache and testing in a different browser, but I keep having the same display issue. The site is supposed to go live soon, so any help would be appreciated!

    #965322

    Hi,

    Your site is showing blank for me to test the font varaients.

    To upload and manage fonts please use the latest version of the theme and upload the fonts from Enfold > Import Export tab.

    https://kriesi.at/documentation/enfold/typography/# (Purchase code hidden if logged out)

    It is much easier to manager your fonts this way :)

    Best regards,
    Vinay

    #965440

    Sorry, the website went down temporarily last night while we transferred the domain to another account. I downloaded the .zip file from Google Fonts and uploaded it under the Import/Export tab, but nothing happened. It shows up in my Media Library, but when I go to my General Settings, it does not show any “Custom Uploaded Fonts” in the menu like it does in the article above.

    #965682

    Hi,

    Once you click on upload and see that the zip file is showing in the media library Please make sure to insert the zip file.

    Best regards,
    Vinay

    #966534

    Hi, I don’t think I explained myself very well. I have uploaded and inserted the zip file. But, when I go to my general settings, I do not see the “Custom Uploaded Fonts” section like there is in the example you sent over. The fonts are also not displaying on my website even though I uploaded the fonts specified in my css. I downloaded the .zip file straight from Google fonts, is there another format I should be uploading it in?

    #966837

    I tried uploading the same .zip file to another website using Enfold and it worked great. So, for some reason, it is only on this site that the feature isn’t working.

    #967288

    I was able to solve the functions.php problem myself by disabling CSS file merging and compression and Javascript file merging and compression under the Performance panel.

    My site is now looking the way I want it, but I am still not able to upload fonts through the Custom Font Manager, so that’s a bug you may want to be aware of!

    #967931

    Hi,

    I checked your site again and uploaded a sample Ubuntu font for testing purpose. There was no issue as you can see in the below screenshot the font shows up fine.

    Please read the documentation carefully and perform the steps correctly, I assure you it will work 100% :)

    To know more about enfold features please check – http://kriesi.at/documentation/enfold/
    Thank you for using Enfold :)

    Best regards,
    Vinay

    #969762

    I was finally able to get it to work. Thanks!

    #969778

    Hi,

    I’m glad you were able to get this corrected. If you need additional help, please let us know here in the forums.

    Best regards,
    Jordan Shannon

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Faux Bold and Italics’ is closed to new replies.