Tagged: 

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1232063

    Hi,
    I have a similar error to that reported by others on here.

    Editing posts / pages seems fine, but when I try to add a new post or page I see this in the header of the page:

    Warning: Creating default object from empty value in /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-admin/includes/post.php on line 716
    
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-admin/includes/post.php:716) in /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-admin/admin-header.php on line 9

    and the following error at the bottom of the page:
    Fatal error: Uncaught TypeError: Argument 1 passed to AviaBuilder::handler_wp_dbx_post_sidebar() must be an instance of WP_Post, instance of stdClass given, called in /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-includes/class-wp-hook.php on line 287 and defined in /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/template-builder.class.php:429 Stack trace: #0 /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-includes/class-wp-hook.php(287): AviaBuilder->handler_wp_dbx_post_sidebar(Object(stdClass)) #1 /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters('', Array) #2 /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #3 /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-admin/edit-form-advanced.php(712): do_action('dbx_post_sideba...', Object(stdClass)) #4 /homepages/4 in /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/template-builder.class.php on line 429

    Latest WP version and Enfold is up to date.
    I have tried with php 7.2, 7.3 and 7.4, same with each.

    This is pretty urgent as I need to post updates several times a week with online classes for my students during lockdown and I can’t add a new post right now to do so…

    Thanks in advance!

    #1232360

    I’m getting desperate now, I need to post to my site and it’s just completely broken.

    I’ve reinstalled WordPress and Enfold.

    This is the mess I get when I try to add a page:

    Broken mess!
    http://www.olpin.net/forumpics/enfold_broken1.png

    What on earth am I supposed to do to fix this?

    #1232377

    ### wp-core ###

    version: 5.4.2
    site_language: en_US
    user_language: en_US
    timezone: Europe/London
    permalink: /%year%/%monthnum%/%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 2
    dotorg_communication: true

    ### wp-paths-sizes ###

    wordpress_path: /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp
    wordpress_size: loading…
    uploads_path: /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-content/uploads
    uploads_size: loading…
    themes_path: /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-content/themes
    themes_size: loading…
    plugins_path: /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-content/plugins
    plugins_size: loading…
    database_size: loading…
    total_size: loading…

    ### wp-active-theme ###

    name: Enfold (Ilyo) (enfold-child)
    version: 0.1.0
    author: Richard Olpin
    author_website: http://www.richardolpinphotography.co.uk
    parent_theme: Enfold (enfold)
    theme_features: avia_exclude_bbPress, deactivate_tribe_events_calendar, avia_exclude_GFForms, avia_exclude_menu_exchange, avia_exclude_relevanssi, avia_exclude_WooCommerce, avia_exclude_wpSEO, avia_exclude_wpml, avia_exclude_instagram_feed, avia_mega_menu, avia_improved_backend_style, avia_option_pages_toggles, avia_sidebar_manager, automatic-feed-links, nav_menus, menus, widgets, post-formats, avia-disable-default-shortcodes, avia_post_meta_compat, force-post-thumbnails-in-widget, post-thumbnails, title-tag, editor-styles, editor-style, customize-selective-refresh-widgets, responsive-embeds, editor-color-palette, editor-font-sizes, avia_no_session_support
    theme_path: /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-content/themes/enfold-child

    ### wp-parent-theme ###

    name: Enfold (enfold)
    version: 4.7.6
    author: Kriesi
    author_website: https://kriesi.at
    theme_path: /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-content/themes/enfold

    ### wp-plugins-active (6) ###

    Akismet Anti-Spam: version: 4.1.6, author: Automattic
    Classic Editor: version: 1.5, author: WordPress Contributors
    Contact Form 7: version: 5.2, author: Takayuki Miyoshi
    EventON: version: 2.6, author: AshanJay
    Hide YouTube Related Videos: version: 1.4.2, author: SparkWeb Interactive, Inc.
    Honeypot for Contact Form 7: version: 1.14.1, author: Nocean

    ### wp-plugins-inactive (7) ###

    All In One SEO Pack Pro: version: 3.6.2, author: All in One SEO Team
    iQ Block Country: version: 1.2.9, author: Pascal
    Optimus: version: 1.6.0, author: KeyCDN
    Simple Revisions Delete by bweb: version: 1.5, author: Brice CAPOBIANCO
    WP-Optimize – Clean, Compress, Cache: version: 3.1.2, author: David Anderson, Ruhani Rabin, Team Updraft
    WP Google Fonts: version: v3.1.4, author: Noah Kagan
    WP Super Cache: version: 1.7.1, author: Automattic

    ### wp-media ###

    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    gd_version: 2.2.5
    ghostscript_version: not available

    ### wp-server ###

    server_architecture: Linux 4.4.223-icpu-044 x86_64
    httpd_software: Apache
    php_version: 7.4.8 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: -1
    upload_max_size: 2M
    php_post_max_size: 8M
    curl_version: 7.64.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: false

    ### wp-database ###

    extension: mysqli
    server_version: 5.7.30-log
    client_version: mysqlnd 7.4.8

    ### wp-constants ###

    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-content
    WP_PLUGIN_DIR: /homepages/43/d97354903/htdocs/www.BlackBeltAcademy.info/wp/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined

    ### wp-filesystem ###

    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable

    `

    #1232480

    Hi,

    Thanks for the login details and sorry for the problem. I’m not sure what is causing this on your site, I can’t reproduce the problem on a local installation. What happens if you activate the parent theme? Also, would you be able to downgrade your PHP version to 7.3 to see if that changes anything?

    Best regards,
    Rikard

    #1232510

    As per my original post I’ve tried with 7.2, 7.3 and 7.4

    #1233795

    Hi Richard!

    Hope you are doing well :)

    I have updated Enfold to the latest version 4.7.6.1 via FTP however I could not check the issue as WP admin logins are not working for me. Could you please check them once again?

    Best regards,
    Yigit

    #1233943

    Still not loading instagram on different sites
    Could you please look after it?
    I used the widget ‘Enfold Child Instagram’ in my Enfold child theme. Did not change anything myself. Latest version of enfold: 4.7.6.1 But other site same issue with 4.7.5

    Says in the widget: Errors found: Instagram heeft ongeldige data geretourneerd. (unvalid data returned by Instagram)

    • This reply was modified 2 months, 3 weeks ago by  JannyPolak.
    #1233949

    Hi @jannypolak,

    Please refer to this post – https://kriesi.at/documentation/enfold/instagram/ and use – https://wordpress.org/plugins/instagram-feed/ plugin to display your Instagram feed :)

    Best regards,
    Yigit

    #1233979

    Thanks for that, though I seem to have resolved it for now.

    I have no idea what happened, but it seemed like something was screwy in the database, and the only clue I have is that I think maybe I had two browsers open and had an editor running whilst enfold had updated on the other machine.

    Having tried reinstalling WP, Enfold and disabling all plugins nothing worked, but it was definitely related to the timing of the theme update so the only thing I had left to try was to wipe the database and restore a backup I had from a few days earlier. Thankfully that worked.

    So, I lost a few recent edits, but at least I can edit the site again now.

    #1234001

    Thanks for the quick reply. Plugin downloaded and works!

    #1234135

    Hi Richard,

    Glad it is resolved!
    Not really sure what went wrong either. If it happens again, please let us know so we can look into it :)

    @jannypolak You are welcome! If you have any other questions or issues, please start a thread under Enfold sub forum – kriesi.at/support/forum/enfold#new-post :)

    Best regards,
    Yigit

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Fatal Error – can't add new posts/pages’ is closed to new replies.