Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1225632

    I created a local test page.

    Color section and inside a header text. When I load it the text fades in.

    I did an online test with the same and there is no fade in the text.

    What am I missing?

    Thanks.

    #1226240

    Hey peterolle,
    Sorry for the late reply, could your jQuery be loading in your footer instead of your header?
    Some web hosts add this “feature” as a code snippet or a MU plugin, there is also an option at: Enfold Theme Options > Performance > Load jQuery in your footer, and some caching and minifying plugins also have this option.
    Do you get any errors in your browser console?

    Best regards,
    Mike

    #1226241

    If I am logged in it works fine.

    Normal user gets it random and no image.

    By random I mean if you click in the navigation and click and click and click and click and so on to see the pages, some fade, some not.

    So it is not a jQuery problem. Yes, I have Load jQuery in your footer active in options.

    Thanks.

    #1226264

    Hi,
    Thanks for the link to the other thread and your page, So I see that your header image URLs have been removed and are held in an attribute called data-wpfc-original-src until scroll when the attribute is removed and the image URL is replaced.
    So please disable the wpfc plugin and clear your cache to see if this helps, if it does then check your plugin options to disable this function.
    Perhaps this has to do with your header text too? Or try removing the diagonal border to see if that helps.

    Best regards,
    Mike

    #1226322

    Thank you Mike.

    You are talking how to fix the fade in of the text in the header?

    #1226388

    Hi,
    When I was checking your site and clicking each main menu item to see the Fade not working on each page, I noticed that the header images were not showing unless you scroll, so thus my reply above. I was thinking perhaps the Fade is related to your header images issue. Try disabling your WP Fastest Cache plugin to see if this is corrected. Or perhaps with the diagonal border over the text heading the animation is blocked? Probably not, but I would test without it.

    Best regards,
    Mike

    #1226726

    It was lazy load causing the images problem. Even if it should be visible as the image is in the header. No idea if it is because Enfold request the image in a special way or why, but I solved that excluding the header images from lazy load.

    Now the fade text occurs randomly.

    What can be the cause now that the other thing is fixed?

    Thank you.

    #1227761

    Hi,
    Sorry for the late reply, I have tried to recreate one of your pages with the special heading and a diagonal border and then compared the source code with yours, but I don’t see a difference to explain why yours is not working.
    Please check the page shortcode in the Private Content area, to see if I have the settings correct and if it works for you. Did you try to exclude the color section, or the special heading from the lazyload?
    Can you exclude whole pages? If so try excluding one page, if that helps then try excluding the color section, or the special heading to see if you can pin it down to one element. don’t forget to clear your browser and site cache between tests.
    If none of this helps please include your page shortcode for me to test.

    Best regards,
    Mike

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.