Viewing 30 posts - 1 through 30 (of 38 total)
  • Author
  • #915810

    I updated my staging site with 4.2.4 today and was chagrined to see that the full screen video bug seems to have come back with 4.2.4…. this time, instead of the play / progress bar being on the bottom of the video, as it has forever, it has now shifted with 4.2.4 to the top of the video and then disappears once it finishes loading.

    In private content I have included the exact same page on 4.2.4 and 4.2.3 so you can see the difference.

    New rule for the developers – you cannot release any more updates that “break” full screen video! :) :) :)



    Hey goldengate415,
    I wanted to recreate your issue with the self-hosted video, so I downloaded your video and added it as the background of a color section. Is this how you have it?
    On your site I see the screen is black, but I don’t see the progress bar at the top, does it flash quickly?
    With this setup on my localhost the video plays in v4.2.4, perhaps my setup is wrong.

    Best regards,


    Hi Mike!

    I’ve read your message six times now and I’m not sure what it means.

    Do you see the difference between how the staging site displays the video and how the production site displays the exact same video?
    The staging site displays a progress bar that stays until the video loads at the TOP of the screen. The production site displays that at the bottom of the screen. With very high speed connections I guess there is the possibility that it loads at the top of the screen and disappears? I am at a hotel traveling and my connection is not as fast as home.

    This is Full Screen Slider element with mp4 self-hosted video.

    Hope this helps.



    this is what he asked : and added it as the background of a color section. Is this how you have it?

    so your setup was: This is Full Screen Slider element with mp4 self-hosted video

    i will try the last too – because – allthough i try allways to avoid self-hosted videos now.
    I was very satisfied with cloudinary – and for the most circumstances the free version is absolutely enough.


    i think the controls could not be on the bottom – because .mejs-container has no height rule

    if you set:

    .mejs-container { max-height: 100% !important;}

    the controls are on the bottom.
    but you have to look if this leads to any conflict with other browser. – i did not test that for now


    Sorry for the confusion, what I saw was a video on 4.2.3 & no video on 4.2.4, so I jumped to the conclusion that the video controls was going to be a little box with a black screen, like the error we saw not too long ago were we added height and width to make the video show. Does that make since?
    So I checked your staging site in Chrome, Firefox, & Edge and see no video, Please see screenshots in Private Content area.
    I then tried to recreate this issue on my localhost by putting the video as a background in a color section:
    where the video works.
    Anyways, now I understand that you saw a video on your staging site, although now it’s not working, and the video controls were at the top, were as on 4.2.3 the controls are at the bottom.

    **I now realized that to see the controls I have to edit /avia-shortcodes/section.php because this is not default behavior.
    I also see that Guenni007’s code works to move it to the bottom, thanks :)
    Is my understanding correct?

    Best regards,


    Hi guys,
    Thanks for your help. I raced to my computer this morning (no coffee yet uh oh!!!) to check on this thread.

    – Video is not in a color section
    – Video does play on staging site url which is 4.2.4 Enfold, so Mike I’m not sure why it’s not playing on yours? I am using Chrome if that helps.
    – When I add code above (which I recognize as the code we attempted to use to fix the video bug in prior versions), the play bar goes away but the video no longer plays at all, with no option to play.

    4.2.4 is definitely the problem as the staging site is an exact copy of the production site… only difference is 4.2.4 on staging vs. 4.2.3 on production.



    dear Rob do you see the same error / fault on my test-page ?
    It is a selfhosted video on a fullscreen slider ! – And it is Enfold 4.2.4


    Yours looks good… I wonder what the difference is? Is your file mp4 format? Very strange.

    Which element are you using?


    As you said full-screen video slider – and yes it is an mp4 (h.264, baseline version 3.1 – or high 4.1)
    sometimes this is important for crossbrowser support
    What are the specifics of the video and audio formats supported?

    Although the protocol specification does not limit the video and audio formats, the current Apple implementation supports the following formats:
    H.264 Baseline Level 3.0, Baseline Level 3.1, Main Level 3.1, and High Profile Level 4.1.


    MP4… and again it worked on 4.2.3 so something the developers did broke it in 4.2.4.

    007 I noticed that on your demo page it is not full screen video as there is a header… try hiding the header to see if problem replicates on 4.2.4..?

    Mods, next steps please…. Thanks. Once again we have an update I can’t push to production because it breaks current video functionality. Thanks


    with transparency header it works : ✓
    wait if no header will work: ✓

    see test page with hide header on this site

    edit :
    Template : no header nor footer ✓. it works. ??


    007 Noted with thanks.

    Mods, next steps please? Are you able to replicate this? Do you want credentials to log into my staging site? Actually I’ll go ahead and insert them in private content…. see below for login.


    as i said above i inserted that little css to have the controls down the video !!!


    007 As I stated above, the css did not fix it. Please allow the mods to work this issue from here on out.

    Thanks and best regards


    Ok I have added the code from @Guenni007 to your General Styling > Quick CSS field and it is working good.
    Thanks Guenni007!
    Please clear your browser cache and check.

    Best regards,


    Hi Mike!

    Thank you for persisting on this one. I think the issue is Fast Velocity Minify Plugin, which has worked great with Enfold up until 4.2.4. Once I activate this plugin, the video just goes to black screen. Can you please take a look at the staging site again with the plugin activated?



    It was black for a while, but the video did show at the end. How do you think the video control solution is working?

    Best regards,


    Hi Mike,

    On my end, the black just stays on the screen… video never shows. I’m using Chrome in incognito mode. There is no circle spinner to indicate loading….

    Are you seeing something different? Can you try Chrome incognito?

    Thanks much,


    Please see Please see screenshot in Private Content area from Chrome incognito.

    Best regards,


    Hey mike that’s the home page….


    Opps, your right, and I saw the page was not working, but found that the plugin Fast Velocity Minify was causing the issue.
    Please check :)

    Best regards,


    I HAD TO MAKE Guenni007’S CSS hack to make the enfold update work for full screen videos to work. Whats going on there at Kriesi? I always thought this was a safe theme/company but I am having to work extra just to keep up with this.


    Hi mike yes I identified that in the post above. But there was no conflict until this version of Enfold…. what changed ? Possible to fix ? Thanks


    Very good, I read back again and see that now. Unfortunately I would say that there is not a possible fix for a minify plugin that is braking a script, other than not using it.

    Best regards,


    On the Fullscreen Slider options, if I choose “hidden” controls instead of “default” controls, the controls don’t hide, but the video does start working. Given that there’s erratic behavior with the Fullscreen Slider, and this has been an issue on and off since last October, AND this just popped up with this week’s 4.2.4 upload, I think it’s not the minify plugin. There’s something else going on here. Can you ask the developers to take a look? Or?


    I think in your statement:

    On the Fullscreen Slider options, if I choose “hidden” controls instead of “default” controls, the controls don’t hide

    the reason the video controls don’t hide is because the option you are looking at is for the “Slideshow control styling” to show or hide the video controls please look at “Hide Video Controls” option, when you edit the video inside the Fullscreen slider.
    But with the “Fast Velocity Minify” plugin active none of these options allow the video to play in “chrome incognito” even though as we established earlier, the video will play in a normal chrome window. I have set the controls to default and the video still plays in normal chrome.
    But I have found that the error for the video not playing in “chrome incognito” with the “Fast Velocity Minify” plugin active is:

    Uncaught TypeError: footer-eb2377dd-1519352885.min.js:1399

    which is from the footer js file from the Fast Velocity Minify plugin.
    The good news is, if you go to the “Fast Velocity Minify” plugin settings and choose “Disable JavaScript processing” it solves the error and the video will play in “chrome incognito” just like the normal chrome.
    Now you can have the “Fast Velocity Minify” plugin active and play the videos.
    As a side note, I see you have some js listed in the “Ignore List” of the “Fast Velocity Minify” plugin, I imagine you could expand this list and not need to use the above setting.

    Please see screenshot in Private Content area.
    Best regards,


    i sometimes have to do it with bwp minify as well. My additional google maps plugin f.e. has to be excluded to run.


    Hi Mike, thanks…. I appreciate your continuing to dig into this. I’m bummed that this new release means I have to eliminate more js from processing… and given that the larger picture of the next few updates seems to be to re-work js and make the theme more efficient <?> I’m wondering if at some point I’m going to need to disable minifcation etc… ?

    I’m on the road today but should have some time tomorrow to work on this… please keep this thread open for now. Thanks!



    We will leave this open for now, & I can understand your concern. But I believe you are going to be very happy over the next few updates :)

    Best regards,

Viewing 30 posts - 1 through 30 (of 38 total)
  • The topic ‘Enfold 4.2.4 self-hosted video bug back….’ is closed to new replies.