Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1271626

    Hi, I updated WP version to 5.6 on the website http://www.cabler.it and I faced with problems about the principal menu. I searched for answers on your forum and I found this topic: https://kriesi.at/support/topic/problems-after-updating-to-wordpress-5-6-read-this-first/
    After following directions, the new plugin Enable JQuery Migrate Helper sent me a notification:
    “Right now, you are using a plugin to support some old code in this website’s jQuery JavaScript library. That code is deprecated, meaning it is basically obsolete and is losing the support of your themes and plugins and WordPress itself.
    This plugin, called Enable jQuery Migrate Helper, is not a fix. It is a temporary solution to give your plugin and theme authors time to update.
    If you get warnings, please check for updated versions of the plugin or theme that generated the warning. There will very likely be one you can install. When you have updated your plugins and themes, and there are no more warnings, please deactivate Enable jQuery Migrate Helper.
    You are currently using a legacy version of jQuery. It has no support and doesn’t receive security updates. Please upgrade as soon as possible. ”

    How can I overcome this problem? Thank you.

    Valentina

    #1271871

    Hi Valentina,

    Sorry for the problem. Please continue using the jQuery migrate helper plugin until the next version of the theme is available. It should be ready within a week or two.

    Best regards,
    Rikard

    #1279006

    Hi, I received some time ago a warning about the jQuery library.
    You can view captured and logged deprecations at https://cabler.it/wp-admin/tools.php?page=jqmh&tab=logs.
    Recently, I have been notoced on my backend that no deprecations have been logged on my website and maybe I no longer need the jQuery Migrate Helper plugin. So I tried to deactivate it but the main menu still doesn’t work.
    Do you have news about next version of the theme?
    Thank you.

    Valentina

    #1279307

    Hi Valentina,

    Sorry for the long wait, but the new version of the theme is still not available unfortunately. We can fix the problem with the alternate mobile menu for you though, after that you should be able to remove the jQuery migrate plugin. If you want us to do that, then please make sure that you have backups of the site.

    Best regards,
    Rikard

    #1283118

    Hi Rikard, ok. Please proceed with the solution you are proposing. Do you need any specific data from me?
    Thank you.

    Valentina

    #1283565

    Hi Valentina,

    Thanks for the update. I’ve updated the file in question, but it’s still not working, since you are running an old version of the theme. Could you try to update to the latest version (4.7.6.4) to see if that helps please? The update to 4.7.x has to be done manually from the version you are running, please refer to my replies in this thread: https://kriesi.at/support/topic/enfold-4-5-theme-update-update-failed-download-failed-a-valid-url-was-not-pro/#post-1021541

    You can either update manually via FTP: https://kriesi.at/documentation/enfold/how-to-install-enfold-theme/#theme-update, or use a plugin to upload the theme zip file: https://wordpress.org/plugins/update-theme-and-plugins-from-zip-file/

    If that doesn’t work then please try to delete the whole theme folder, then replace it with the new version. Make sure that you have backups of the site before starting updating.

    Also please read this after you have updated: https://kriesi.at/documentation/enfold/theme-registration/

    If you need help with updating, then please post FTP login details in private as well.

    Best regards,
    Rikard

    #1284372

    Hi Rikard, do you refer to Enfold parent or Child theme?

    #1284735

    Hi,

    I’m referring to the parent theme.

    Best regards,
    Rikard

    #1284890

    Ok, thank you! It’s working now.
    Best regards.

    Valentina

    #1284898

    Hi,

    Did you need additional help with this topic or shall we close?

    Best regards,
    Jordan Shannon

    #1285003

    You can close it, everything is working now.
    Thank you.

    Valentina

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Enable JQuesry Migrate Helper on WP 5.6’ is closed to new replies.