Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1186111

    This topic has numerous posts over the years. The recommendation from mods to stop the Google Search Console error is to disallow the directory in robots.txt.

    However as pointed out by user pentasys further on in this thread, this is not enough to stop the error.

    The user suggested to add an index.html file to the directory with a noindex command is fine: except that after every Enfold update, every user would have to remember to re-add the index.html file into /framework because the update would (I assume) overwrite/delete the user-added index.html.

    A further user suggestion was then made for the theme to permanently add such a file into /framework, with the correct code to stop indexing, so that these Console errors are stopped permanently, and then (I assume) we can also remove the Disallow from robots.txt.

    This suggestion has been ignored. I’m fed up with these “errors” being reported to me every month or so by Google, for what is a problem of the theme’s making.

    This is a simple fix. PLEASE can a request be added so the next theme update adds index.html to /framework to solve this problem once and for all? After all, some folks might not search back through old posts and you mods will just keep answering this same old question for the rest of eternity: unless you fix it… :-)

    #1188067

    Hey,

    Thanks for contacting us!

    We need to discuss this with Kriesi first. If he agrees, we will add the file in upcoming updates.

    We will share this thread with Kriesi as reference. Please kindly wait to hear from us :)

    Best regards,
    Yigit

    #1198015

    Hi,

    Our devs think this is a problem of server security configuration. Normally if you go to a folder you recieve “Forbidden You don’t have permission to access /wp-content/themes/ on this server.” This is also set by WP by default in htaccess.

    Have you made any changes in .htaccess file? If not, could you please contact your hosting provider and ask them why is it possible to navigate to /wp-content/themes/ folder?

    Best regards,
    Yigit

    #1198126

    Hi,
    I think the relevant section in my .htaccess file is:

    # Block the include-only files.
    RewriteEngine On
    RewriteBase /
    RewriteRule ^wp-admin/includes/ – [F,L]
    RewriteRule !^wp-includes/ – [S=3]
    RewriteRule ^wp-includes/[^/]+\.php$ – [F,L]
    RewriteRule ^wp-includes/js/tinymce/langs/.+\.php – [F,L]
    RewriteRule ^wp-includes/theme-compat/ – [F,L]

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    Options All -Indexes

    I added the blocking of includes files because I read somewhere else to explicitly block these. The last line ‘Options…’ was added as recommended in the link in this post: https://kriesi.at/support/topic/google-search-console-403-error-on-directory-wp-contentthemesenfoldframework-2/#post-1013166

    If I type in http://yoursitename.com/wp-includes/ then I get a Forbidden message. If I do the same for /wp-content/ or /wp-content/themes/ I get a blank screen with no messages. This may indicate a problem because the wpsuperstars page says I should get a 403 or 404 page.

    Ideas?

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.