Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #870154

    I have read several support threads regarding dealing with a 403 error in Google Search Console for the following path:
    /wp-content/themes/enfold/framework

    The suggested solution is to add the following to your robots.txt file.
    Disallow: /wp-content/themes/enfold/framework/

    My concern with doing that is it goes against advice I have read online about disallowing paths to WordPress folders.
    See this article on the subject from February 2017 by Yoast. https://yoast.com/wordpress-robots-txt-example/

    Is it safe to “Disallow: /wp-content/themes/enfold/framework/” or could that affect my google ranking for other pages on my WordPress website?

    Your advice would be appreciated.

    #871053

    Hey fusionxs,

    I can’t see reason to why your SEO results should go down if you select to not have that folder indexed, it doesn’t contain any of the content on your actual site. I would say that disallowing it is safe.

    Best regards,
    Rikard

    #871276

    Thanks for coming back to me.
    I will disallow wp-content/themes/enfold/framework in my robots.txt file on your advice.

    Keep up the good work!

    Kind regards

    #871629

    Hi,

    Great, we’ll keep the thread open in case you should have any further questions or problems after disallowing that folder.

    Best regards,
    Rikard

    #1000325

    Good Morning,

    It is not enough to have a Disallow in the robots.txt file
    Google indexes the URL http://www.yourdomain.com/wp-content/themes/enfold/framework/
    Google has notified me of the coverage index error of this URL even though I had put the Disallow in the robots.txt file
    on the google support page specify it:

    It has been indexed although a robots.txt file has blocked it: the page has been included in the index even though it is blocked by a robots.txt file. Google always follows the indications of these files; however, if there are links to the page on other websites, it will index it. We do not consider it an error because we are not sure if you intend to block the page so that it does not appear in the search results. If you want to block it, robots.txt is not the appropriate mechanism to prevent it from being included in the index; instead, use a “noindex” directive or prohibit anonymous users from accessing it by requiring authentication. With the robots.txt Tester, you can find out which rule blocks the page. Due to the robots.txt file, it is likely that the fragments of this page that are displayed in the search results are not optimal. If you do not want to block the page, unlock it in your robots.txt file.

    The only solution is that the URL http://www.yourdomain.com/wp-content/themes/enfold/framework/ can have an HTML response code that can be included in the “noindex” directive.

    I have looked at what is in the URL http://www.yourdomain.com/wp-content/themes/enfold/framework/ and I see that there is a PHP file: avia_framework.php only. Could you add a blank index.html file in that directory but with the “noindex” directive? Would this change affect the functioning of Enfold? Thanks and best regards

    #1000949

    Hi,

    You can also add a 301 redirect on your web site, that will redirect that link to something else ;)

    Best regards,
    Basilis

    #1000953

    Hi! I’m having a Google search Console issue as well — it’s no longer recognizing my property. I put my tracking code into the Google Services area of Enfold’s theme; how do I get Google Search to verify my site? It’s been verified for years before this.

    #1001048

    Hi,

    Add this code to your child theme functions.php:

    
    function avia_custom_head_script() {
        ?>
    <!– Google Analytics –>
        <?php
    }
    add_action('wp_head', 'avia_custom_head_script');
    

    and replace:

    
    <!– Google Analytics –>
    

    with your Google code.I.e. include your Google analytics code or add the verification meta tag.

    Best regards,
    Dude

    #1012386

    I have exactly the same error and thus question as pentasys above – can I just place a index.html in that folder with the following or is there a better/other method to fix that Google Crawl error?

    <!DOCTYPE html>
    <html><head>
    <meta name="robots" content="noindex, nofollow" />
    </head>
    <body>(…)</body>
    </html>

    algkents problem seems to bit another one and not related to this thread…

    #1013166

    Hi,

    You can add a index.html to the folder. In addition you should disable directory listing to block users from browsing your directories. This article will help you: https://www.wpsuperstars.net/how-to-disable-directory-browsing-wordpress/ (if you’re not using Apache see https://www.netsparker.com/blog/web-security/disable-directory-listing-web-servers/ )

    Best regards,
    Peter

    #1209275

    Following Dude’s recommendation, I went ahead and did what the WP Superstars article suggested.

    However, can Team Kriesi confirm that disabling directory listing and browsing by using the Options All -Indexes in .htaccess doesn’t affect anything in terms of SEO and theme functioning correctly?

    Thank you!

    #1211040

    Hi,

    It should work just fine. The directive Options All -Indexes just disables the viewing of the directory or turn off the mod_autoindex module — the module that automatically generates the directory.

    // https://httpd.apache.org/docs/2.4/en/mod/mod_autoindex.html

    Best regards,
    Ismael

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.