Viewing 27 posts - 1 through 27 (of 27 total)
  • Author
    Posts
  • #1174673

    Everytime we try edit a page or post we are getting this critical error. It happened after updating WP to the newest version and the theme to the newest version. What information would be needed to help troubleshoot as the error is very vague.

    #1174681

    I’m getting this same issue!
    the site is reporting the following error details:

    Error Details
    =============
    An error of type E_ERROR was caused in line 981 of the file [redacted]/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/timeline/timeline.php. Error message: Call to undefined function rray_key_exists()

    #1174708

    I am getting the same results on multiple sites….There has been a critical error on your website. Please advise.

    Anna

    #1174709

    This is also impacting the front end of my site at this point. Please see here: https://www.commoninterestsfinancial.com/services/

    #1174895

    Hi commoninterests,

    https://share.getcloudapp.com/DOuvlbnQ The code you’re referring to has the correct function. DO you really have it like this “rray_key_exists”? If yes, please add an “a” it has to be “array_key_exists” and you need to update your php to php7.

    Best regards,
    Victoria

    #1174899

    Hi IdahoEmploymentLawyers,

    Can you please check the server log for error?


    @annameis
    Please start a separate thread, describe your issue there and give us a link to your website?

    Best regards,
    Victoria

    #1175117

    Victoria,

    I’ve updated PHP to 7.

    lines 979-981 in that file read as follows:

    if( ! empty( $this->title_styling ) )
    {
    if( !rray_key_exists( ‘font-size’, $this->title_styling ) )

    looks like there was a typo in the file after all! I replaced the ‘!’ with an ‘a’ and everything seems to be working fine now. thanks for the help.

    #1175256

    Hi,

    Sorry for the problem, please replace this file: /enfold/config-templatebuilder/avia-shortcodes/timeline/timeline.php

    With this: https://www.dropbox.com/s/qjdgp4h1ye8o48m/timeline.php?dl=0

    Best regards,
    Rikard

    #1176941

    So I am trying to get into this directory – /enfold/config-templatebuilder/avia-shortcodes/timeline/timeline.php and there is no Timeline folder in Avia-shortcodes. What are my next steps in solving this?

    #1177290

    Hi IdahoEmploymentLawyers,

    Image 2020-01-22 at 21.18.41.png
    https://share.getcloudapp.com/7KuyZYPD There should be, are you using the child theme?

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Are you running Enfold 4.7.1 or earlier?

    Best regards,
    Victoria

    #1178226

    Notes in Private Reply

    #1178431

    Hi IdahoEmploymentLawyers,

    Thanks for the FTP details and sorry for the confusion, my previous reply was directed to another user posting in your thread. Please send us WordPress login details as well so that we can have a closer look at your installation.

    Best regards,
    Rikard

    #1179117

    Hidden Details

    #1179409

    Hi,

    Thanks for that and sorry for the problem. I see that you are running an old version of the theme, could you try to update to the latest version (4.7.2) to see if that helps please? The update to 4.7.x has to be done manually from the version you are running, please refer to my replies in this thread: https://kriesi.at/support/topic/enfold-4-5-theme-update-update-failed-download-failed-a-valid-url-was-not-pro/#post-1021541

    You can either update manually via FTP: https://kriesi.at/documentation/enfold/how-to-install-enfold-theme/#theme-update, or use a plugin to upload the theme zip file: https://wordpress.org/plugins/update-theme-and-plugins-from-zip-file/

    If that doesn’t work then please try to delete the whole theme folder, then replace it with the new version. Make sure that you have backups of the site before starting updating.

    After you have updated then try to activate the Classic Editor in the main page of the theme options.

    Also please read this after you have updated: https://kriesi.at/documentation/enfold/theme-registration/

    Best regards,
    Rikard

    • This reply was modified 4 years, 4 months ago by Rikard.
    #1179628

    Where am I getting the updated version? I am coming in after the old web developer refused to fix these issues. I have no clue where you’re getting version 4.7.

    #1179985

    Hi IdahoEmploymentLawyers,

    Do you have access to the Themeforest account?

    Best regards,
    Victoria

    #1180120

    Unfortunatly I believe it was the old web developer who had this. I have the purchase code and date in an email for License Certificate.

    #1180474

    Hi IdahoEmploymentLawyers,

    I would try to reach out to the old developer then to see if you can get access to the theme files on Themeforest, if you can’t then I would recommend that you purchase a new license. Otherwise you will have this same problem every time you want to update, and you won’t get any automatic updates without a purchase code/update token either.

    Best regards,
    Rikard

    #1181895

    Old developer is unresponsive and could care less about resolving this issue. As of right now the site is unable to be updated. Is there nothing else we can do with the purchase information they have?

    #1182324

    We get the same critical error on a site. It’s a site we tok over that is on an earlier version of Enfold 3.x something, tried to update the website and now the entire website is a critical error so we’re reverting the update.

    • This reply was modified 4 years, 3 months ago by tekniskakari.
    #1182440

    Hi IdahoEmploymentLawyers,

    I don’t think so to be honest with you. You could try reaching out to Envato support as well, but I think they will tell you the same thing. You will need access to a Themeforest/Envato account which has been used to purchase the theme license.

    Best regards,
    Rikard

    #1188205

    Hello, I am having the same problem on a fresh install of WordPress, brand new installation of the theme, no plug-ins. The front of the site loads, but the admin area has this message:

    “There has been a critical error on your website. Please check your site admin email inbox for instructions.”

    I tried replacing the timeline.php file, per above, and checked the PHP (it’s version 7.2)

    Please help!

    • This reply was modified 4 years, 3 months ago by Empiread.
    #1188592

    Hi Empiread,

    Can you please check the server log for error?

    Best regards,
    Victoria

    #1188594

    This is the error I am getting:

    [Tue Feb 25 22:50:27.981717 2020] [cgid:error] [pid 36054:tid 47998828533504] [client 73.136.47.232:52261] AH01271: exec used but not allowed in /home/etasigma/public_html/500.shtml, referer: http://etasigmaalpha.com/new/wp-admin/theme-install.php?browse=featured

    #1188931

    Hi Empiread,

    This path does not even have WordPress in it.

    Please start a separate thread, describe your issue there and give us a link to your website and post credentials there.

    Best regards,
    Victoria

    #1188941

    I included the link to the site and credentials in the “Private Content” section of the post.
    Of course the error is on the admin login page so you can’t actually login.

    • This reply was modified 4 years, 3 months ago by Empiread.
    #1189156

    Hi,

    Thanks for the login details, but I’m getting a 500 internal server error on the login page so I can’t login:

    This page isn’t working
    yoursite.com is currently unable to handle this request.
    HTTP ERROR 500

    Please open a new thread if you should need any further help on the topic, as threads like this can get very messy otherwise.

    Best regards,
    Rikard

Viewing 27 posts - 1 through 27 (of 27 total)
  • You must be logged in to reply to this topic.