Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #1419483

    Am getting a critical error message when trying to edit the home page of the website

    can log into admin fine and am also able to view the site.

    Error message appears when trying to edit the home page.
    error details email says..

    Error Details
    An error of type E_ERROR was caused in line 3768 of the file /home/sites/26a/8/8b9cdb854b/public_html/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/class-element-templates.php. Error message: Uncaught TypeError: Argument 1 passed to aviaElementTemplates::set_locked_attributes() must be of the type array, string given, called in /home/sites/26a/8/8b9cdb854b/public_html/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow_fullsize/slideshow_fullsize.php on line 1128 and defined in /home/sites/26a/8/8b9cdb854b/public_html/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/class-element-templates.php:3768
    Stack trace:
    #0 /home/sites/26a/8/8b9cdb854b/public_html/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow_fullsize/slideshow_fullsize.php(1128): aviaElementTemplates->set_locked_attributes(”, Object(avia_sc_slider_full), ‘av_slide_full’, Array, Array, ”)
    #1 /home/sites/26a/8/8b9cdb854b/public_html/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow_fullsize/slideshow_fullsize.php(1172): avia_sc_slider_full->get_element_styles(Array)
    #2 /home/sites/26a/8/8b9cdb854b/public_html/wp-content/themes/enfold/config-t

    have set enfold login and etails below in private content


    Hey madmanbean,

    Thank you for the inquiry.

    We logged in to the site and noticed that the theme is a bit outdated. Please upgrade the theme from version 5.6.2 to the latest version, 5.6.6, and make sure to purge the cache afterward.

    Best regards,


    Ok I will update the theme but what concerns me is that it is only the one page that creates this error rather than all of them. Having already trying to clear all caches it would seem, to me that the error is in the database rather than a file.


    Ok I have updated the theme, cleared all caches and, as expected, the error message is still there when trying to edit the home page.

    What next?



    Thank you for the update.

    The error seems to be related to the Fullwidth Easy Slider. Have you tried to delete the slider and recreate it from scratch? If you’re unable to remove the slider from the builder due to the error, try switching the builder to debug mode and then remove the actual shortcodes from the shortcodes field. Please check the documentation below for more info.


    Best regards,


    have added debug mode but same problem still exists as cannot open the edit page without the error message


    Ok.. have fixed it..

    enabled debug mode and switched to a wordpress theme. This showed the code for the home page which I could then edit.

    removed the code for the header and updated. went back to child theme and viewed the home page which still showed the full screen slide show.

    however, when I clicked on edit this time the enfold editor opened and works again.

    Why that slider was still there I do not know as I purged the cache as well!

    Any thoughts as to why the full screen slider remained?



    Thank you for following up.

    The slider should have been disabled when you remove the shortcodes. We are not sure why it remained there, but glad to know that the slider attributes have been updated and the error has been removed. You might be able to do these steps by switching to the classic editor instead of activating a different theme.

    Best regards,

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.