Tagged: , ,

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #1146188

    @yigit

    As offered in post https://kriesi.at/support/topic/cookie-consent-bar-on-mobile/#post-1146162 I like you to help me with the cookie issue on tablet and mobile

    I hereby sent you separately my logins to replace in the parent theme: /enfold/js/avia-snippet-cookieconsent.js file with this one – https://github.com/KriesiMedia/enfold-library/blob/master/temp_fixes/Enfold_4_6_3/avia-snippet-cookieconsent.js

    Many thanks in advance!

    #1147809

    Hey JannyPolak,

    Thank you for following up.

    The consent bar shows up fine on mobile view, at least in an emulation. Is it working properly on your end now? The theme is already upgraded to v4.6.3.1, which contains the cookie consent fix above.

    Best regards,
    Ismael

    #1147812

    Sorry, unfortunately at least on mobile iPhone no cookie bars below to be seen…
    And everything is updated to 4.6.3.1 already.
    Maybe you can check again the post of Yigit? See earlier in this topic

    #1148252

    Hi,

    Did you remove the browser cache in your phone? Please toggle the Enfold > Performance > File Compression settings, then test it on a private or incognito mode.

    Thank you for the update.

    Best regards,
    Ismael

    #1148357

    I did the things you mentioned in Enfold Child but still not working on iPhone

    However, this was the reaction before – in another topic – from @yigit: He said to do this in the parent theme
    But since I am afraid to ruin my website, he suggested to make this new topic, asking you to do this for me

    My question now is:

    Can I do this without any risk in the parent theme, as @yigit proposed someone else:
    “Please go to Enfold theme options > Performance and disable “Javascript file merging and compression”, save theme options, flush cache once again then enable it. ”

    And secondly, I will not be the only one suffering with this problem is it?
    Is there really no other way to solve this?

    • This reply was modified 1 month ago by  JannyPolak.
    #1148746

    Hi,

    “Please go to Enfold theme options > Performance and disable “Javascript file merging and compression”, save theme options, flush cache once again then enable it. ”

    The steps above will only disable the script compression, then merge the scripts back again, so it won’t do any harm to the site. We disable the compression settings temporarily for the “modeo” site. Please try to check the page again. Make sure that the browser cache is removed beforehand.

    Best regards,
    Ismael

    #1148865

    Hi, Both on iphone and ipad MODEO does not show the cookie bar. The bar is only visible on my Mac
    Tried on Safari and Chrome, and all browsercaches emptied

    It also is conflicting with the contactform recaptcha, since the recaptcha is not visible after emptying the browsercache. And it says on mobile and ipad, instead of showing the recaptcha: ‘This contact form is deactivated because you refused to accept Google reCaptha service which is necessary to validate any messages sent by the form’. I use the V2 method

    Only after re-saving in the backend of WordPresse the page with the contactform, the recaptcha is visible again on some devices.. I did not change anything. How can?
    Both on wifi as well as on 4G this issue.

    This is a problem for customers who want to contact me by the contactform.

    I am totally confused what to do

    • This reply was modified 1 month ago by  JannyPolak.
    #1148902

    https://kriesi.at/support/topic/cookie-consent-bar-on-mobile/

    Done!

    • This reply was modified 1 month ago by  tjg.
    • This reply was modified 4 weeks, 1 day ago by  tjg.
    #1149230

    .

    • This reply was modified 4 weeks, 1 day ago by  tjg.
    #1149689

    Hi,

    @jannypolak: It makes sense that the spam protection doesn’t work initially on load because the consent bar is still missing. Users have to accept the cookies first and refresh the page in order to use the contact form properly but they’re not able to do that because of the issues pointed above. We edited the avia-snippet-cookieconsent.js file in the “modeo” site as suggested in the previous thread and purged the cache. Let us know if it changes anything.

    Best regards,
    Ismael

    #1149821

    Yeaaaahhhh! It shows a cookie bar.

    Still one request, because two other websites are still not working properly as well…

    Could you please help me with the other two websites to give here a step by step instruction for me?
    This will help me (and maybe others) in the future..

    Many thanks in advance

    PS I use the Child Theme and W3 total cache. Usually I click on top of the dashboard at Performance > purge all cache. But it obviously did not help..
    I must have done something wrong or forgot something

    #1150380

    Hi,

    Awesome! Glad it worked.

    We added the modified version of the js/avia-snippet-cookieconsent.js in both sites, and disabled the file compression settings temporarily. Please don’t forget to remove the browser cache prior to testing. Let us know if the consent bar will display properly then.

    Best regards,
    Ismael

    #1150473

    Hi

    The bars are visible on both sites. I am very glad you solved this

    1. Can I leave ‘CSS file merging and compression’ disabled? Or what should I do?
    2. Can I leave ‘Javascript file merging and compression’ disabled? Or what should I do?
    3. I am now in the process of a new website, what are the steps I should do to avoid problems with the visibility of the cookie bar for this site ? Disable those two (as mentioned in 1 and 2) as well?

    After this reply from you, I will be fine ;)

    Thanks in advance 💛

    #1150847

    Hi,

    Great! Glad that the consent bars are now visible.

    1-2) You can definitely enable the file compression settings, but new changes or modifications will not take effect immediately, so make sure that everything in the site is completely done before turning them on again.

    3.) Nothing really. Just make sure that the site is using the updated version of the theme. If you ran into troubles again, you can always come back in the forum.

    Thank you for your patience.

    Best regards,
    Ismael

    #1150849

    Thanks!

    #1150902

    Hi JannyPolak,

    Glad we could help :)

    If you need further assistance please let us know.
    Best regards,
    Victoria

Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.