Viewing 30 posts - 1 through 30 (of 34 total)
  • Author
    Posts
  • #559096

    Hi,
    suddenly (I have not changed anything in Enfold) the body background colour of my boxed layout is gone.
    I have used this in quick CSS as a workaround, and currently the colour is there because of that:
    html, body {
    background-color: #6699cc !important;
    }
    Although this works alright, it of course should not be required. perhaps someone can take a look at it.
    Site: hi-flyfoto.de
    Thanks for your help

    #559424

    Hi mleonhard!

    Please remove the custom css temporarily then try disabling you plugins and clearing your cache.

    Also ensure that you are using the latest version of Enfold.

    If the above doesn’t work, please provide us with temporary admin access to your website so we can take a closer look.

    Cheers!
    Dake

    #559431

    Hi Dake
    Yes, I had tried that already to no avail.
    Here is the login.
    Thanks for your help
    Michael

    #559471

    Hi!

    Please try

    html *, body * {
    background-color: #6699cc !important;
    }

    and let us know if that fixes the issue for you

    Cheers!
    Basilis

    #559484

    Hi Basilis,
    I did and it has (see initial post)
    However it is a workaround for the non-functioning native function,
    and not the way Enfold is supposed to work. That is the only reason for the thread.
    Thanks
    Michael

    #559915

    Hi Michael!

    I see what you are trying to tell us. The reason you are required to add extra function for a non-functioning native is because in Enfold options your background color is set to white so you are required to add extra css to override it.

    Please goto Enfold Options > General Styling > Main Content > Main Content background color
    and set it to your liking and then you can remove the extra css for it. :)

    Regards,
    Vinay

    #559919

    Hi Vinay,
    perhaps I wasn’t quite clear enough.
    Initially, I had set the background colour the way you describe it, and it worked fine.
    Then suddenly the background changed to white, although it was still set to #6699cc
    in Enfold Options > General Styling > Main Content > Main Content background color.
    As a workaround (!) I have used this in quick CSS:
    html, body {
    background-color: #6699cc !important;
    }
    Thanks for your effort
    Michael

    #560089

    Hi!

    I see what you mean.

    At this point have you tried reinstalling the Enfold theme via ftp to see if the background color functionality returns?

    Best regards,
    Dake

    #560407

    That seemed a little drastic to me, and apparantly for a good reason
    I have tried this: renamed the enfold folder and uploaded an new one via ftp, imported the previously exported enfold settings.
    Now the whole formatting of the site is shot! Renaming the folders so the original folder is current again does not make a difference
    As you might understand, I am not quite happy!

      So please give me some useful advice urgently.

    Thank you
    Michael

    PS I have successfully imported a database backup of some days ago (1st Jan), but that does not bring back the layout.
    Since following the last advice killed the layout of my site, I would appreciate some very fast support.

    PPS
    Alright, I have solved the layout issue myself by creating a new enfold.css in the dynamic_avia folder.
    However the initial issue with the background colour still persists

    • This reply was modified 4 years ago by  mleonhard.
    #560995

    Hi!

    You didn’t set the Enfold > Frontpage Settings? Why is that? I removed the background css code, purge the cache and the background is still set to #6699cc.

    Regards,
    Ismael

    #561111

    Hi Ismael,
    I had defined the frontpage in the WP settings and that seemed to work fine.
    In any case, also if I set the frontpage in Enfold, remove the CSS code and set the background colour to #6699cc
    in Enfold, I find that the background is white and not #6699cc.
    So I can still set the background colour only with quick CSS and not the Body Background Color setting in Enfold.
    Thanks
    Michael

    #561915

    Hi!

    does this happen when you activate a default WordPress theme as well?

    Regards,
    Andy

    #561919

    Hi Andy,
    haven’t tried that, but I guess not, because the background colour is defined in the Enfold theme.
    the live preview of another theme shows white background colour
    Regards
    Michael

    #561941

    Hey!

    check it out, when setting background color in a default WordPress theme and let us know about your results.

    Regards,
    Andy

    #561943

    Hey!

    I really like the drones they are so cool. I noticed you are using multiple caching plugins. It is not recommended to use multiple cache plugins as it will cause a conflict and wont allow you to view the css or js change .until the cache expires.

    I have disabled both the caching plugins you can enable any one of them after the issue is sorted.

    Your issue was that when you change the background color in enfold options it wont work right?

    I see that now is it working correctly after disabling the caching plugin. in future when you make any css changes to view it you need to disable cache or empty cache.

    However i see that your layout is changed and when you change the main color it is changing the boxed layout color. may i know what exactly you change in layout?

    for the time being i am using a quick css to enable background color.

    Regards,
    Vinay

    #561953

    Hi Vinay,
    thanks for the compliment.
    Only W3 Total Cache was active, was it not? I had WP Super Cache installed but inactive because
    YASR, which I tried out, only works well with Super Cache.
    When I was making changes, of course I cleared the cache to see the results.
    Now, with W3T deactivated and the quick CSS removed, I only see white background on my PC, ipad and different browsers.
    So for me the issue persists, background colour only with the code in quick CSS.
    Regards
    Michael

    #561973

    Hi!

    activate your caching plugin again, go into plugin’s settings and choose to switch off caching. Afterwards clear browser cache and hard refresh a few times. Otherwise caching goes on, although plugin is deactivated.

    Cheers!
    Andy

    #561975

    @ Andy
    Setting the colour in Twenty Fifteen works

    #561980

    Hey!

    there might be some corrupted files, so please delete all theme files completely via FTP, before installing a fresh copy from your themeforest account: http://kriesi.at/documentation/enfold/install-enfold-over-ftp/

    Best regards,
    Andy

    #561994

    Hi Andy,
    activating the cache etc. makes no difference, also after clearing really everything from the browser with ccleaner.

    I had already tried a new ftp installation of enfold (renamed the original enfold folder rather than deleting it).
    In fact now I have two enfold folders (enfold and enfold_new) I can activate both in WP and there is no difference
    Regards
    Michael

    #562004

    Hi!

    Make sure that the wp-content/uploads/dynamic_avia/ folder is writable. Enfold will use this folder to create the dynamic css file (called enfold.css). It contains the styling settings which you configured on the theme option page and if Enfold can’t write or create it you won’t notice any changes even if you save the options.
    Check the permissions on your wp-content>uploads>dynamic_avai folder. Change the folder and contents to 755 or 775. It shouldn’t need 777 but I’ve run into a few servers where that was needed for some reason.

    Regards,
    Andy

    • This reply was modified 4 years ago by  Andy.
    #562087

    Hi Andy
    the folder is 777, so no problem there. In fact, when I uploaded the new enfold via FTP
    I had created a new enfold.css

    #562728

    Hi!

    I did change the background images and it works fine but background color is not getting picked up. This is possible because of some corrupt file.

    If you have 2 folders enfold and enfold_new it is going to pick enfold so please delete the theme folder and re-upload it or rename the current folder to enfold_old and then upload all new files to enfold. Please make sure all the new files that you upload is inside folder name enfold.

    Best regards,
    Vinay

    #563042

    Hi Vinay,

    Please make sure all the new files that you upload is inside folder name enfold.

    That is how I tested the new enfold with FTP upload. I did not delete the folder, but renamed to enfold_old.
    After I saw that it did not solve the issue, I renamed the folders again:
    newly uploaded enfold-> enfold_new, original enfold->enfold
    Regards
    Michael

    #563174

    Hey!

    I see that you have activated W3 Caching plugin again. It won’t work when caching is enabled. Are we allowed to clear cache and deactivate all your plugins for testing purposes? For thousand of customers it just works fine, so something must cause it especially on your end.

    Regards,
    Andy

    #563181

    Hi Andy,
    if you like, you can do that quickly.
    I have tried that already a couple of times, and since it did not solve anything I activated th plugins again.
    I mean, the background colour did work normally. Just suddenly it changed for no apparant reason,
    and since there is a good workaround it is not the end of the world, just strange.
    Regards
    Michael

    PS let me know when you are finished, because I have to re-activate jetpack afterwards

    • This reply was modified 4 years ago by  mleonhard.
    #563852

    Hey!

    I tried to login using credentials from here, but it does not work for me. Can you check please? we need to be able to login. Let us know when you are ready.

    Regards,
    Andy

    #563855

    Hi Andy,
    there was an issue with the provider and it apparently messed up the login.
    It now works again.

    #564881

    Hi!

    I’m not sure the issue with the provider is sorted out completely I cannot see any wordpress options when i login to the backend.

    Cheers!
    Vinay

    #564891

    Hi Vinay,
    don’t know why, but the test account lost the admin status.
    It is ok now
    Regards
    Michael

Viewing 30 posts - 1 through 30 (of 34 total)

The topic ‘Body background colour gon’ is closed to new replies.