Tagged: 

Viewing 27 posts - 1 through 27 (of 27 total)
  • Author
    Posts
  • #960951

    Hi There,

    We have a blog with some 65.000 posts. Whenever we want to update Enfold by uploading it parallel (/enfold-new/) to the old version and then just rename the two directories, we couldn’t open the website anymore. The database was loading and loading.

    Now we are scared to just click on the update button.

    What do you suggest?

    Thanks

    #961654

    Hey elbnetz,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look? Do you mean you have to folders with Enfold?

    Best regards,
    Victoria

    #961992
    This reply has been marked as private.
    #962758

    Hi Thorsten,

    Have you tried doing it via FTP? In this case it might be better to update the theme via FTP in one of the folders and delete the other one.

    Best regards,
    Victoria

    #962996

    Yes we have tried the update via FTP. That causes the Problem.
    We even have the problem, when we click on “live preview”

    Is there change i the database handling since version 4.2.3?

    Please help.
    Thanks

    #964069

    Any News on this?
    We need your help!
    Is there anything you have changed with the database between this versions or anything else, which makes the problems?

    Wen need to know what we can do to keep the theme up to date.

    Thanks.

    #964114

    I have this problem as well. Updated to 4.4 from 4.2.3 and the site wouldn’t load anymore, not even wp-admin.

    The error_log gives this error:
    PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 20480 bytes) in ....../wp-includes/post.php on line 1939
    And this one:
    ‘PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 1179648 bytes) in …../wp-includes/cache.php on line 652’

    Tried increasing the allowed memory but it didn’t make any difference.

    Fortunately I had the previous version still, so reverting back to the older version of the theme brought the site back.

    What could be wrong? The site in question has a lot of posts as well, over 50,000, just like the OP’s. Probably something to do with that?

    • This reply was modified 6 years, 1 month ago by fisherman.
    #964202

    Hi,

    How did you increase the memory limit? Please ask your hosting provider to do it to make sure that it is actually increased.

    Best regards,
    Ismael

    #964207

    Is there a recommended memory limit?

    #964293

    Hi,

    We usually recommend at least 256M or higher. Some servers do not allow a manual override to the limit so you may need to contact your hosting provider.

    Best regards,
    Ismael

    #964319

    Setting the memory limit higher didn’t work. It just never loads and times out after a long time.

    #964676

    Same results here: Increased to 256M with no positive result.
    Hey guys, something seems to be wrong with version 4.4 and big databases. Can you please investigate?
    Stay with 4.3.x is not an option, as there are problems with WooCommerce

    Thanks

    #965298

    Hi guys,
    Are you looking into this problem?
    Thanks
    Tom

    #965613

    Hi,

    The best approach for you is to create a staging server so you can try all new things on a staging site then perform the same on the live site.

    Is it possible for you to create a staging site and try to update the site via FTP by deleting the enfold folder and uploading a latest version?

    Please check the documentation for more info https://kriesi.at/documentation/enfold/how-to-install-enfold-theme/

    Best regards,
    Vinay

    #966397

    Hi Vinay,

    That is not an option for the moment: The website is some 70 GB in size.
    You don’t just create a staging site just to test that the theme doesn’t work.
    What about telling us what has changed with version 4.4 regarding the database?
    Or are the additional functions need so much additional memory??

    Please, we desperately need a solution here!

    Thanks.

    #966648

    @Vinay
    I tried your suggestion, so instead of just updating through wp-admin, update the site via FTP by deleting the enfold folder.
    It didn’t work, same error as before.
    And I don’t see how a staging server would help in this case. If the theme update doesn’t work for some reason, only your programmers can help.
    Please fix this soon, thanks!
    Tom

    #967466

    Hi fisherman and elbnetz,

    Which version of php are you running?

    Best regards,
    Victoria

    #967472

    Hi, I’m running php 7.1.
    Tom

    #967690

    We are running php 7.0.27

    #967699
    This reply has been marked as private.
    #969894

    Hi,

    Thanks for the update.

    Enable the error logs and then activate the latest version of the theme. Post the content of the error logs on pastebin.com.

    // https://codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG_LOG

    In the wp-config.php file, add this code.

     // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings 
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    
    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define( 'SCRIPT_DEBUG', true );

    Best regards,
    Ismael

    #970003

    We’ve did as suggested, but don’t get a log file.

    • This reply was modified 6 years, 1 month ago by elbnetz.
    #970008

    Now we received the following error message:

    Warning: Error while sending QUERY packet. PID=31805 in /var/www/reifenpresse/wp-includes/wp-db.php on line 1924
    Fehler beim Aufbau einer Datenbankverbindung

    That was after updating to Yoast Version 7.6.1
    After disabling database was back again.

    • This reply was modified 6 years, 1 month ago by elbnetz.
    #971223

    I did the debog log thing you asked for, but it just gave the memory error I already gave you guys, nothing else
    [11-Jun-2018 13:01:10 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 20480 bytes) in ................/wp-includes/post.php on line 1939
    Increasing memory doesn’t help.

    #971481

    Hi,

    @elbnetz: According to the forums, you have to increase the database’s “max_allowed_packet” value. Did you search for that particular entry in the database? The id is “31805”. What’s inside that entry?

    // https://stackoverflow.com/questions/30753674/error-while-sending-query-packet
    // https://dev.mysql.com/doc/refman/8.0/en/packet-too-large.html

    Please contact your hosting provider for more info. I’m sure they’ll be able to help you tweak this database option.

    Best regards,
    Ismael

    #974134

    Hi, are you guys working on this? It would be a shame if Enfold wouldn’t work on large websites.
    Tom

    #974554

    Hi,

    @fisherman: Please create your own thread with the site url and login credentials. How did you increase the memory limit? On some servers, you can’t manually override the limit so you have to ask your hosting provider to increase it.

    Best regards,
    Ismael

Viewing 27 posts - 1 through 27 (of 27 total)
  • You must be logged in to reply to this topic.