Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1195542

    Hi,

    I use WP Engine to host my websites. For at least the last few weeks (maybe longer) the server has been running out of memory which has been crashing my server or forcing it to reboot. I’ve been told that the issue has to do with autoloaded data within the wp_options table. Almost all my websites that use Enfold has this issue with the data stored in this table is way too large. For example here are four websites that WP Engine sent to me that are problematic:

    Install=website1 Table=wp_options Data=5079325
    Install=website2 Table=wp_options Data=1656772
    Install=website3 Table=wp_options Data=3490285
    Install=website4 Table=wp_options Data=2639425

    They stated that at most autoloaded data should be at 800k max. They also stated that the top items in each of these cases look to contain the string “aviaAsset”.

    I’ve been at WP Engine for almost a year and this hasn’t been a problem until the last few weeks. Now I’ve been adding many websites to my WP Engine server over time to be fair. I understand that more websites means more memory so it could be that within the last few weeks I finally got to a point where all the websites together are using too much memory and Enfold may have been using this much memory since the beginning.

    My question then is has Enfold made any adjustments in how it stores autoloaded data in the last few patches or has Enfold always stored this large amount of autoloaded data within the wp_options table? In either case how can I stop this all this data from being stored? I need to shrink this data to get it to the recommended value of 800k. Also, is the autoloaded data being created because of the “performance” options I’m selecting within the Enfold theme? Is this much data being stored anticipated or there another problem?

    Any suggestions or insight will be greatly appreciated. Thank you!

    #1198916

    Hi,

    Just checking to see if anyone has any ideas.

    #1198998

    Hi!

    Thank you for the inquiry.

    To temporarily fix the issue, you can disable the theme’s Performance > File Compression settings to keep it from storing data from merged files in the database. You can then use a plugin like Autoptimize or BWP Minify in place of the default compression.

    If you want to keep using the default compression, you can also try the fix that we provided in the following thread.

    // https://kriesi.at/support/topic/enfold-keeps-showing-critical-error-because-of-head-script-autoload/#post-1198997

    Best regards,
    Ismael

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.